[packages] collectd: remove further instances of -Werror to fix compilation with gcc 4.6 (#10962)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@30533 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
fc8c6d10f3
commit
3cf8d6789f
@ -1,5 +1,5 @@
|
||||
#
|
||||
# Copyright (C) 2006-2011 OpenWrt.org
|
||||
# Copyright (C) 2006-2012 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=collectd
|
||||
PKG_VERSION:=4.10.2
|
||||
PKG_RELEASE:=5
|
||||
PKG_RELEASE:=6
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=http://collectd.org/files/
|
||||
|
@ -20,3 +20,47 @@
|
||||
AM_CPPFLAGS = -DPREFIX='"${prefix}"' \
|
||||
-DCONFIGFILE='"${sysconfdir}/${PACKAGE_NAME}.conf"' \
|
||||
-DLOCALSTATEDIR='"${localstatedir}"' \
|
||||
--- a/src/libcollectdclient/Makefile.am
|
||||
+++ b/src/libcollectdclient/Makefile.am
|
||||
@@ -1,7 +1,7 @@
|
||||
AUTOMAKE_OPTIONS = foreign no-dependencies
|
||||
|
||||
if COMPILER_IS_GCC
|
||||
-AM_CFLAGS = -Wall -Werror
|
||||
+AM_CFLAGS = -Wall
|
||||
endif
|
||||
|
||||
pkginclude_HEADERS = client.h lcc_features.h
|
||||
--- a/src/libcollectdclient/Makefile.in
|
||||
+++ b/src/libcollectdclient/Makefile.in
|
||||
@@ -329,7 +329,7 @@ top_build_prefix = @top_build_prefix@
|
||||
top_builddir = @top_builddir@
|
||||
top_srcdir = @top_srcdir@
|
||||
AUTOMAKE_OPTIONS = foreign no-dependencies
|
||||
-@COMPILER_IS_GCC_TRUE@AM_CFLAGS = -Wall -Werror
|
||||
+@COMPILER_IS_GCC_TRUE@AM_CFLAGS = -Wall
|
||||
pkginclude_HEADERS = client.h lcc_features.h
|
||||
lib_LTLIBRARIES = libcollectdclient.la
|
||||
nodist_pkgconfig_DATA = libcollectdclient.pc
|
||||
--- a/src/owniptc/Makefile.am
|
||||
+++ b/src/owniptc/Makefile.am
|
||||
@@ -3,7 +3,7 @@ AUTOMAKE_OPTIONS = foreign no-dependenci
|
||||
EXTRA_DIST = libiptc.c README.collectd
|
||||
|
||||
if COMPILER_IS_GCC
|
||||
-AM_CFLAGS = -Wall -Werror
|
||||
+AM_CFLAGS = -Wall
|
||||
endif
|
||||
|
||||
noinst_LTLIBRARIES = libiptc.la
|
||||
--- a/src/owniptc/Makefile.in
|
||||
+++ b/src/owniptc/Makefile.in
|
||||
@@ -298,7 +298,7 @@ top_builddir = @top_builddir@
|
||||
top_srcdir = @top_srcdir@
|
||||
AUTOMAKE_OPTIONS = foreign no-dependencies
|
||||
EXTRA_DIST = libiptc.c README.collectd
|
||||
-@COMPILER_IS_GCC_TRUE@AM_CFLAGS = -Wall -Werror
|
||||
+@COMPILER_IS_GCC_TRUE@AM_CFLAGS = -Wall
|
||||
noinst_LTLIBRARIES = libiptc.la
|
||||
libiptc_la_SOURCES = libip4tc.c libip6tc.c \
|
||||
ipt_kernel_headers.h libip6tc.h libiptc.h linux_list.h \
|
||||
|
Loading…
x
Reference in New Issue
Block a user