upgrade expat to 2.0.1
git-svn-id: svn://svn.openwrt.org/openwrt/packages@14670 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
47b6b9ba70
commit
3dbf5c192e
@ -9,11 +9,11 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=expat
|
||||
PKG_VERSION:=1.95.8
|
||||
PKG_VERSION:=2.0.1
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_MD5SUM:=aff487543845a82fe262e6e2922b4c8e
|
||||
PKG_MD5SUM:=ee8b492592568805593f81f8cdf2a04c
|
||||
PKG_SOURCE_URL:=@SF/expat
|
||||
|
||||
PKG_FIXUP = libtool
|
||||
|
@ -1,45 +0,0 @@
|
||||
diff -ruN expat-1.95.8-orig/Makefile.in expat-1.95.8-1/Makefile.in
|
||||
--- expat-1.95.8-orig/Makefile.in 2004-05-07 22:00:48.000000000 +0200
|
||||
+++ expat-1.95.8-1/Makefile.in 2005-04-04 22:53:09.000000000 +0200
|
||||
@@ -34,6 +34,8 @@
|
||||
|
||||
top_builddir = .
|
||||
|
||||
+DESTDIR =
|
||||
+
|
||||
|
||||
INSTALL = @INSTALL@
|
||||
INSTALL_PROGRAM = @INSTALL_PROGRAM@
|
||||
@@ -73,22 +75,22 @@
|
||||
tests/runtests
|
||||
|
||||
install: xmlwf/xmlwf installlib
|
||||
- $(mkinstalldirs) $(bindir) $(man1dir)
|
||||
- $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) xmlwf/xmlwf $(bindir)/xmlwf
|
||||
- $(INSTALL_DATA) $(MANFILE) $(man1dir)
|
||||
+ $(mkinstalldirs) $(DESTDIR)$(bindir) $(DESTDIR)$(man1dir)
|
||||
+ $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) xmlwf/xmlwf $(DESTDIR)$(bindir)/xmlwf
|
||||
+ $(INSTALL_DATA) $(MANFILE) $(DESTDIR)$(man1dir)
|
||||
|
||||
installlib: $(LIBRARY) $(APIHEADER)
|
||||
- $(mkinstalldirs) $(libdir) $(includedir)
|
||||
- $(LIBTOOL) --mode=install $(INSTALL) $(LIBRARY) $(libdir)/$(LIBRARY)
|
||||
- $(INSTALL_DATA) $(APIHEADER) $(includedir)
|
||||
+ $(mkinstalldirs) $(DESTDIR)$(libdir) $(DESTDIR)$(includedir)
|
||||
+ $(LIBTOOL) --mode=install $(INSTALL) $(LIBRARY) $(DESTDIR)$(libdir)/$(LIBRARY)
|
||||
+ $(INSTALL_DATA) $(APIHEADER) $(DESTDIR)$(includedir)
|
||||
|
||||
uninstall: uninstalllib
|
||||
- $(LIBTOOL) --mode=uninstall rm -f $(bindir)/xmlwf
|
||||
- rm -f $(man1dir)/xmlwf.1
|
||||
+ $(LIBTOOL) --mode=uninstall rm -f $(DESTDIR)$(bindir)/xmlwf
|
||||
+ rm -f $(DESTDIR)$(man1dir)/xmlwf.1
|
||||
|
||||
uninstalllib:
|
||||
- $(LIBTOOL) --mode=uninstall rm -f $(libdir)/$(LIBRARY)
|
||||
- rm -f $(includedir)/$(APIHEADER)
|
||||
+ $(LIBTOOL) --mode=uninstall rm -f $(DESTDIR)$(libdir)/$(LIBRARY)
|
||||
+ rm -f $(DESTDIR)$(includedir)/$(APIHEADER)
|
||||
|
||||
# for VPATH builds (invoked by configure)
|
||||
mkdir-init:
|
@ -1,21 +0,0 @@
|
||||
diff -urN expat-1.95.8.orig/conftools/config.sub expat-1.95.8/conftools/config.sub
|
||||
--- expat-1.95.8.orig/conftools/config.sub 2002-06-02 00:29:30.000000000 +0200
|
||||
+++ expat-1.95.8/conftools/config.sub 2008-04-14 18:27:28.000000000 +0200
|
||||
@@ -251,7 +251,7 @@
|
||||
| a29k \
|
||||
| alpha | alphaev[4-8] | alphaev56 | alphaev6[78] | alphapca5[67] \
|
||||
| alpha64 | alpha64ev[4-8] | alpha64ev56 | alpha64ev6[78] | alpha64pca5[67] \
|
||||
- | arc | arm | arm[bl]e | arme[lb] | armv[2345] | armv[345][lb] | avr \
|
||||
+ | arc | arm | arm[bl]e | arme[lb] | armv[2345] | armv[345][lb] | avr | avr32 \
|
||||
| c4x | clipper \
|
||||
| d10v | d30v | dsp16xx \
|
||||
| fr30 \
|
||||
@@ -305,7 +305,7 @@
|
||||
| alpha64-* | alpha64ev[4-8]-* | alpha64ev56-* | alpha64ev6[78]-* \
|
||||
| alphapca5[67]-* | alpha64pca5[67]-* | arc-* \
|
||||
| arm-* | armbe-* | armle-* | armv*-* \
|
||||
- | avr-* \
|
||||
+ | avr-* | avr32-* \
|
||||
| bs2000-* \
|
||||
| c[123]* | c30-* | [cjt]90-* | c54x-* \
|
||||
| clipper-* | cydra-* \
|
Loading…
x
Reference in New Issue
Block a user