oprofile: update to 0.9.7

git-svn-id: svn://svn.openwrt.org/openwrt/packages@31039 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
nbd 2012-03-20 01:00:43 +00:00
parent e2c412babf
commit 3df04c2231
4 changed files with 24 additions and 94 deletions

View File

@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=oprofile
PKG_VERSION:=0.9.4
PKG_RELEASE:=2
PKG_VERSION:=0.9.7
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/oprofile/
PKG_MD5SUM:=82b059379895cf125261d7d773465915
PKG_MD5SUM:=8b5d1d9b65f84420bcc3234777ad3be3
PKG_BUILD_DEPENDS:=binutils
PKG_FIXUP:=libtool
@ -80,7 +80,7 @@ define Package/oprofile/install
$(INSTALL_DIR) $(1)/usr/share/oprofile
$(CP) \
$(PKG_INSTALL_DIR)/usr/share/oprofile/stl.pat \
$(PKG_INSTALL_DIR)/usr/share/oprofile/$(LINUX_KARCH) \
$(PKG_INSTALL_DIR)/usr/share/oprofile/$(patsubst x86,i386,$(LINUX_KARCH)) \
$(1)/usr/share/oprofile/
endef

View File

@ -1,8 +1,6 @@
diff --git a/utils/opcontrol b/utils/opcontrol
index ce53010..60a7e64 100644
--- a/utils/opcontrol
+++ b/utils/opcontrol
@@ -170,7 +170,7 @@ load_module_26()
@@ -248,7 +248,7 @@ load_module_26()
{
grep oprofilefs /proc/filesystems >/dev/null
if test "$?" -ne 0; then
@ -11,7 +9,7 @@ index ce53010..60a7e64 100644
if test "$?" != "0"; then
# couldn't load the module
return
@@ -200,7 +200,7 @@ load_module_24()
@@ -278,7 +278,7 @@ load_module_24()
{
grep oprof /proc/devices >/dev/null
if test "$?" -ne 0; then

View File

@ -1,13 +1,12 @@
diff -urN oprofile-0.9.4/daemon/Makefile.am oprofile-0.9.4.new/daemon/Makefile.am
--- oprofile-0.9.4/daemon/Makefile.am 2008-04-28 23:23:24.000000000 +0200
+++ oprofile-0.9.4.new/daemon/Makefile.am 2009-07-26 15:23:23.000000000 +0200
--- a/daemon/Makefile.am
+++ b/daemon/Makefile.am
@@ -1,4 +1,4 @@
-SUBDIRS = liblegacy .
+SUBDIRS = .
oprofiled_SOURCES = \
init.c \
@@ -42,7 +42,6 @@
@@ -49,7 +49,6 @@ AM_CFLAGS = @OP_CFLAGS@ -fno-omit-frame-
bin_PROGRAMS = oprofiled
oprofiled_LDADD = \
@ -15,28 +14,27 @@ diff -urN oprofile-0.9.4/daemon/Makefile.am oprofile-0.9.4.new/daemon/Makefile.a
../libabi/libabi.a \
../libdb/libodb.a \
../libop/libop.a \
diff -urN oprofile-0.9.4/daemon/Makefile.in oprofile-0.9.4.new/daemon/Makefile.in
--- oprofile-0.9.4/daemon/Makefile.in 2008-07-18 01:14:44.000000000 +0200
+++ oprofile-0.9.4.new/daemon/Makefile.in 2009-07-26 15:23:14.000000000 +0200
@@ -68,7 +68,7 @@
opd_events.$(OBJEXT) opd_mangling.$(OBJEXT) \
opd_perfmon.$(OBJEXT) opd_anon.$(OBJEXT) opd_spu.$(OBJEXT)
--- a/daemon/Makefile.in
+++ b/daemon/Makefile.in
@@ -70,7 +70,7 @@ am_oprofiled_OBJECTS = init.$(OBJEXT) op
opd_extended.$(OBJEXT) opd_ibs.$(OBJEXT) \
opd_ibs_trans.$(OBJEXT)
oprofiled_OBJECTS = $(am_oprofiled_OBJECTS)
-oprofiled_DEPENDENCIES = liblegacy/liblegacy.a ../libabi/libabi.a \
+oprofiled_DEPENDENCIES = ../libabi/libabi.a \
../libdb/libodb.a ../libop/libop.a ../libutil/libutil.a
DEFAULT_INCLUDES = -I. -I$(srcdir) -I$(top_builddir)
DEFAULT_INCLUDES = -I.@am__isrc@ -I$(top_builddir)
depcomp = $(SHELL) $(top_srcdir)/depcomp
@@ -240,7 +240,7 @@
sysconfdir = @sysconfdir@
target_alias = @target_alias@
@@ -285,7 +285,7 @@ top_build_prefix = @top_build_prefix@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
topdir = @topdir@
-SUBDIRS = liblegacy .
+SUBDIRS = .
oprofiled_SOURCES = \
init.c \
oprofiled.c \
@@ -279,7 +279,6 @@
@@ -331,7 +331,6 @@ AM_CPPFLAGS = \
# -fno-omit-frame-pointer needed for daemon build: see ChangeLog-2004 02-23
AM_CFLAGS = @OP_CFLAGS@ -fno-omit-frame-pointer
oprofiled_LDADD = \
@ -44,18 +42,17 @@ diff -urN oprofile-0.9.4/daemon/Makefile.in oprofile-0.9.4.new/daemon/Makefile.i
../libabi/libabi.a \
../libdb/libodb.a \
../libop/libop.a \
diff -urN oprofile-0.9.4/daemon/oprofiled.c oprofile-0.9.4.new/daemon/oprofiled.c
--- oprofile-0.9.4/daemon/oprofiled.c 2008-04-28 23:23:23.000000000 +0200
+++ oprofile-0.9.4.new/daemon/oprofiled.c 2009-07-26 15:25:25.000000000 +0200
@@ -73,7 +73,6 @@
static char * events;
--- a/daemon/oprofiled.c
+++ b/daemon/oprofiled.c
@@ -77,7 +77,6 @@ static char * events;
static char * ext_feature;
static int showvers;
static struct oprofiled_ops * opd_ops;
-extern struct oprofiled_ops opd_24_ops;
extern struct oprofiled_ops opd_26_ops;
#define OPD_IMAGE_FILTER_HASH_SIZE 32
@@ -465,9 +464,6 @@
@@ -477,9 +476,6 @@ static void opd_options(int argc, char c
static struct oprofiled_ops * get_ops(void)
{
switch (op_get_interface()) {

View File

@ -1,65 +0,0 @@
diff -ruN oprofile-0.9.4.bak/events//Makefile.am oprofile-0.9.4/events//Makefile.am
--- oprofile-0.9.4.bak/events//Makefile.am 2008-02-22 17:17:48.000000000 +0100
+++ oprofile-0.9.4/events//Makefile.am 2011-02-22 18:04:40.058491002 +0100
@@ -4,15 +4,15 @@
alpha/ev67/events alpha/ev67/unit_masks \
alpha/ev6/events alpha/ev6/unit_masks \
alpha/pca56/events alpha/pca56/unit_masks \
- i386/athlon/events i386/athlon/unit_masks \
- i386/core_2/events i386/core_2/unit_masks \
- i386/p4/events i386/p4-ht/events \
- i386/p4-ht/unit_masks i386/p4/unit_masks \
- i386/pii/events i386/pii/unit_masks \
- i386/piii/events i386/piii/unit_masks \
- i386/ppro/events i386/ppro/unit_masks \
- i386/p6_mobile/events i386/p6_mobile/unit_masks \
- i386/core/events i386/core/unit_masks \
+ x86/athlon/events x86/athlon/unit_masks \
+ x86/core_2/events x86/core_2/unit_masks \
+ x86/p4/events x86/p4-ht/events \
+ x86/p4-ht/unit_masks x86/p4/unit_masks \
+ x86/pii/events x86/pii/unit_masks \
+ x86/piii/events x86/piii/unit_masks \
+ x86/ppro/events x86/ppro/unit_masks \
+ x86/p6_mobile/events x86/p6_mobile/unit_masks \
+ x86/core/events x86/core/unit_masks \
ia64/ia64/events ia64/ia64/unit_masks \
ia64/itanium2/events ia64/itanium2/unit_masks \
ia64/itanium/events ia64/itanium/unit_masks \
diff -ruN oprofile-0.9.4.bak/events//Makefile.in oprofile-0.9.4/events//Makefile.in
--- oprofile-0.9.4.bak/events//Makefile.in 2008-07-18 01:14:45.000000000 +0200
+++ oprofile-0.9.4/events//Makefile.in 2011-02-22 18:04:32.208491002 +0100
@@ -213,15 +213,15 @@
alpha/ev67/events alpha/ev67/unit_masks \
alpha/ev6/events alpha/ev6/unit_masks \
alpha/pca56/events alpha/pca56/unit_masks \
- i386/athlon/events i386/athlon/unit_masks \
- i386/core_2/events i386/core_2/unit_masks \
- i386/p4/events i386/p4-ht/events \
- i386/p4-ht/unit_masks i386/p4/unit_masks \
- i386/pii/events i386/pii/unit_masks \
- i386/piii/events i386/piii/unit_masks \
- i386/ppro/events i386/ppro/unit_masks \
- i386/p6_mobile/events i386/p6_mobile/unit_masks \
- i386/core/events i386/core/unit_masks \
+ x86/athlon/events x86/athlon/unit_masks \
+ x86/core_2/events x86/core_2/unit_masks \
+ x86/p4/events x86/p4-ht/events \
+ x86/p4-ht/unit_masks x86/p4/unit_masks \
+ x86/pii/events x86/pii/unit_masks \
+ x86/piii/events x86/piii/unit_masks \
+ x86/ppro/events x86/ppro/unit_masks \
+ x86/p6_mobile/events x86/p6_mobile/unit_masks \
+ x86/core/events x86/core/unit_masks \
ia64/ia64/events ia64/ia64/unit_masks \
ia64/itanium2/events ia64/itanium2/unit_masks \
ia64/itanium/events ia64/itanium/unit_masks \
@@ -310,7 +310,7 @@
distdir: $(DISTFILES)
- $(mkdir_p) $(distdir)/alpha/ev4 $(distdir)/alpha/ev5 $(distdir)/alpha/ev6 $(distdir)/alpha/ev67 $(distdir)/alpha/pca56 $(distdir)/arm/armv6 $(distdir)/arm/mpcore $(distdir)/arm/xscale1 $(distdir)/arm/xscale2 $(distdir)/avr32 $(distdir)/i386/athlon $(distdir)/i386/core $(distdir)/i386/core_2 $(distdir)/i386/p4 $(distdir)/i386/p4-ht $(distdir)/i386/p6_mobile $(distdir)/i386/pii $(distdir)/i386/piii $(distdir)/i386/ppro $(distdir)/ia64/ia64 $(distdir)/ia64/itanium $(distdir)/ia64/itanium2 $(distdir)/mips/20K $(distdir)/mips/24K $(distdir)/mips/25K $(distdir)/mips/34K $(distdir)/mips/5K $(distdir)/mips/r10000 $(distdir)/mips/r12000 $(distdir)/mips/rm7000 $(distdir)/mips/rm9000 $(distdir)/mips/sb1 $(distdir)/mips/vr5432 $(distdir)/mips/vr5500 $(distdir)/ppc/7450 $(distdir)/ppc/e300 $(distdir)/ppc/e500 $(distdir)/ppc/e500v2 $(distdir)/ppc64/970 $(distdir)/ppc64/970MP $(distdir)/ppc64/cell-be $(distdir)/ppc64/pa6t $(distdir)/ppc64/power4 $(distdir)/ppc64/power5 $(distdir)/ppc64/power5+ $(distdir)/ppc64/power5++ $(distdir)/ppc64/power6 $(distdir)/rtc $(distdir)/x86-64/family10 $(distdir)/x86-64/hammer
+ $(mkdir_p) $(distdir)/alpha/ev4 $(distdir)/alpha/ev5 $(distdir)/alpha/ev6 $(distdir)/alpha/ev67 $(distdir)/alpha/pca56 $(distdir)/arm/armv6 $(distdir)/arm/mpcore $(distdir)/arm/xscale1 $(distdir)/arm/xscale2 $(distdir)/avr32 $(distdir)/x86/athlon $(distdir)/x86/core $(distdir)/x86/core_2 $(distdir)/x86/p4 $(distdir)/x86/p4-ht $(distdir)/x86/p6_mobile $(distdir)/x86/pii $(distdir)/x86/piii $(distdir)/x86/ppro $(distdir)/ia64/ia64 $(distdir)/ia64/itanium $(distdir)/ia64/itanium2 $(distdir)/mips/20K $(distdir)/mips/24K $(distdir)/mips/25K $(distdir)/mips/34K $(distdir)/mips/5K $(distdir)/mips/r10000 $(distdir)/mips/r12000 $(distdir)/mips/rm7000 $(distdir)/mips/rm9000 $(distdir)/mips/sb1 $(distdir)/mips/vr5432 $(distdir)/mips/vr5500 $(distdir)/ppc/7450 $(distdir)/ppc/e300 $(distdir)/ppc/e500 $(distdir)/ppc/e500v2 $(distdir)/ppc64/970 $(distdir)/ppc64/970MP $(distdir)/ppc64/cell-be $(distdir)/ppc64/pa6t $(distdir)/ppc64/power4 $(distdir)/ppc64/power5 $(distdir)/ppc64/power5+ $(distdir)/ppc64/power5++ $(distdir)/ppc64/power6 $(distdir)/rtc $(distdir)/x86-64/family10 $(distdir)/x86-64/hammer
@srcdirstrip=`echo "$(srcdir)" | sed 's|.|.|g'`; \
topsrcdirstrip=`echo "$(top_srcdir)" | sed 's|.|.|g'`; \
list='$(DISTFILES)'; for file in $$list; do \