Update zabbix to 1.6
git-svn-id: svn://svn.openwrt.org/openwrt/packages@12815 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
f91b64f2c1
commit
3e7bac00b7
@ -9,9 +9,9 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=zabbix
|
PKG_NAME:=zabbix
|
||||||
PKG_VERSION:=1.3.2
|
PKG_VERSION:=1.6
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
PKG_MD5SUM:=698a07f4e53820e44ef4a72c7c191e92
|
PKG_MD5SUM:=39d4c871439b1b4f0429964b4abbfc45
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=@SF/zabbix
|
PKG_SOURCE_URL:=@SF/zabbix
|
||||||
|
13
admin/zabbix/patches/001-cross_compile.patch
Normal file
13
admin/zabbix/patches/001-cross_compile.patch
Normal file
@ -0,0 +1,13 @@
|
|||||||
|
diff -urN zabbix-1.6/configure zabbix-1.6.new/configure
|
||||||
|
--- zabbix-1.6/configure 2008-09-18 22:15:39.000000000 +0200
|
||||||
|
+++ zabbix-1.6.new/configure 2008-09-30 19:20:43.000000000 +0200
|
||||||
|
@@ -4826,8 +4826,7 @@
|
||||||
|
{ { echo "$as_me:$LINENO: error: cannot run test program while cross compiling
|
||||||
|
See \`config.log' for more details." >&5
|
||||||
|
echo "$as_me: error: cannot run test program while cross compiling
|
||||||
|
-See \`config.log' for more details." >&2;}
|
||||||
|
- { (exit 1); exit 1; }; }
|
||||||
|
+See \`config.log' for more details." >&2;} }
|
||||||
|
else
|
||||||
|
cat >conftest.$ac_ext <<_ACEOF
|
||||||
|
|
49
admin/zabbix/patches/002-uclibc_loadavg.patch
Normal file
49
admin/zabbix/patches/002-uclibc_loadavg.patch
Normal file
@ -0,0 +1,49 @@
|
|||||||
|
diff -urN zabbix-1.6/src/libs/zbxsysinfo/linux/cpu.c zabbix-1.6.new/src/libs/zbxsysinfo/linux/cpu.c
|
||||||
|
--- zabbix-1.6/src/libs/zbxsysinfo/linux/cpu.c 2008-09-18 22:15:26.000000000 +0200
|
||||||
|
+++ zabbix-1.6.new/src/libs/zbxsysinfo/linux/cpu.c 2008-09-30 19:32:54.000000000 +0200
|
||||||
|
@@ -22,6 +22,45 @@
|
||||||
|
#include "sysinfo.h"
|
||||||
|
#include "stats.h"
|
||||||
|
|
||||||
|
+
|
||||||
|
+/* uclibc and dietlibc do not have this junk -ReneR */
|
||||||
|
+#if defined (__UCLIBC__) || defined (__dietlibc__)
|
||||||
|
+static int getloadavg (double loadavg[], int nelem)
|
||||||
|
+{
|
||||||
|
+ int fd;
|
||||||
|
+
|
||||||
|
+ fd = open ("/proc/loadavg", O_RDONLY);
|
||||||
|
+ if (fd < 0)
|
||||||
|
+ return -1;
|
||||||
|
+ else
|
||||||
|
+ {
|
||||||
|
+ char buf[65], *p;
|
||||||
|
+ ssize_t nread;
|
||||||
|
+ int i;
|
||||||
|
+
|
||||||
|
+ nread = read (fd, buf, sizeof buf - 1);
|
||||||
|
+ close (fd);
|
||||||
|
+ if (nread <= 0)
|
||||||
|
+ return -1;
|
||||||
|
+ buf[nread - 1] = '\0';
|
||||||
|
+
|
||||||
|
+ if (nelem > 3)
|
||||||
|
+ nelem = 3;
|
||||||
|
+ p = buf;
|
||||||
|
+ for (i = 0; i < nelem; ++i)
|
||||||
|
+ {
|
||||||
|
+ char *endp;
|
||||||
|
+ loadavg[i] = strtod (p, &endp);
|
||||||
|
+ if (endp == p)
|
||||||
|
+ return -1;
|
||||||
|
+ p = endp;
|
||||||
|
+ }
|
||||||
|
+
|
||||||
|
+ return i;
|
||||||
|
+ }
|
||||||
|
+}
|
||||||
|
+#endif
|
||||||
|
+
|
||||||
|
int SYSTEM_CPU_NUM(const char *cmd, const char *param, unsigned flags, AGENT_RESULT *result)
|
||||||
|
{
|
||||||
|
char mode[128];
|
Loading…
x
Reference in New Issue
Block a user