[packages] update nfs-kernel-server and nfs-utils to v1.2.5

rename patches and remove 002-no_ttycom_h.patch - it not needed anymore


git-svn-id: svn://svn.openwrt.org/openwrt/packages@28743 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
tripolar 2011-11-03 23:25:15 +00:00
parent 71cb5d9710
commit 3f1e6d4f12
5 changed files with 54 additions and 64 deletions

View File

@ -7,9 +7,9 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=nfs-kernel-server
PKG_VERSION:=1.1.6
PKG_VERSION:=1.2.5
PKG_RELEASE:=1
PKG_MD5SUM:=b0d1b8ec5c8c081a340cfc77bb8670cd
PKG_MD5SUM:=8395ac770720b83c5c469f88306d7765
PKG_SOURCE_URL:=@SF/nfs
PKG_SOURCE:=nfs-utils-$(PKG_VERSION).tar.bz2
@ -73,6 +73,7 @@ TARGET_LDFLAGS += -Wl,-rpath-link=$(STAGING_DIR)/usr/lib $(LIBRPC)
CONFIGURE_ARGS += \
--disable-gss \
--disable-nfsv4 \
--disable-nfsv41 \
--enable-static \
--enable-shared
@ -88,6 +89,7 @@ HOST_CFLAGS += -Dlinux
HOST_CONFIGURE_ARGS += \
--disable-gss \
--disable-nfsv4 \
--disable-nfsv41 \
--without-tcp-wrappers
HOST_CONFIGURE_VARS += \

View File

@ -1,35 +0,0 @@
--- a/utils/mountd/cache.c
+++ b/utils/mountd/cache.c
@@ -142,6 +142,7 @@ void auth_unix_gid(FILE *f)
pw = getpwuid(uid);
if (!pw)
rv = -1;
+#ifndef __UCLIBC__
else {
rv = getgrouplist(pw->pw_name, pw->pw_gid, groups, &ngroups);
if (rv == -1 && ngroups >= 100) {
@@ -153,6 +154,7 @@ void auth_unix_gid(FILE *f)
groups, &ngroups);
}
}
+#endif /* __UCLIBC__ */
qword_printint(f, uid);
qword_printint(f, time(0)+30*60);
if (rv >= 0) {
--- a/support/nfs/svc_socket.c
+++ b/support/nfs/svc_socket.c
@@ -66,9 +66,13 @@ svc_socket (u_long number, int type, int
memset (&addr, 0, sizeof (addr));
addr.sin_family = AF_INET;
-
+#ifndef __UCLIBC__ /* neither getrpcbynumber() nor getrpcbynumber_r() is SuSv3 */
ret = getrpcbynumber_r (number, &rpcbuf, rpcdata, sizeof rpcdata,
&rpcp);
+#else
+ rpcp = getrpcbynumber (number);
+ ret = 0;
+#endif
if (ret == 0 && rpcp != NULL)
{
/* First try name. */

View File

@ -1,26 +0,0 @@
--- a/tools/rpcgen/rpc_main.c
+++ b/tools/rpcgen/rpc_main.c
@@ -545,13 +545,6 @@ s_output(int argc, char **argv, char *in
timerflag = 1;
}
-#ifndef linux
- if( !tirpcflag && inetdflag )
- f_print(fout, "#include <sys/ttycom.h>/* TIOCNOTTY */\n");
-#else
- if( !tirpcflag )
- f_print(fout, "#include <sys/ttycom.h>/* TIOCNOTTY */\n");
-#endif
if( Cflag && (inetdflag || pmflag ) ) {
f_print(fout, "#ifdef __cplusplus\n");
f_print(fout, "#include <sysent.h> /* getdtablesize, open */\n");
--- a/tools/rpcgen/rpc_svcout.c
+++ b/tools/rpcgen/rpc_svcout.c
@@ -788,7 +788,6 @@ write_rpc_svc_fg(char *infile, char *sp)
else {
f_print(fout, "%si = open(\"/dev/tty\", 2);\n", sp);
f_print(fout, "%sif (i >= 0) {\n", sp);
- f_print(fout, "%s\t(void) ioctl(i, TIOCNOTTY, (char *)NULL);\n", sp);;
f_print(fout, "%s\t(void) close(i);\n", sp);
f_print(fout, "%s}\n", sp);
}

View File

@ -0,0 +1,49 @@
--- a/support/include/sockaddr.h
+++ b/support/include/sockaddr.h
@@ -20,7 +20,10 @@
#ifndef NFS_UTILS_SOCKADDR_H
#define NFS_UTILS_SOCKADDR_H
+/* uClibc doesn't have/need libio.h */
+#ifndef __UCLIBC__
#include <libio.h>
+#endif
#include <stdbool.h>
#include <sys/socket.h>
#include <netinet/in.h>
--- a/support/nfs/svc_socket.c
+++ b/support/nfs/svc_socket.c
@@ -40,10 +40,13 @@ int getservport(u_long number, const cha
char rpcdata[1024], servdata[1024];
struct rpcent rpcbuf, *rpcp;
struct servent servbuf, *servp = NULL;
- int ret;
-
+ int ret=0;
+#ifndef __UCLIBC__
ret = getrpcbynumber_r(number, &rpcbuf, rpcdata, sizeof rpcdata,
&rpcp);
+#else
+ rpcp = getrpcbynumber (number);
+#endif
if (ret == 0 && rpcp != NULL) {
/* First try name. */
ret = getservbyname_r(rpcp->r_name, proto, &servbuf, servdata,
--- a/utils/mountd/cache.c
+++ b/utils/mountd/cache.c
@@ -162,6 +162,7 @@ static void auth_unix_gid(FILE *f)
pw = getpwuid(uid);
if (!pw)
rv = -1;
+#ifndef __UCLIBC__
else {
rv = getgrouplist(pw->pw_name, pw->pw_gid, groups, &ngroups);
if (rv == -1 && ngroups >= groups_len) {
@@ -176,6 +177,7 @@ static void auth_unix_gid(FILE *f)
}
}
}
+#endif
qword_printuint(f, uid);
qword_printuint(f, time(0) + DEFAULT_TTL);
if (rv >= 0) {

View File

@ -1,6 +1,6 @@
--- a/tools/rpcgen/rpc_cout.c
+++ b/tools/rpcgen/rpc_cout.c
@@ -38,7 +38,6 @@ static char sccsid[] = "@(#)rpc_cout.c 1
@@ -36,7 +36,6 @@ static char sccsid[] = "@(#)rpc_cout.c 1
#include <stdio.h>
#include <string.h>
#include <stdlib.h>