Port deco to -ng
git-svn-id: svn://svn.openwrt.org/openwrt/packages@4368 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
97e3a7d938
commit
3f86f89410
49
utils/deco/Makefile
Normal file
49
utils/deco/Makefile
Normal file
@ -0,0 +1,49 @@
|
||||
# Copyright (C) 2006 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
# $Id$
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=deco
|
||||
PKG_VERSION:=39
|
||||
PKG_RELEASE:=1
|
||||
PKG_MD5SUM:=f77f60e8be0cae1f814cba1ef61bf4d0
|
||||
|
||||
PKG_SOURCE_URL:=@SF/deco
|
||||
PKG_SOURCE:=$(PKG_NAME)$(PKG_VERSION).tgz
|
||||
|
||||
PKG_CAT:=zcat
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)$(PKG_VERSION)
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/deco
|
||||
SECTION:=utils
|
||||
CATEGORY:=Utilities
|
||||
DEPENDS:=libncurses
|
||||
TITLE:=Text-based, full featured file manager
|
||||
DESCRIPTION:=A clone of Norton Commander for Unix. Text-based, full featured\\\
|
||||
file manager.\\\
|
||||
URL:=http://deco.sourceforge.net/
|
||||
endef
|
||||
|
||||
define Build/Configure
|
||||
$(call Build/Configure/Default)
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
$(MAKE) -C $(PKG_BUILD_DIR)
|
||||
endef
|
||||
|
||||
define Package/deco/install
|
||||
install -m0755 -d $(1)/usr/bin
|
||||
install -m0755 $(PKG_BUILD_DIR)/deco $(1)/usr/bin/deco
|
||||
install -m0755 -d $(1)/usr/lib/deco
|
||||
install -m0644 $(PKG_BUILD_DIR)/profile $(1)/usr/lib/deco/profile
|
||||
install -m0644 $(PKG_BUILD_DIR)/menu $(1)/usr/lib/deco/menu
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,deco))
|
11
utils/deco/patches/100-tty.c.patch
Normal file
11
utils/deco/patches/100-tty.c.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- src/tty.c 2005-09-25 00:23:41.671022039 -0700
|
||||
+++ str_new/tty.c 2005-09-25 01:09:37.189119615 -0700
|
||||
@@ -14,7 +14,7 @@
|
||||
#if HAVE_TERMIOS_H
|
||||
# include <sys/termios.h>
|
||||
# if HAVE_SYS_IOCTL_H
|
||||
-# include <sys/ioctl.h>
|
||||
+/*# include <sys/ioctl.h>*/
|
||||
# endif
|
||||
# define HAVE_TERMIO_H 1
|
||||
# define termio termios
|
Loading…
x
Reference in New Issue
Block a user