Merge pulseaudio pending patching from #3360

git-svn-id: svn://svn.openwrt.org/openwrt/packages@13478 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
florian 2008-12-02 16:30:08 +00:00
parent 2ccfec33a8
commit 415ea42a7d
6 changed files with 51 additions and 97 deletions

View File

@ -9,12 +9,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=pulseaudio
PKG_VERSION:=0.9.10
PKG_VERSION:=0.9.13
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://0pointer.de/lennart/projects/pulseaudio/
PKG_MD5SUM:=9187ac1b302b9ab45f355242f453882e
PKG_MD5SUM:=279fb92f08393a6a992d55e3ac9a006b
PKG_FIXUP = libtool
@ -23,7 +23,7 @@ include $(INCLUDE_DIR)/package.mk
define Package/pulseaudio
SECTION:=sound
CATEGORY:=Sound
DEPENDS:=+liboil +libsamplerate +libsndfile +libatomicops +libltdl +dbus +libintl +libiconv @BROKEN
DEPENDS:=+speex +libgdbm +liboil +libsamplerate +libsndfile +libatomicops +libltdl +dbus +libintl +libiconv @BROKEN
TITLE:=Network sound server
URL:=http://www.pulseaudio.org
endef
@ -34,17 +34,23 @@ CONFIGURE_ARGS += \
--with-realtime-group=root \
--with-access-group=root \
--without-x \
--enable-static-bins \
--enable-ltdl-install \
--disable-dbus \
--disable-hal \
--disable-gconf \
--disable-tcpwrap \
--disable-nls \
--disable-solaris \
--disable-glib2 \
--disable-jack \
--disable-asyncns \
--disable-polkit \
--disable-samplerate \
--disable-lirc \
--disable-bluez \
--without-caps
CONFIGURE_VARS += \
PKG_CONFIG_PATH="$(STAGING_DIR)/usr/lib/pkgconfig" \
LIBOIL_CFLAGS="-I$(STAGING_DIR)/usr/include/liboil-0.3/" \
LIBOIL_LIBS="-L$(STAGING_DIR)/usr/lib/" \
PKG_CONFIG_PATH="$(STAGING_DIR)/usr/lib/pkgconfig"
SUPP_LIBS:=-L$(STAGING_DIR)/usr/lib/libintl/lib -L$(STAGING_DIR)/usr/lib/libiconv/lib

View File

@ -1,14 +0,0 @@
Index: pulseaudio-0.9.10/configure
===================================================================
--- pulseaudio-0.9.10.orig/configure 2008-04-11 13:28:12.000000000 +0200
+++ pulseaudio-0.9.10/configure 2008-04-11 13:28:12.000000000 +0200
@@ -30281,8 +30281,7 @@
else
{ { echo "$as_me:$LINENO: error: *** libatomic-ops headers not found" >&5
-echo "$as_me: error: *** libatomic-ops headers not found" >&2;}
- { (exit 1); exit 1; }; }
+echo "$as_me: error: *** libatomic-ops headers not found" >&2;} }
fi

View File

@ -1,60 +0,0 @@
Index: pulseaudio-0.9.10/src/pulsecore/shm.c
===================================================================
--- pulseaudio-0.9.10.orig/src/pulsecore/shm.c 2008-04-11 13:28:12.000000000 +0200
+++ pulseaudio-0.9.10/src/pulsecore/shm.c 2008-04-11 13:28:13.000000000 +0200
@@ -125,7 +125,7 @@
m->do_unlink = 0;
} else {
-#ifdef HAVE_SHM_OPEN
+#ifdef HAVE_SHM_UNLINK
struct shm_marker *marker;
pa_random(&m->id, sizeof(m->id));
@@ -167,7 +167,7 @@
fail:
-#ifdef HAVE_SHM_OPEN
+#ifdef HAVE_SHM_UNLINK
if (fd >= 0) {
shm_unlink(fn);
pa_close(fd);
@@ -196,7 +196,7 @@
pa_xfree(m->ptr);
#endif
} else {
-#ifdef HAVE_SHM_OPEN
+#ifdef HAVE_SHM_UNLINK
if (munmap(m->ptr, m->size) < 0)
pa_log("munmap() failed: %s", pa_cstrerror(errno));
@@ -260,7 +260,7 @@
#endif
}
-#ifdef HAVE_SHM_OPEN
+#ifdef HAVE_SHM_UNLINK
int pa_shm_attach_ro(pa_shm *m, unsigned id) {
char fn[32];
@@ -318,7 +318,7 @@
int pa_shm_cleanup(void) {
-#ifdef HAVE_SHM_OPEN
+#ifdef HAVE_SHM_UNLINK
#ifdef SHM_PATH
DIR *d;
struct dirent *de;
@@ -371,8 +371,10 @@
/* Ok, the owner of this shms segment is dead, so, let's remove the segment */
segment_name(fn, sizeof(fn), id);
+#ifdef HAVE_SHM_UNLINK
if (shm_unlink(fn) < 0 && errno != EACCES)
pa_log_warn("Failed to remove SHM segment %s: %s\n", fn, pa_cstrerror(errno));
+#endif
}
closedir(d);

View File

@ -1,15 +0,0 @@
Index: pulseaudio-0.9.10/src/daemon/caps.c
===================================================================
--- pulseaudio-0.9.10.orig/src/daemon/caps.c 2008-04-11 13:28:12.000000000 +0200
+++ pulseaudio-0.9.10/src/daemon/caps.c 2008-04-11 13:28:13.000000000 +0200
@@ -131,9 +131,8 @@
return 0;
}
-int pa_drop_caps(void) {
+void pa_drop_caps(void) {
pa_drop_root();
- return 0;
}
#endif

View File

@ -0,0 +1,24 @@
Index: pulseaudio-0.9.13/src/tests/rtstutter.c
===================================================================
--- pulseaudio-0.9.13.orig/src/tests/rtstutter.c 2008-08-19 23:25:05.000000000 +0200
+++ pulseaudio-0.9.13/src/tests/rtstutter.c 2008-10-08 16:23:38.000000000 +0200
@@ -53,7 +53,6 @@ static void* work(void *p) {
CPU_ZERO(&mask);
CPU_SET((size_t) PA_PTR_TO_INT(p), &mask);
- pa_assert_se(pthread_setaffinity_np(pthread_self(), sizeof(mask), &mask) == 0);
for (;;) {
struct timespec now, end;
Index: pulseaudio-0.9.13/src/tests/rtstutter.c
===================================================================
--- pulseaudio-0.9.13.orig/src/tests/rtstutter.c 2008-08-19 23:25:05.000000000 +0200
+++ pulseaudio-0.9.13/src/tests/rtstutter.c 2008-10-08 16:23:38.000000000 +0200
@@ -53,7 +53,6 @@ static void* work(void *p) {
CPU_ZERO(&mask);
CPU_SET((size_t) PA_PTR_TO_INT(p), &mask);
- pa_assert_se(pthread_setaffinity_np(pthread_self(), sizeof(mask), &mask) == 0);
for (;;) {
struct timespec now, end;

View File

@ -0,0 +1,13 @@
Index: pulseaudio-0.9.13/src/daemon/main.c
===================================================================
--- pulseaudio-0.9.13.orig/src/daemon/main.c 2008-10-03 21:16:52.000000000 +0200
+++ pulseaudio-0.9.13/src/daemon/main.c 2008-10-10 09:56:38.000000000 +0200
@@ -892,7 +892,7 @@ int main(int argc, char *argv[]) {
win32_timer = pa_mainloop_get_api(mainloop)->time_new(pa_mainloop_get_api(mainloop), pa_gettimeofday(&win32_tv), message_cb, NULL);
#endif
- oil_init();
+ oil_init_no_optimize();
if (!conf->no_cpu_limit)
pa_assert_se(pa_cpu_limit_init(pa_mainloop_get_api(mainloop)) == 0);