coova-chilli: fix "struct sysinfo" redeclaration with recent uClibc.

Patch from http://lists.coova.org/pipermail/chilli/2013-August/002347.html -
refreshed and compile tested locally.

git-svn-id: svn://svn.openwrt.org/openwrt/packages@38058 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
jow 2013-09-19 12:53:25 +00:00
parent b4ae48bb91
commit 41e8061432
2 changed files with 26 additions and 2 deletions

View File

@ -1,5 +1,5 @@
#
# Copyright (C) 2007-2010 OpenWrt.org
# Copyright (C) 2007-2013 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=coova-chilli
PKG_VERSION:=1.2.9
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://ap.coova.org/chilli

View File

@ -0,0 +1,24 @@
--- a/src/system.h
+++ b/src/system.h
@@ -76,10 +76,6 @@
#include <sys/stat.h>
#endif
-#ifdef HAVE_SYS_SYSINFO_H
-#include <sys/sysinfo.h>
-#endif
-
#ifdef HAVE_TIME_H
#include <time.h>
#endif
@@ -132,6 +128,10 @@
#include <linux/un.h>
#endif
+#ifdef HAVE_SYS_SYSINFO_H
+#include <sys/sysinfo.h>
+#endif
+
#elif defined (__FreeBSD__) || defined (__APPLE__) || defined (__OpenBSD__) || defined (__NetBSD__)
#include <net/if.h>
#include <net/bpf.h>