[package] add radlib (#5773)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@18981 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
0bcb24b147
commit
4270fd791c
44
libs/radlib/Makefile
Normal file
44
libs/radlib/Makefile
Normal file
@ -0,0 +1,44 @@
|
||||
# Copyright (C) 2006-2009 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=radlib
|
||||
PKG_VERSION:=2.8.5
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=@SF/radlib
|
||||
PKG_MD5SUM:=82ab0c702e55a860b69ad76e2aac748f
|
||||
|
||||
ifeq ($(CONFIG_EXTERNAL_KERNEL_TREE),)
|
||||
PATCH_DIR:=
|
||||
else
|
||||
PATCH_DIR:=./patches
|
||||
endif
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/radlib
|
||||
SECTION:=libs
|
||||
CATEGORY:=Libraries
|
||||
TITLE:=Rapid Application Development Library
|
||||
endef
|
||||
|
||||
define Package/radlib/description
|
||||
radlib is a rapid application development library for unix multi-process applications
|
||||
endef
|
||||
|
||||
CONFIGURE_ARGS += \
|
||||
--prefix="$(TOOLCHAIN_DIR)/usr"
|
||||
|
||||
define Package/radlib/install
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/.libs/librad.so $(1)/usr/lib/
|
||||
endef
|
||||
|
||||
|
||||
$(eval $(call BuildPackage,radlib))
|
44
libs/radlib/patches/001-cross_link_bug.patch
Normal file
44
libs/radlib/patches/001-cross_link_bug.patch
Normal file
@ -0,0 +1,44 @@
|
||||
diff -urN radlib-2.8.4/debug/Makefile.am radlib-2.8.42/debug/Makefile.am
|
||||
--- radlib-2.8.4/debug/Makefile.am 2009-02-05 06:10:01.000000000 +0100
|
||||
+++ radlib-2.8.42/debug/Makefile.am 2009-10-04 16:40:08.000000000 +0200
|
||||
@@ -43,5 +43,5 @@
|
||||
endif
|
||||
|
||||
if CROSSCOMPILE
|
||||
-raddebug_LDFLAGS += $(prefix)/lib/crt1.o $(prefix)/lib/crti.o $(prefix)/lib/crtn.o
|
||||
+#raddebug_LDFLAGS += $(prefix)/lib/crt1.o $(prefix)/lib/crti.o $(prefix)/lib/crtn.o
|
||||
endif
|
||||
diff -urN radlib-2.8.4/debug/Makefile.in radlib-2.8.42/debug/Makefile.in
|
||||
--- radlib-2.8.4/debug/Makefile.in 2009-08-15 16:03:37.000000000 +0200
|
||||
+++ radlib-2.8.42/debug/Makefile.in 2009-10-04 16:40:17.000000000 +0200
|
||||
@@ -43,7 +43,7 @@
|
||||
@MYSQL_FALSE@@PGRESQL_TRUE@am__append_6 = -I$(prefix)/pgsql/include
|
||||
@SQLITE_TRUE@am__append_7 = -L/usr/lib -L/usr/local/lib
|
||||
@SQLITE_TRUE@am__append_8 = -I/usr/include -I/usr/local/include
|
||||
-@CROSSCOMPILE_TRUE@am__append_9 = $(prefix)/lib/crt1.o $(prefix)/lib/crti.o $(prefix)/lib/crtn.o
|
||||
+#@CROSSCOMPILE_TRUE@am__append_9 = $(prefix)/lib/crt1.o $(prefix)/lib/crti.o $(prefix)/lib/crtn.o
|
||||
subdir = debug
|
||||
DIST_COMMON = $(srcdir)/Makefile.am $(srcdir)/Makefile.in
|
||||
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
|
||||
diff -urN radlib-2.8.4/msgRouter/Makefile.am radlib-2.8.42/msgRouter/Makefile.am
|
||||
--- radlib-2.8.4/msgRouter/Makefile.am 2009-02-05 06:10:01.000000000 +0100
|
||||
+++ radlib-2.8.42/msgRouter/Makefile.am 2009-10-04 16:31:24.000000000 +0200
|
||||
@@ -44,5 +44,5 @@
|
||||
endif
|
||||
|
||||
if CROSSCOMPILE
|
||||
-radmrouted_LDFLAGS += $(prefix)/lib/crt1.o $(prefix)/lib/crti.o $(prefix)/lib/crtn.o
|
||||
+#radmrouted_LDFLAGS += $(prefix)/lib/crt1.o $(prefix)/lib/crti.o $(prefix)/lib/crtn.o
|
||||
endif
|
||||
diff -urN radlib-2.8.4/msgRouter/Makefile.in radlib-2.8.42/msgRouter/Makefile.in
|
||||
--- radlib-2.8.4/msgRouter/Makefile.in 2009-08-15 16:03:37.000000000 +0200
|
||||
+++ radlib-2.8.42/msgRouter/Makefile.in 2009-10-04 16:36:01.000000000 +0200
|
||||
@@ -43,7 +43,7 @@
|
||||
@MYSQL_FALSE@@PGRESQL_TRUE@am__append_6 = -I$(prefix)/pgsql/include
|
||||
@SQLITE_TRUE@am__append_7 = -L/usr/lib -L/usr/local/lib
|
||||
@SQLITE_TRUE@am__append_8 = -I/usr/include -I/usr/local/include
|
||||
-@CROSSCOMPILE_TRUE@am__append_9 = $(prefix)/lib/crt1.o $(prefix)/lib/crti.o $(prefix)/lib/crtn.o
|
||||
+#@CROSSCOMPILE_TRUE@am__append_9 = $(prefix)/lib/crt1.o $(prefix)/lib/crti.o $(prefix)/lib/crtn.o
|
||||
subdir = msgRouter
|
||||
DIST_COMMON = $(srcdir)/Makefile.am $(srcdir)/Makefile.in
|
||||
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
|
Loading…
x
Reference in New Issue
Block a user