[package] rename the old irssi to irssi-glib1 and update irssi to 0.8.13

git-svn-id: svn://svn.openwrt.org/openwrt/packages@15105 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
florian 2009-04-04 16:23:31 +00:00
parent e052f51617
commit 434ca544b3
4 changed files with 177 additions and 70 deletions

53
net/irssi-glib1/Makefile Normal file
View File

@ -0,0 +1,53 @@
#
# Copyright (C) 2006 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
# $Id$
include $(TOPDIR)/rules.mk
PKG_NAME:=irssi
PKG_VERSION:=0.8.10
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)a.tar.bz2
PKG_SOURCE_URL:=http://irssi.org/files/
PKG_MD5SUM:=38e616bccb6a34ff6d91690317c2fa19
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
include $(INCLUDE_DIR)/package.mk
define Package/irssi
SUBMENU:=Instant Messaging
SECTION:=net
CATEGORY:=Network
DEPENDS:=+glib1 +libncurses
TITLE:=console irc client
URL:=http://irssi.org/
endef
define Build/Configure
$(call Build/Configure/Default, \
--with-perl=no \
--with-glib1 \
--with-glib-prefix="$(STAGING_DIR)/usr" \
--with-textui \
--without-terminfo \
--without-bot \
--without-file-offset-size \
--without-ssl \
--disable-ssl \
--enable-ipv6 \
--disable-proxy \
)
endef
define Package/irssi/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/fe-text/irssi $(1)/usr/bin/
endef
$(eval $(call BuildPackage,irssi))

View File

@ -0,0 +1,54 @@
diff -ruN irssi-0.8.10.orig/configure irssi-0.8.10/configure
--- irssi-0.8.10.orig/configure 2005-12-11 23:46:06.000000000 +0100
+++ irssi-0.8.10/configure 2006-02-24 13:19:21.570891250 +0100
@@ -21848,13 +21848,6 @@
echo "$as_me:$LINENO: checking size of off_t" >&5
echo $ECHO_N "checking size of off_t... $ECHO_C" >&6
-if test "$cross_compiling" = yes; then
- { { echo "$as_me:$LINENO: error: cannot run test program while cross compiling
-See \`config.log' for more details." >&5
-echo "$as_me: error: cannot run test program while cross compiling
-See \`config.log' for more details." >&2;}
- { (exit 1); exit 1; }; }
-else
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
_ACEOF
@@ -21872,35 +21865,8 @@
}
_ACEOF
-rm -f conftest$ac_exeext
-if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
- (eval $ac_link) 2>&5
- ac_status=$?
- echo "$as_me:$LINENO: \$? = $ac_status" >&5
- (exit $ac_status); } && { ac_try='./conftest$ac_exeext'
- { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
- (eval $ac_try) 2>&5
- ac_status=$?
- echo "$as_me:$LINENO: \$? = $ac_status" >&5
- (exit $ac_status); }; }; then
-
- sizeof_off_t=`cat conftestval`
- rm -f conftestval
-
-else
- echo "$as_me: program exited with status $ac_status" >&5
-echo "$as_me: failed program was:" >&5
-sed 's/^/| /' conftest.$ac_ext >&5
-
-( exit $ac_status )
-
- { { echo "$as_me:$LINENO: error: Unsupported off_t size" >&5
-echo "$as_me: error: Unsupported off_t size" >&2;}
- { (exit 1); exit 1; }; }
-
-fi
+ sizeof_off_t=8
rm -f core *.core gmon.out bb.out conftest$ac_exeext conftest.$ac_objext conftest.$ac_ext
-fi
echo "$as_me:$LINENO: result: $sizeof_off_t" >&5
echo "${ECHO_T}$sizeof_off_t" >&6

View File

@ -9,45 +9,99 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=irssi
PKG_VERSION:=0.8.10
PKG_RELEASE:=2
PKG_VERSION:=0.8.13
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)a.tar.bz2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://irssi.org/files/
PKG_MD5SUM:=38e616bccb6a34ff6d91690317c2fa19
PKG_MD5SUM:=0d6fc2203832b514eff014fffd574664
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
include $(INCLUDE_DIR)/package.mk
define Package/irssi
define Package/irssi/Default
SUBMENU:=Instant Messaging
SECTION:=net
CATEGORY:=Network
DEPENDS:=+glib1 +libncurses
DEPENDS:=+glib2 +libncurses
TITLE:=console irc client
URL:=http://irssi.org/
endef
define Build/Configure
define Package/irssi/Default/description
Irssi is a terminal based IRC client for UNIX systems.
endef
define Package/irssi
$(call Package/irssi/Default)
TITLE+= (without OpenSSL support)
endef
define Package/irssi/description
$(call Package/irssi/Default/description)
This package is built without OpenSSL support.
endef
define Package/irssi-openssl
$(call Package/irssi/Default)
TITLE+= (with OpenSSL support)
DEPENDS+= +libopenssl
endef
define Package/irssi-openssl/description
$(call Package/irssi/Default/description)
This package is built with OpenSSL support.
endef
define Build/Template
$(STAMP_BUILT)-$(2): $(STAMP_PREPARED)
-$(MAKE) -C $(PKG_BUILD_DIR) clean
$(call Build/Configure/Default, \
--with-perl=no \
--with-glib1 \
--with-glib-prefix="$(STAGING_DIR)/usr" \
--with-textui \
--without-terminfo \
--without-bot \
--without-file-offset-size \
--disable-ipv6 \
--disable-proxy \
$(3))
$(MAKE) -C $(PKG_BUILD_DIR)
( cd $(PKG_BUILD_DIR); mv -f src/fe-text/irssi $(PKG_NAME)-$(2) )
touch $$@
$(STAMP_BUILT): $(STAMP_BUILT)-$(2)
define Package/$(1)/install
$(INSTALL_DIR) $$(1)/usr/bin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/$(PKG_NAME)-$(2) $$(1)/usr/bin/$(PKG_NAME)
endef
endef
EXTRA_CFLAGS+=-I$(STAGING_DIR)/include -I$(STAGING_DIR)/usr/lib/libiconv/include -I$(STAGING_DIR)/usr/lib/libintl/include
EXTRA_LDFLAGS+=-L$(STAGING_DIR)/usr/lib/libiconv/lib -L$(STAGING_DIR)/usr/lib/libintl/lib
ifneq ($(SDK)$(CONFIG_PACKAGE_irssi),)
define Build/without-ssl
$(call Build/Template,irssi,without-ssl, \
--without-ssl \
--disable-ssl \
--enable-ipv6 \
--disable-proxy \
)
endef
)
endef
endif
$(eval $(Build/without-ssl))
define Package/irssi/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/fe-text/irssi $(1)/usr/bin/
endef
ifneq ($(SDK)$(CONFIG_PACKAGE_irssi-openssl),)
define Build/with-openssl
$(call Build/Template,irssi-openssl,with-openssl, \
--with-ssl="$(STAGING_DIR)/usr" \
)
endef
endif
$(eval $(Build/with-openssl))
$(eval $(call BuildPackage,irssi))
$(eval $(call BuildPackage,irssi-openssl))

View File

@ -1,54 +0,0 @@
diff -ruN irssi-0.8.10.orig/configure irssi-0.8.10/configure
--- irssi-0.8.10.orig/configure 2005-12-11 23:46:06.000000000 +0100
+++ irssi-0.8.10/configure 2006-02-24 13:19:21.570891250 +0100
@@ -21848,13 +21848,6 @@
echo "$as_me:$LINENO: checking size of off_t" >&5
echo $ECHO_N "checking size of off_t... $ECHO_C" >&6
-if test "$cross_compiling" = yes; then
- { { echo "$as_me:$LINENO: error: cannot run test program while cross compiling
-See \`config.log' for more details." >&5
-echo "$as_me: error: cannot run test program while cross compiling
-See \`config.log' for more details." >&2;}
- { (exit 1); exit 1; }; }
-else
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
_ACEOF
@@ -21872,35 +21865,8 @@
}
_ACEOF
-rm -f conftest$ac_exeext
-if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
- (eval $ac_link) 2>&5
- ac_status=$?
- echo "$as_me:$LINENO: \$? = $ac_status" >&5
- (exit $ac_status); } && { ac_try='./conftest$ac_exeext'
- { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
- (eval $ac_try) 2>&5
- ac_status=$?
- echo "$as_me:$LINENO: \$? = $ac_status" >&5
- (exit $ac_status); }; }; then
-
- sizeof_off_t=`cat conftestval`
- rm -f conftestval
-
-else
- echo "$as_me: program exited with status $ac_status" >&5
-echo "$as_me: failed program was:" >&5
-sed 's/^/| /' conftest.$ac_ext >&5
-
-( exit $ac_status )
-
- { { echo "$as_me:$LINENO: error: Unsupported off_t size" >&5
-echo "$as_me: error: Unsupported off_t size" >&2;}
- { (exit 1); exit 1; }; }
-
-fi
+ sizeof_off_t=8
rm -f core *.core gmon.out bb.out conftest$ac_exeext conftest.$ac_objext conftest.$ac_ext
-fi
echo "$as_me:$LINENO: result: $sizeof_off_t" >&5
echo "${ECHO_T}$sizeof_off_t" >&6