[package] add gnuplot (#7764), patch from obsy
git-svn-id: svn://svn.openwrt.org/openwrt/packages@23014 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
09ad32e9d3
commit
43eb878392
48
utils/gnuplot/Makefile
Normal file
48
utils/gnuplot/Makefile
Normal file
@ -0,0 +1,48 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=gnuplot
|
||||
PKG_VERSION:=4.4.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_INSTALL=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=@SF/gnuplot
|
||||
PKG_MD5SUM:=e708665bd512153ad5c35252fe499059
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
EXTRA_LDFLAGS += \
|
||||
-Wl,-rpath-link=$(STAGING_DIR)/usr/lib
|
||||
|
||||
CONFIGURE_VARS += \
|
||||
CPPFLAGS="$$$$CPPFLAGS -I$(STAGING_DIR)/usr/include/uClibc++" \
|
||||
CXXFLAGS="$$$$CXXFLAGS -fno-builtin -fno-rtti -nostdinc++" \
|
||||
LIBS="-nodefaultlibs -luClibc++ -lpthread -lgcc"
|
||||
|
||||
define Package/gnuplot
|
||||
SECTION:=utils
|
||||
CATEGORY:=Utilities
|
||||
DEPENDS:=+libncurses +uclibcxx +zlib +libpng +libfreetype +libgd
|
||||
TITLE:=A portable command-line driven graphing utility
|
||||
URL:=http://sourceforge.net/projects/gnuplot/
|
||||
endef
|
||||
|
||||
define Package/gnuplot/description
|
||||
Gnuplot is a portable command-line driven graphing utility for linux, OS/2,
|
||||
MS Windows, OSX, VMS, and many other platforms.
|
||||
endef
|
||||
|
||||
CONFIGURE_ARGS += \
|
||||
--without-x \
|
||||
--disable-mouse \
|
||||
--without-tutorial \
|
||||
--without-row-help \
|
||||
--without-lisp-files
|
||||
|
||||
define Package/gnuplot/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/gnuplot $(1)/usr/bin/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,gnuplot))
|
11
utils/gnuplot/patches/010-Makefile.in.patch
Normal file
11
utils/gnuplot/patches/010-Makefile.in.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- a/Makefile.in.orig 2010-03-13 22:20:04.000000000 +0100
|
||||
+++ b/Makefile.in 2010-06-03 15:08:35.000000000 +0200
|
||||
@@ -240,7 +240,7 @@
|
||||
top_builddir = @top_builddir@
|
||||
top_srcdir = @top_srcdir@
|
||||
AUTOMAKE_OPTIONS = foreign 1.2h
|
||||
-SUBDIRS = config m4 term src docs $(LISPDIR) man demo tutorial share
|
||||
+SUBDIRS = config m4 term src $(LISPDIR) share
|
||||
EXTRA_DIST = BUGS CodeStyle Copyright FAQ.pdf GNUmakefile INSTALL INSTALL.gnu \
|
||||
Makefile.maint PATCHLEVEL PGPKEYS PORTING README README.1ST \
|
||||
VERSION configure.vms pm3d
|
Loading…
x
Reference in New Issue
Block a user