shorewall:
* Update 3.4.3 > 3.4.6 (closes: #2310) * Cleanup Makefile * Refresh patch git-svn-id: svn://svn.openwrt.org/openwrt/packages@8615 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
d5f6dc5fed
commit
44a48a606a
@ -1,5 +1,5 @@
|
||||
#
|
||||
# Copyright (C) 2006 OpenWrt.org
|
||||
# Copyright (C) 2007 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
@ -9,16 +9,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=shorewall
|
||||
PKG_VERSION:=3.4.3
|
||||
PKG_RELEASE:=1
|
||||
PKG_MD5SUM:=4ac779d02d4befc72a0ce1534fbb328d
|
||||
PKG_VERSION:=3.4.6
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE_URL:=http://www1.shorewall.net/pub/$(PKG_NAME)/3.4/$(PKG_NAME)-$(PKG_VERSION)/
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
|
||||
PKG_CAT:=zcat
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
||||
PKG_MD5SUM:=ec6a8bd3d6d0468b6302a7725851c39b
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
@ -27,11 +23,12 @@ define Package/shorewall
|
||||
CATEGORY:=Network
|
||||
DEPENDS:=+iptables
|
||||
TITLE:=Shorewall firewall
|
||||
DESCRIPTION:=\
|
||||
Shorewall Firewall is an iptables-based firewall for Linux.
|
||||
URL:=http://www.shorewall.net/
|
||||
endef
|
||||
|
||||
define define Package/shorewall/description
|
||||
Shorewall Firewall is an iptables-based firewall for Linux.
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
rm -rf $(PKG_INSTALL_DIR)
|
||||
@ -41,10 +38,10 @@ endef
|
||||
|
||||
define Package/shorewall/install
|
||||
$(INSTALL_DIR) $(1)/sbin
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/sbin/$(PKG_NAME) $(1)/sbin
|
||||
$(INSTALL_DIR) $(1)/etc/init.d
|
||||
$(INSTALL_BIN) ./files/$(PKG_NAME).init $(1)/etc/init.d/$(PKG_NAME)
|
||||
$(INSTALL_DIR) $(1)/usr/share
|
||||
$(INSTALL_BIN) ./files/shorewall.init $(1)/etc/init.d/shorewall
|
||||
$(CP) $(PKG_INSTALL_DIR)/sbin/shorewall $(1)/sbin
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/share/shorewall $(1)/usr/share
|
||||
$(CP) $(PKG_INSTALL_DIR)/etc/shorewall $(1)/etc
|
||||
endef
|
||||
|
@ -1,22 +1,24 @@
|
||||
diff -ruN shorewall-3.4.3/install.sh shorewall-3.4.3.new/install.sh
|
||||
--- shorewall-3.4.3/install.sh 2007-04-17 19:16:56.000000000 +0200
|
||||
+++ shorewall-3.4.3.new/install.sh 2007-08-01 16:21:24.000000000 +0200
|
||||
@@ -677,26 +677,6 @@
|
||||
# Install the Man Pages
|
||||
#
|
||||
Index: shorewall-3.4.6/install.sh
|
||||
===================================================================
|
||||
--- shorewall-3.4.6.orig/install.sh 2007-09-04 21:51:24.000000000 +0200
|
||||
+++ shorewall-3.4.6/install.sh 2007-09-04 21:51:24.000000000 +0200
|
||||
@@ -676,28 +676,6 @@
|
||||
fi
|
||||
|
||||
#
|
||||
-# Install the Man Pages
|
||||
-#
|
||||
-
|
||||
-cd manpages
|
||||
-
|
||||
-rm -f *.gz
|
||||
-
|
||||
-for f in *.5; do
|
||||
- gzip $f
|
||||
- gzip -c $f > $f.gz
|
||||
- run_install -D -m 0444 $f.gz ${PREFIX}/usr/share/man/man5/$f.gz
|
||||
- echo "Man page $f.gz installed to /usr/share/man/man5/$f.gz"
|
||||
-done
|
||||
-
|
||||
-for f in *.8; do
|
||||
- gzip $f
|
||||
- gzip -c $f > $f.gz
|
||||
- run_install -D -m 0444 $f.gz ${PREFIX}/usr/share/man/man8/$f.gz
|
||||
- echo "Man page $f.gz installed to /usr/share/man/man8/$f.gz"
|
||||
-done
|
||||
@ -25,6 +27,7 @@ diff -ruN shorewall-3.4.3/install.sh shorewall-3.4.3.new/install.sh
|
||||
-
|
||||
-echo "Man Pages Installed"
|
||||
-
|
||||
#
|
||||
-#
|
||||
# Install the firewall script
|
||||
#
|
||||
install_file firewall ${PREFIX}/usr/share/shorewall/firewall 0555
|
||||
|
Loading…
x
Reference in New Issue
Block a user