Update alsa-lib and alsa-utils to 1.0.19
git-svn-id: svn://svn.openwrt.org/openwrt/packages@14169 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
d9ce314ed0
commit
453cc9ef5b
@ -9,14 +9,15 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=alsa-lib
|
PKG_NAME:=alsa-lib
|
||||||
PKG_VERSION:=1.0.13
|
PKG_VERSION:=1.0.19
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||||
PKG_SOURCE_URL:=ftp://ftp.alsa-project.org/pub/lib/
|
PKG_SOURCE_URL:=ftp://ftp.alsa-project.org/pub/lib/
|
||||||
PKG_MD5SUM:=d55a9d7d2a79d738a1b7a511cffda4b6
|
PKG_MD5SUM:=73db3666c211e5fb023bb77450cf430d
|
||||||
|
|
||||||
PKG_FIXUP = libtool
|
PKG_FIXUP:=libtool
|
||||||
|
PKG_INSTALL:=1
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
@ -40,34 +41,54 @@ define Package/alsa-lib/description
|
|||||||
endef
|
endef
|
||||||
|
|
||||||
TARGET_CFLAGS += $(FPIC)
|
TARGET_CFLAGS += $(FPIC)
|
||||||
CONFIGURE_ARGS += \
|
|
||||||
--enable-shared \
|
|
||||||
--enable-static \
|
|
||||||
--disable-debugging \
|
|
||||||
--disable-profiling \
|
|
||||||
--with-softfloat \
|
|
||||||
--with-versioned=no \
|
|
||||||
|
|
||||||
define Build/Compile
|
define Build/Configure
|
||||||
# override AM_CFLAGS holding inappropriate optimization flags
|
$(call Build/Configure/Default, \
|
||||||
$(MAKE) -C $(PKG_BUILD_DIR) AM_CFLAGS="" all
|
--enable-static \
|
||||||
$(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" install
|
--disable-python \
|
||||||
|
--disable-debug \
|
||||||
|
--without-debug \
|
||||||
|
$(SOFT_FLOAT_CONFIG_OPTION) \
|
||||||
|
--with-versioned=no \
|
||||||
|
)
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Build/InstallDev
|
define Build/InstallDev
|
||||||
mkdir -p $(1)/usr/include
|
$(INSTALL_DIR) $(1)/usr/include/
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/include/alsa $(1)/usr/include/
|
$(CP) \
|
||||||
mkdir -p $(1)/usr/lib
|
$(PKG_INSTALL_DIR)/usr/include/alsa \
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libasound.{la,a,so*} $(1)/usr/lib/
|
$(1)/usr/include/
|
||||||
mkdir -p $(1)/usr/lib/pkgconfig
|
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/alsa.pc $(1)/usr/lib/pkgconfig/
|
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
|
||||||
|
$(CP) \
|
||||||
|
$(PKG_INSTALL_DIR)/usr/lib/libasound.{la,a,so*} \
|
||||||
|
$(1)/usr/lib/
|
||||||
|
$(INSTALL_DATA) \
|
||||||
|
$(PKG_INSTALL_DIR)/usr/lib/pkgconfig/alsa.pc \
|
||||||
|
$(1)/usr/lib/pkgconfig/
|
||||||
|
|
||||||
|
$(INSTALL_DIR) $(1)/usr/share/aclocal
|
||||||
|
$(INSTALL_DATA) \
|
||||||
|
$(PKG_INSTALL_DIR)/usr/share/aclocal/alsa.m4 \
|
||||||
|
$(1)/usr/share/aclocal/
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/alsa-lib/install
|
define Package/alsa-lib/install
|
||||||
$(INSTALL_DIR) $(1)/usr/lib
|
$(INSTALL_DIR) $(1)/usr/lib
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libasound.so.* $(1)/usr/lib/
|
$(CP) \
|
||||||
$(INSTALL_DIR) $(1)/usr/share/alsa/
|
$(PKG_INSTALL_DIR)/usr/lib/libasound.so.* \
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/share/alsa/alsa.conf $(1)/usr/share/alsa/
|
$(1)/usr/lib/
|
||||||
|
|
||||||
|
$(INSTALL_DIR) $(1)/usr/share/alsa/{cards,pcm}
|
||||||
|
$(INSTALL_DATA) \
|
||||||
|
$(PKG_INSTALL_DIR)/usr/share/alsa/alsa.conf \
|
||||||
|
$(1)/usr/share/alsa/
|
||||||
|
$(INSTALL_DATA) \
|
||||||
|
$(PKG_INSTALL_DIR)/usr/share/alsa/pcm/* \
|
||||||
|
$(1)/usr/share/alsa/pcm/
|
||||||
|
$(CP) \
|
||||||
|
$(PKG_INSTALL_DIR)/usr/share/alsa/cards/* \
|
||||||
|
$(1)/usr/share/alsa/cards/
|
||||||
endef
|
endef
|
||||||
|
|
||||||
$(eval $(call BuildPackage,alsa-lib))
|
$(eval $(call BuildPackage,alsa-lib))
|
||||||
|
53
libs/alsa-lib/patches/100-fix-with-softfloat.patch
Normal file
53
libs/alsa-lib/patches/100-fix-with-softfloat.patch
Normal file
@ -0,0 +1,53 @@
|
|||||||
|
From: Takashi Iwai <tiwai@suse.de>
|
||||||
|
Date: Wed, 21 Jan 2009 08:25:48 +0000 (+0100)
|
||||||
|
Subject: Fix build with softfloat option
|
||||||
|
X-Git-Url: http://git.alsa-project.org/?p=alsa-lib.git;a=commitdiff_plain;h=a789b66d00644eeeb72fd424d686c7fe8faa5daa
|
||||||
|
|
||||||
|
Fix build with softfloat option
|
||||||
|
|
||||||
|
Fix build of alsa-lib when --with-softfloat is used:
|
||||||
|
- disable ladspa plugin
|
||||||
|
- don't use sqrt() function
|
||||||
|
|
||||||
|
Signed-off-by: Takashi Iwai <tiwai@suse.de>
|
||||||
|
---
|
||||||
|
|
||||||
|
diff --git a/configure.in b/configure.in
|
||||||
|
index 9a71d95..ea6a8a0 100644
|
||||||
|
--- a/configure.in
|
||||||
|
+++ b/configure.in
|
||||||
|
@@ -367,6 +367,7 @@ AC_ARG_ENABLE(seq,
|
||||||
|
AC_ARG_ENABLE(alisp,
|
||||||
|
AS_HELP_STRING([--disable-alisp], [disable the alisp component]),
|
||||||
|
[build_alisp="$enableval"], [build_alisp="yes"])
|
||||||
|
+test "$softfloat" = "yes" && build_alisp="no"
|
||||||
|
AC_ARG_ENABLE(old-symbols,
|
||||||
|
AS_HELP_STRING([--disable-old-symbols], [disable old obsoleted symbols]),
|
||||||
|
[keep_old_symbols="$enableval"], [keep_old_symbols="yes"])
|
||||||
|
@@ -474,6 +475,7 @@ fi
|
||||||
|
|
||||||
|
if test "$softfloat" = "yes"; then
|
||||||
|
build_pcm_lfloat="no"
|
||||||
|
+ build_pcm_ladspa="no"
|
||||||
|
fi
|
||||||
|
|
||||||
|
AM_CONDITIONAL(BUILD_PCM_PLUGIN, test x$build_pcm_plugin = xyes)
|
||||||
|
diff --git a/src/mixer/simple_none.c b/src/mixer/simple_none.c
|
||||||
|
index 0f4dd3a..4802200 100644
|
||||||
|
--- a/src/mixer/simple_none.c
|
||||||
|
+++ b/src/mixer/simple_none.c
|
||||||
|
@@ -1450,7 +1450,14 @@ static int simple_add1(snd_mixer_class_t *class, const char *name,
|
||||||
|
}
|
||||||
|
if (ctype != SND_CTL_ELEM_TYPE_BOOLEAN)
|
||||||
|
return 0;
|
||||||
|
+#ifdef HAVE_SOFT_FLOAT
|
||||||
|
+ /* up to 256 channels */
|
||||||
|
+ for (n = 1; n < 256; n++)
|
||||||
|
+ if (n * n == values)
|
||||||
|
+ break;
|
||||||
|
+#else
|
||||||
|
n = sqrt((double)values);
|
||||||
|
+#endif
|
||||||
|
if (n * n != values)
|
||||||
|
return 0;
|
||||||
|
values = n;
|
28
libs/alsa-lib/patches/101-add-ldl-to-mixer-simple.patch
Normal file
28
libs/alsa-lib/patches/101-add-ldl-to-mixer-simple.patch
Normal file
@ -0,0 +1,28 @@
|
|||||||
|
From: Takashi Iwai <tiwai@suse.de>
|
||||||
|
Date: Wed, 21 Jan 2009 08:29:35 +0000 (+0100)
|
||||||
|
Subject: Add missing -ldl to modules/mixer/simple/*
|
||||||
|
X-Git-Url: http://git.alsa-project.org/?p=alsa-lib.git;a=commitdiff_plain;h=3b728db20d1729f1270731006f44c20ab910bee0
|
||||||
|
|
||||||
|
Add missing -ldl to modules/mixer/simple/*
|
||||||
|
|
||||||
|
Signed-off-by: Takashi Iwai <tiwai@suse.de>
|
||||||
|
---
|
||||||
|
|
||||||
|
diff --git a/modules/mixer/simple/Makefile.am b/modules/mixer/simple/Makefile.am
|
||||||
|
index f73871f..bad0944 100644
|
||||||
|
--- a/modules/mixer/simple/Makefile.am
|
||||||
|
+++ b/modules/mixer/simple/Makefile.am
|
||||||
|
@@ -21,11 +21,11 @@ smixer_sbase_la_LIBADD = ../../../src/libasound.la
|
||||||
|
|
||||||
|
smixer_ac97_la_SOURCES = ac97.c sbasedl.c
|
||||||
|
smixer_ac97_la_LDFLAGS = -module -avoid-version $(LDFLAGS_NOUNDEFINED)
|
||||||
|
-smixer_ac97_la_LIBADD = ../../../src/libasound.la
|
||||||
|
+smixer_ac97_la_LIBADD = ../../../src/libasound.la -ldl
|
||||||
|
|
||||||
|
smixer_hda_la_SOURCES = hda.c sbasedl.c
|
||||||
|
smixer_hda_la_LDFLAGS = -module -avoid-version $(LDFLAGS_NOUNDEFINED)
|
||||||
|
-smixer_hda_la_LIBADD = ../../../src/libasound.la
|
||||||
|
+smixer_hda_la_LIBADD = ../../../src/libasound.la -ldl
|
||||||
|
|
||||||
|
if BUILD_PYTHON
|
||||||
|
smixer_python_la_SOURCES = python.c
|
@ -9,12 +9,13 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=alsa-utils
|
PKG_NAME:=alsa-utils
|
||||||
PKG_VERSION:=1.0.13
|
PKG_VERSION:=1.0.19
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||||
PKG_SOURCE_URL:=ftp://ftp.alsa-project.org/pub/utils/
|
PKG_SOURCE_URL:=ftp://ftp.alsa-project.org/pub/utils/
|
||||||
PKG_MD5SUM:=dfe4bb5d3217f3ec662b172ce8397cf0
|
PKG_MD5SUM:=5ff0379c707c1a29083233edc9ab4e06
|
||||||
|
PKG_INSTALL:=1
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
@ -29,21 +30,22 @@ endef
|
|||||||
define Build/Configure
|
define Build/Configure
|
||||||
$(call Build/Configure/Default, \
|
$(call Build/Configure/Default, \
|
||||||
--disable-rpath \
|
--disable-rpath \
|
||||||
|
--disable-alsatest \
|
||||||
|
--disable-xmlto \
|
||||||
)
|
)
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Build/Compile
|
|
||||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
|
||||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
|
||||||
all install
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/alsa-utils/install
|
define Package/alsa-utils/install
|
||||||
$(INSTALL_DIR) $(1)/usr/{s,}bin
|
$(INSTALL_DIR) $(1)/usr/{s,}bin
|
||||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/amixer $(1)/usr/bin/
|
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/amixer $(1)/usr/bin/
|
||||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/alsamixer $(1)/usr/bin/
|
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/alsamixer $(1)/usr/bin/
|
||||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/aplay $(1)/usr/bin/
|
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/aplay $(1)/usr/bin/
|
||||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/alsactl $(1)/usr/sbin/
|
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/alsactl $(1)/usr/sbin/
|
||||||
|
|
||||||
|
$(INSTALL_DIR) $(1)/usr/share/alsa/init
|
||||||
|
$(INSTALL_DATA) \
|
||||||
|
$(PKG_INSTALL_DIR)/usr/share/alsa/init/* \
|
||||||
|
$(1)/usr/share/alsa/init/
|
||||||
endef
|
endef
|
||||||
|
|
||||||
$(eval $(call BuildPackage,alsa-utils))
|
$(eval $(call BuildPackage,alsa-utils))
|
||||||
|
Loading…
x
Reference in New Issue
Block a user