diff --git a/utils/comgt/Makefile b/utils/comgt/Makefile
index 0df02f437..d233bb180 100644
--- a/utils/comgt/Makefile
+++ b/utils/comgt/Makefile
@@ -36,7 +36,7 @@ endef
 define Build/Prepare	
 	rm -rf $(PKG_BUILD_DIR)
 	mkdir -p $(PKG_BUILD_DIR)
-	zcat $(DL_DIR)/$(PKG_SOURCE) | tar -C $(PKG_BUILD_DIR) $(TAR_OPTIONS) -
+	zcat $(DL_DIR)/$(PKG_SOURCE) | tar -C $(PKG_BUILD_DIR) $(TAR_OPTIONS)
 	if [ -d ./patches ]; then $(PATCH) $(PKG_BUILD_DIR) ./patches ; fi
 endef
 
diff --git a/utils/microcom/Makefile b/utils/microcom/Makefile
index 646c9e5cd..874afdac7 100644
--- a/utils/microcom/Makefile
+++ b/utils/microcom/Makefile
@@ -34,7 +34,7 @@ define Build/Prepare
 	rm -rf $(PKG_BUILD_DIR)
 	mkdir -p $(PKG_BUILD_DIR)
 	# the .tar.gz is different - no subdirectory, so do this manually
-	zcat $(DL_DIR)/$(PKG_SOURCE) | tar -C $(PKG_BUILD_DIR) $(TAR_OPTIONS) -
+	zcat $(DL_DIR)/$(PKG_SOURCE) | tar -C $(PKG_BUILD_DIR) $(TAR_OPTIONS)
 endef
 
 define Build/Configure