python: refresh patches
git-svn-id: svn://svn.openwrt.org/openwrt/packages@22968 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
aa323f78f1
commit
469dd1b2a8
@ -1,16 +1,18 @@
|
|||||||
Index: Python-2.5.1/Makefile.pre.in
|
---
|
||||||
===================================================================
|
Makefile.pre.in | 25 +++++++++++++------------
|
||||||
--- Python-2.5.1.orig/Makefile.pre.in 2007-07-30 12:55:24.000000000 -0500
|
1 file changed, 13 insertions(+), 12 deletions(-)
|
||||||
+++ Python-2.5.1/Makefile.pre.in 2007-07-30 12:55:24.000000000 -0500
|
|
||||||
@@ -175,6 +175,7 @@
|
--- Python-2.6.4.orig/Makefile.pre.in
|
||||||
|
+++ Python-2.6.4/Makefile.pre.in
|
||||||
|
@@ -175,6 +175,7 @@ UNICODE_OBJS= @UNICODE_OBJS@
|
||||||
|
|
||||||
PYTHON= python$(EXE)
|
PYTHON= python$(EXE)
|
||||||
BUILDPYTHON= python$(BUILDEXE)
|
BUILDPYTHON= python$(BUILDEXE)
|
||||||
+HOSTPYTHON= $(BUILDPYTHON)
|
+HOSTPYTHON= $(BUILDPYTHON)
|
||||||
|
|
||||||
# === Definitions added by makesetup ===
|
# The task to run while instrument when building the profile-opt target
|
||||||
|
PROFILE_TASK= $(srcdir)/Tools/pybench/pybench.py -n 2 --with-gc --with-syscheck
|
||||||
@@ -205,7 +206,7 @@
|
@@ -205,7 +206,7 @@ GRAMMAR_INPUT= $(srcdir)/Grammar/Grammar
|
||||||
##########################################################################
|
##########################################################################
|
||||||
# Parser
|
# Parser
|
||||||
PGEN= Parser/pgen$(EXE)
|
PGEN= Parser/pgen$(EXE)
|
||||||
@ -19,41 +21,7 @@ Index: Python-2.5.1/Makefile.pre.in
|
|||||||
POBJS= \
|
POBJS= \
|
||||||
Parser/acceler.o \
|
Parser/acceler.o \
|
||||||
Parser/grammar1.o \
|
Parser/grammar1.o \
|
||||||
@@ -394,8 +395,8 @@
|
@@ -370,7 +371,7 @@ build_all_generate_profile:
|
||||||
# Build the shared modules
|
|
||||||
sharedmods: $(BUILDPYTHON)
|
|
||||||
@case $$MAKEFLAGS in \
|
|
||||||
- *s*) $(RUNSHARED) CC='$(CC)' LDSHARED='$(BLDSHARED)' OPT='$(OPT)' ./$(BUILDPYTHON) -E $(srcdir)/setup.py -q build;; \
|
|
||||||
- *) $(RUNSHARED) CC='$(CC)' LDSHARED='$(BLDSHARED)' OPT='$(OPT)' ./$(BUILDPYTHON) -E $(srcdir)/setup.py build;; \
|
|
||||||
+ *s*) $(RUNSHARED) CC='$(CC)' LDSHARED='$(BLDSHARED)' OPT='$(OPT)' $(HOSTPYTHON) -E $(srcdir)/setup.py -q build;; \
|
|
||||||
+ *) $(RUNSHARED) CC='$(CC)' LDSHARED='$(BLDSHARED)' OPT='$(OPT)' $(HOSTPYTHON) -E $(srcdir)/setup.py build;; \
|
|
||||||
esac
|
|
||||||
|
|
||||||
# Build static library
|
|
||||||
@@ -512,8 +513,8 @@
|
|
||||||
|
|
||||||
|
|
||||||
$(GRAMMAR_H) $(GRAMMAR_C): $(PGEN) $(GRAMMAR_INPUT)
|
|
||||||
-@$(INSTALL) -d Include
|
|
||||||
- -$(PGEN) $(GRAMMAR_INPUT) $(GRAMMAR_H) $(GRAMMAR_C)
|
|
||||||
+ -$(HOSTPGEN) $(GRAMMAR_INPUT) $(GRAMMAR_H) $(GRAMMAR_C)
|
|
||||||
|
|
||||||
$(PGEN): $(PGENOBJS)
|
|
||||||
$(CC) $(OPT) $(LDFLAGS) $(PGENOBJS) $(LIBS) -o $(PGEN)
|
|
||||||
@@ -993,7 +994,7 @@
|
|
||||||
# Install the dynamically loadable modules
|
|
||||||
# This goes into $(exec_prefix)
|
|
||||||
sharedinstall:
|
|
||||||
- $(RUNSHARED) ./$(BUILDPYTHON) -E $(srcdir)/setup.py install \
|
|
||||||
+ $(RUNSHARED) $(HOSTPYTHON) -E $(srcdir)/setup.py install \
|
|
||||||
--prefix=$(prefix) \
|
|
||||||
--install-scripts=$(BINDIR) \
|
|
||||||
--install-platlib=$(DESTSHARED) \
|
|
||||||
diff --git a/Makefile.pre.in b/Makefile.pre.in
|
|
||||||
index c2ce5c6..63dc91e 100644
|
|
||||||
--- a/Makefile.pre.in
|
|
||||||
+++ b/Makefile.pre.in
|
|
||||||
@@ -371,7 +371,7 @@ build_all_generate_profile:
|
|
||||||
$(MAKE) all CFLAGS="$(CFLAGS) -fprofile-generate" LIBS="$(LIBS) -lgcov"
|
$(MAKE) all CFLAGS="$(CFLAGS) -fprofile-generate" LIBS="$(LIBS) -lgcov"
|
||||||
|
|
||||||
run_profile_task:
|
run_profile_task:
|
||||||
@ -62,7 +30,7 @@ index c2ce5c6..63dc91e 100644
|
|||||||
|
|
||||||
build_all_use_profile:
|
build_all_use_profile:
|
||||||
$(MAKE) all CFLAGS="$(CFLAGS) -fprofile-use"
|
$(MAKE) all CFLAGS="$(CFLAGS) -fprofile-use"
|
||||||
@@ -389,7 +389,7 @@ $(BUILDPYTHON): Modules/python.o $(LIBRARY) $(LDLIBRARY)
|
@@ -388,14 +389,14 @@ $(BUILDPYTHON): Modules/python.o $(LIBRA
|
||||||
$(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS) $(LDLAST)
|
$(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS) $(LDLAST)
|
||||||
|
|
||||||
platform: $(BUILDPYTHON)
|
platform: $(BUILDPYTHON)
|
||||||
@ -71,7 +39,25 @@ index c2ce5c6..63dc91e 100644
|
|||||||
|
|
||||||
|
|
||||||
# Build the shared modules
|
# Build the shared modules
|
||||||
@@ -669,7 +669,7 @@ $(LIBRARY_OBJS) $(MODOBJS) Modules/python.o: $(PYTHON_HEADERS)
|
sharedmods: $(BUILDPYTHON)
|
||||||
|
@case $$MAKEFLAGS in \
|
||||||
|
- *s*) $(RUNSHARED) CC='$(CC)' LDSHARED='$(BLDSHARED)' OPT='$(OPT)' ./$(BUILDPYTHON) -E $(srcdir)/setup.py -q build;; \
|
||||||
|
- *) $(RUNSHARED) CC='$(CC)' LDSHARED='$(BLDSHARED)' OPT='$(OPT)' ./$(BUILDPYTHON) -E $(srcdir)/setup.py build;; \
|
||||||
|
+ *s*) $(RUNSHARED) CC='$(CC)' LDSHARED='$(BLDSHARED)' OPT='$(OPT)' $(HOSTPYTHON) -E $(srcdir)/setup.py -q build;; \
|
||||||
|
+ *) $(RUNSHARED) CC='$(CC)' LDSHARED='$(BLDSHARED)' OPT='$(OPT)' $(HOSTPYTHON) -E $(srcdir)/setup.py build;; \
|
||||||
|
esac
|
||||||
|
|
||||||
|
# Build static library
|
||||||
|
@@ -517,7 +518,7 @@ Modules/python.o: $(srcdir)/Modules/pyth
|
||||||
|
|
||||||
|
$(GRAMMAR_H) $(GRAMMAR_C): $(PGEN) $(GRAMMAR_INPUT)
|
||||||
|
-@$(INSTALL) -d Include
|
||||||
|
- -$(PGEN) $(GRAMMAR_INPUT) $(GRAMMAR_H) $(GRAMMAR_C)
|
||||||
|
+ -$(HOSTPGEN) $(GRAMMAR_INPUT) $(GRAMMAR_H) $(GRAMMAR_C)
|
||||||
|
|
||||||
|
$(PGEN): $(PGENOBJS)
|
||||||
|
$(CC) $(OPT) $(LDFLAGS) $(PGENOBJS) $(LIBS) -o $(PGEN)
|
||||||
|
@@ -676,7 +677,7 @@ $(LIBRARY_OBJS) $(MODOBJS) Modules/pytho
|
||||||
|
|
||||||
TESTOPTS= -l $(EXTRATESTOPTS)
|
TESTOPTS= -l $(EXTRATESTOPTS)
|
||||||
TESTPROG= $(srcdir)/Lib/test/regrtest.py
|
TESTPROG= $(srcdir)/Lib/test/regrtest.py
|
||||||
@ -79,8 +65,17 @@ index c2ce5c6..63dc91e 100644
|
|||||||
+TESTPYTHON= $(RUNSHARED) $(HOSTPYTHON) -E -tt
|
+TESTPYTHON= $(RUNSHARED) $(HOSTPYTHON) -E -tt
|
||||||
test: all platform
|
test: all platform
|
||||||
-find $(srcdir)/Lib -name '*.py[co]' -print | xargs rm -f
|
-find $(srcdir)/Lib -name '*.py[co]' -print | xargs rm -f
|
||||||
|
-$(TESTPYTHON) $(TESTPROG) $(TESTOPTS)
|
||||||
@@ -1032,7 +1014,7 @@ frameworkinstallstructure: $(LDLIBRARY)
|
@@ -1001,7 +1002,7 @@ libainstall: all
|
||||||
|
# Install the dynamically loadable modules
|
||||||
|
# This goes into $(exec_prefix)
|
||||||
|
sharedinstall:
|
||||||
|
- $(RUNSHARED) ./$(BUILDPYTHON) -E $(srcdir)/setup.py install \
|
||||||
|
+ $(RUNSHARED) $(HOSTPYTHON) -E $(srcdir)/setup.py install \
|
||||||
|
--prefix=$(prefix) \
|
||||||
|
--install-scripts=$(BINDIR) \
|
||||||
|
--install-platlib=$(DESTSHARED) \
|
||||||
|
@@ -1039,7 +1040,7 @@ frameworkinstallstructure: $(LDLIBRARY)
|
||||||
fi; \
|
fi; \
|
||||||
done
|
done
|
||||||
$(LN) -fsn include/python$(VERSION) $(DESTDIR)$(prefix)/Headers
|
$(LN) -fsn include/python$(VERSION) $(DESTDIR)$(prefix)/Headers
|
||||||
@ -89,7 +84,7 @@ index c2ce5c6..63dc91e 100644
|
|||||||
$(LN) -fsn $(VERSION) $(DESTDIR)$(PYTHONFRAMEWORKINSTALLDIR)/Versions/Current
|
$(LN) -fsn $(VERSION) $(DESTDIR)$(PYTHONFRAMEWORKINSTALLDIR)/Versions/Current
|
||||||
$(LN) -fsn Versions/Current/$(PYTHONFRAMEWORK) $(DESTDIR)$(PYTHONFRAMEWORKINSTALLDIR)/$(PYTHONFRAMEWORK)
|
$(LN) -fsn Versions/Current/$(PYTHONFRAMEWORK) $(DESTDIR)$(PYTHONFRAMEWORKINSTALLDIR)/$(PYTHONFRAMEWORK)
|
||||||
$(LN) -fsn Versions/Current/Headers $(DESTDIR)$(PYTHONFRAMEWORKINSTALLDIR)/Headers
|
$(LN) -fsn Versions/Current/Headers $(DESTDIR)$(PYTHONFRAMEWORKINSTALLDIR)/Headers
|
||||||
@@ -1074,7 +1056,7 @@ frameworkinstallextras:
|
@@ -1081,7 +1082,7 @@ frameworkinstallextras:
|
||||||
# This installs a few of the useful scripts in Tools/scripts
|
# This installs a few of the useful scripts in Tools/scripts
|
||||||
scriptsinstall:
|
scriptsinstall:
|
||||||
SRCDIR=$(srcdir) $(RUNSHARED) \
|
SRCDIR=$(srcdir) $(RUNSHARED) \
|
||||||
@ -98,7 +93,7 @@ index c2ce5c6..63dc91e 100644
|
|||||||
--prefix=$(prefix) \
|
--prefix=$(prefix) \
|
||||||
--install-scripts=$(BINDIR) \
|
--install-scripts=$(BINDIR) \
|
||||||
--root=/$(DESTDIR)
|
--root=/$(DESTDIR)
|
||||||
@@ -1096,7 +1078,7 @@ config.status: $(srcdir)/configure
|
@@ -1103,7 +1104,7 @@ config.status: $(srcdir)/configure
|
||||||
|
|
||||||
# Run reindent on the library
|
# Run reindent on the library
|
||||||
reindent:
|
reindent:
|
||||||
@ -107,7 +102,7 @@ index c2ce5c6..63dc91e 100644
|
|||||||
|
|
||||||
# Rerun configure with the same options as it was run last time,
|
# Rerun configure with the same options as it was run last time,
|
||||||
# provided the config.status script exists
|
# provided the config.status script exists
|
||||||
@@ -1192,7 +1174,7 @@ funny:
|
@@ -1200,7 +1201,7 @@ funny:
|
||||||
|
|
||||||
# Perform some verification checks on any modified files.
|
# Perform some verification checks on any modified files.
|
||||||
patchcheck:
|
patchcheck:
|
||||||
|
@ -1,8 +1,10 @@
|
|||||||
diff --git a/configure.in b/configure.in
|
---
|
||||||
index 14095a1..e7ab47f 100644
|
configure.in | 46 ++++++++++++++++++++++++++++++++++------------
|
||||||
--- a/configure.in
|
1 file changed, 34 insertions(+), 12 deletions(-)
|
||||||
+++ b/configure.in
|
|
||||||
@@ -2559,6 +2559,7 @@ AC_CHECK_LIB(c, inet_aton, [$ac_cv_prog_TRUE],
|
--- Python-2.6.4.orig/configure.in
|
||||||
|
+++ Python-2.6.4/configure.in
|
||||||
|
@@ -2653,6 +2653,7 @@ AC_CHECK_LIB(c, inet_aton, [$ac_cv_prog_
|
||||||
# On Tru64, chflags seems to be present, but calling it will
|
# On Tru64, chflags seems to be present, but calling it will
|
||||||
# exit Python
|
# exit Python
|
||||||
AC_MSG_CHECKING(for chflags)
|
AC_MSG_CHECKING(for chflags)
|
||||||
@ -10,7 +12,7 @@ index 14095a1..e7ab47f 100644
|
|||||||
AC_TRY_RUN([
|
AC_TRY_RUN([
|
||||||
#include <sys/stat.h>
|
#include <sys/stat.h>
|
||||||
#include <unistd.h>
|
#include <unistd.h>
|
||||||
@@ -2568,12 +2569,19 @@ int main(int argc, char*argv[])
|
@@ -2662,12 +2663,19 @@ int main(int argc, char*argv[])
|
||||||
return 1;
|
return 1;
|
||||||
return 0;
|
return 0;
|
||||||
}
|
}
|
||||||
@ -34,7 +36,7 @@ index 14095a1..e7ab47f 100644
|
|||||||
AC_TRY_RUN([
|
AC_TRY_RUN([
|
||||||
#include <sys/stat.h>
|
#include <sys/stat.h>
|
||||||
#include <unistd.h>
|
#include <unistd.h>
|
||||||
@@ -2583,10 +2591,16 @@ int main(int argc, char*argv[])
|
@@ -2677,10 +2685,16 @@ int main(int argc, char*argv[])
|
||||||
return 1;
|
return 1;
|
||||||
return 0;
|
return 0;
|
||||||
}
|
}
|
||||||
@ -55,7 +57,7 @@ index 14095a1..e7ab47f 100644
|
|||||||
|
|
||||||
dnl Check if system zlib has *Copy() functions
|
dnl Check if system zlib has *Copy() functions
|
||||||
dnl
|
dnl
|
||||||
@@ -3664,6 +3664,7 @@ else
|
@@ -3781,6 +3795,7 @@ else
|
||||||
fi
|
fi
|
||||||
|
|
||||||
AC_MSG_CHECKING(for %zd printf() format support)
|
AC_MSG_CHECKING(for %zd printf() format support)
|
||||||
@ -63,7 +65,7 @@ index 14095a1..e7ab47f 100644
|
|||||||
AC_TRY_RUN([#include <stdio.h>
|
AC_TRY_RUN([#include <stdio.h>
|
||||||
#include <stddef.h>
|
#include <stddef.h>
|
||||||
#include <string.h>
|
#include <string.h>
|
||||||
@@ -3697,10 +3698,17 @@ int main()
|
@@ -3814,10 +3829,17 @@ int main()
|
||||||
return 1;
|
return 1;
|
||||||
|
|
||||||
return 0;
|
return 0;
|
||||||
|
@ -1,8 +1,10 @@
|
|||||||
diff --git a/Makefile.pre.in b/Makefile.pre.in
|
---
|
||||||
index a341e63..e949653 100644
|
Makefile.pre.in | 16 ----------------
|
||||||
--- a/Makefile.pre.in
|
1 file changed, 16 deletions(-)
|
||||||
+++ b/Makefile.pre.in
|
|
||||||
@@ -879,22 +879,6 @@ libinstall: build_all $(srcdir)/Lib/$(PLATDIR)
|
--- Python-2.6.4.orig/Makefile.pre.in
|
||||||
|
+++ Python-2.6.4/Makefile.pre.in
|
||||||
|
@@ -887,22 +887,6 @@ libinstall: build_all $(srcdir)/Lib/$(PL
|
||||||
done; \
|
done; \
|
||||||
done
|
done
|
||||||
$(INSTALL_DATA) $(srcdir)/LICENSE $(DESTDIR)$(LIBDEST)/LICENSE.txt
|
$(INSTALL_DATA) $(srcdir)/LICENSE $(DESTDIR)$(LIBDEST)/LICENSE.txt
|
||||||
|
@ -1,7 +1,9 @@
|
|||||||
diff --git a/setup.py b/setup.py
|
---
|
||||||
index 32e1af8..f7f190f 100644
|
setup.py | 15 ++-------------
|
||||||
--- a/setup.py
|
1 file changed, 2 insertions(+), 13 deletions(-)
|
||||||
+++ b/setup.py
|
|
||||||
|
--- Python-2.6.4.orig/setup.py
|
||||||
|
+++ Python-2.6.4/setup.py
|
||||||
@@ -309,9 +309,6 @@ class PyBuildExt(build_ext):
|
@@ -309,9 +309,6 @@ class PyBuildExt(build_ext):
|
||||||
return sys.platform
|
return sys.platform
|
||||||
|
|
||||||
|
@ -1,7 +1,9 @@
|
|||||||
diff --git a/setup.py b/setup.py
|
---
|
||||||
index f7f190f..6ca7a1d 100644
|
setup.py | 30 ------------------------------
|
||||||
--- a/setup.py
|
1 file changed, 30 deletions(-)
|
||||||
+++ b/setup.py
|
|
||||||
|
--- Python-2.6.4.orig/setup.py
|
||||||
|
+++ Python-2.6.4/setup.py
|
||||||
@@ -270,36 +270,6 @@ class PyBuildExt(build_ext):
|
@@ -270,36 +270,6 @@ class PyBuildExt(build_ext):
|
||||||
ext_filename = os.path.join(
|
ext_filename = os.path.join(
|
||||||
self.build_lib,
|
self.build_lib,
|
||||||
@ -36,6 +38,6 @@ index f7f190f..6ca7a1d 100644
|
|||||||
- 'failed with %s: %s' % (ext.name, exc_type, why),
|
- 'failed with %s: %s' % (ext.name, exc_type, why),
|
||||||
- level=3)
|
- level=3)
|
||||||
- self.failed.append(ext.name)
|
- self.failed.append(ext.name)
|
||||||
|
|
||||||
def get_platform(self):
|
|
||||||
|
|
||||||
|
def get_platform(self):
|
||||||
|
# Get value of sys.platform
|
||||||
|
@ -1,8 +1,12 @@
|
|||||||
--- Python-2.5.1/Makefile.pre.in.orig 2008-10-02 12:30:28.000000000 +0200
|
---
|
||||||
+++ Python-2.5.1/Makefile.pre.in 2008-10-02 12:31:50.000000000 +0200
|
Makefile.pre.in | 6 +++---
|
||||||
@@ -996,11 +996,11 @@
|
1 file changed, 3 insertions(+), 3 deletions(-)
|
||||||
|
|
||||||
|
--- Python-2.6.4.orig/Makefile.pre.in
|
||||||
|
+++ Python-2.6.4/Makefile.pre.in
|
||||||
|
@@ -1118,11 +1118,11 @@ TAGS::
|
||||||
# Sanitation targets -- clean leaves libraries, executables and tags
|
# Sanitation targets -- clean leaves libraries, executables and tags
|
||||||
# files, which clobber removes those as well
|
# files, which clobber removes as well
|
||||||
pycremoval:
|
pycremoval:
|
||||||
- find $(srcdir) -name '*.py[co]' -exec rm -f {} ';'
|
- find $(srcdir) -name '*.py[co]' -exec rm -f {} ';'
|
||||||
+ find $(srcdir) ! -path './ipkg-install/*' -name '*.py[co]' -exec rm -f {} ';'
|
+ find $(srcdir) ! -path './ipkg-install/*' -name '*.py[co]' -exec rm -f {} ';'
|
||||||
@ -14,4 +18,4 @@
|
|||||||
+ find . ! -path './ipkg-install/*' -name '*.s[ol]' -exec rm -f {} ';'
|
+ find . ! -path './ipkg-install/*' -name '*.s[ol]' -exec rm -f {} ';'
|
||||||
find $(srcdir)/build -name 'fficonfig.h' -exec rm -f {} ';' || true
|
find $(srcdir)/build -name 'fficonfig.h' -exec rm -f {} ';' || true
|
||||||
find $(srcdir)/build -name 'fficonfig.py' -exec rm -f {} ';' || true
|
find $(srcdir)/build -name 'fficonfig.py' -exec rm -f {} ';' || true
|
||||||
|
-rm -f Lib/lib2to3/*Grammar*.pickle
|
||||||
|
@ -1,8 +1,10 @@
|
|||||||
Index: build_scripts.py
|
---
|
||||||
===================================================================
|
Lib/distutils/command/build_scripts.py | 43 +++------------------------------
|
||||||
--- a/Lib/distutils/command/build_scripts.py
|
1 file changed, 4 insertions(+), 39 deletions(-)
|
||||||
+++ b/Lib/distutils/command/build_scripts.py
|
|
||||||
@@ -52,10 +52,7 @@
|
--- Python-2.6.4.orig/Lib/distutils/command/build_scripts.py
|
||||||
|
+++ Python-2.6.4/Lib/distutils/command/build_scripts.py
|
||||||
|
@@ -54,10 +54,7 @@ class build_scripts (Command):
|
||||||
|
|
||||||
|
|
||||||
def copy_scripts (self):
|
def copy_scripts (self):
|
||||||
@ -14,7 +16,7 @@ Index: build_scripts.py
|
|||||||
"""
|
"""
|
||||||
self.mkpath(self.build_dir)
|
self.mkpath(self.build_dir)
|
||||||
outfiles = []
|
outfiles = []
|
||||||
@@ -78,41 +75,9 @@
|
@@ -80,41 +77,9 @@ class build_scripts (Command):
|
||||||
if not self.dry_run:
|
if not self.dry_run:
|
||||||
raise
|
raise
|
||||||
f = None
|
f = None
|
||||||
|
@ -1,8 +1,10 @@
|
|||||||
Index: Lib/ctypes/__init__.py
|
---
|
||||||
===================================================================
|
Lib/ctypes/__init__.py | 6 ------
|
||||||
--- a/Lib/ctypes/__init__.py (revision 77004)
|
1 file changed, 6 deletions(-)
|
||||||
+++ b/Lib/ctypes/__init__.py (working copy)
|
|
||||||
@@ -538,9 +538,3 @@
|
--- Python-2.6.4.orig/Lib/ctypes/__init__.py
|
||||||
|
+++ Python-2.6.4/Lib/ctypes/__init__.py
|
||||||
|
@@ -538,9 +538,3 @@ for kind in [c_ushort, c_uint, c_ulong,
|
||||||
elif sizeof(kind) == 4: c_uint32 = kind
|
elif sizeof(kind) == 4: c_uint32 = kind
|
||||||
elif sizeof(kind) == 8: c_uint64 = kind
|
elif sizeof(kind) == 8: c_uint64 = kind
|
||||||
del(kind)
|
del(kind)
|
||||||
|
@ -1,6 +1,10 @@
|
|||||||
--- Python-2.6.4/Modules/Setup.dist 2008-11-27 11:15:12.000000000 +0100
|
---
|
||||||
+++ Python-2.6.4/Modules/Setup.dist 2010-02-27 04:14:15.000000000 +0100
|
Modules/Setup.dist | 2 +-
|
||||||
@@ -460,7 +460,7 @@
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
--- Python-2.6.4.orig/Modules/Setup.dist
|
||||||
|
+++ Python-2.6.4/Modules/Setup.dist
|
||||||
|
@@ -460,7 +460,7 @@ GLHACK=-Dclear=__GLclear
|
||||||
# Andrew Kuchling's zlib module.
|
# Andrew Kuchling's zlib module.
|
||||||
# This require zlib 1.1.3 (or later).
|
# This require zlib 1.1.3 (or later).
|
||||||
# See http://www.gzip.org/zlib/
|
# See http://www.gzip.org/zlib/
|
||||||
|
@ -1,7 +1,9 @@
|
|||||||
diff --git a/setup.py b/setup.py
|
---
|
||||||
index 0e08e74..65161db 100644
|
setup.py | 10 ++++++----
|
||||||
--- a/setup.py
|
1 file changed, 6 insertions(+), 4 deletions(-)
|
||||||
+++ b/setup.py
|
|
||||||
|
--- Python-2.6.4.orig/setup.py
|
||||||
|
+++ Python-2.6.4/setup.py
|
||||||
@@ -622,9 +622,10 @@ class PyBuildExt(build_ext):
|
@@ -622,9 +622,10 @@ class PyBuildExt(build_ext):
|
||||||
|
|
||||||
#print 'openssl_ver = 0x%08x' % openssl_ver
|
#print 'openssl_ver = 0x%08x' % openssl_ver
|
||||||
|
Loading…
x
Reference in New Issue
Block a user