Add apr-util from #1713
git-svn-id: svn://svn.openwrt.org/openwrt/packages@7263 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
96c5be8027
commit
4950d49305
74
utils/apr-util/Makefile
Normal file
74
utils/apr-util/Makefile
Normal file
@ -0,0 +1,74 @@
|
|||||||
|
#
|
||||||
|
# Copyright (C) 2006 OpenWrt.org
|
||||||
|
#
|
||||||
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
|
# See /LICENSE for more information.
|
||||||
|
#
|
||||||
|
# crazy_imp
|
||||||
|
|
||||||
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
|
PKG_NAME:=apr-util
|
||||||
|
PKG_VERSION:=0.9.13
|
||||||
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
|
PKG_SOURCE_URL:=http://apache.autinity.de/apr/
|
||||||
|
PKG_MD5SUM:=31e3881af0d9546286b0057717cdb89b
|
||||||
|
PKG_CAT:=zcat
|
||||||
|
|
||||||
|
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||||
|
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
||||||
|
|
||||||
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
|
define Package/apr-util
|
||||||
|
SECTION:=utils
|
||||||
|
CATEGORY:=Utilities
|
||||||
|
DEPENDS:=+libiconv +libexpat
|
||||||
|
TITLE:=Apache Portable Runtime Library Util
|
||||||
|
URL:=http://apr.apache.org/
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Build/Configure
|
||||||
|
$(call Build/Configure/Default, \
|
||||||
|
--with-apr="$(STAGING_DIR)/usr/bin/apr-config" \
|
||||||
|
, \
|
||||||
|
APR_BUILD_DIR="$(STAGING_DIR)/usr/share/build" \
|
||||||
|
CFLAGS="-I$(STAGING_DIR)/usr/lib/libiconv/include/" \
|
||||||
|
)
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Build/Compile
|
||||||
|
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||||
|
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||||
|
all install
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Build/InstallDev
|
||||||
|
mkdir -p $(STAGING_DIR)/usr/bin
|
||||||
|
$(CP) $(PKG_INSTALL_DIR)/usr/bin/apu-config \
|
||||||
|
$(STAGING_DIR)/usr/bin
|
||||||
|
mkdir -p $(STAGING_DIR)/usr/include/apr-0/
|
||||||
|
$(CP) $(PKG_INSTALL_DIR)/usr/include/apr-0/* \
|
||||||
|
$(STAGING_DIR)/usr/include/apr-0/
|
||||||
|
mkdir -p $(STAGING_DIR)/usr/lib
|
||||||
|
$(CP) $(PKG_INSTALL_DIR)/usr/lib/*aprutil* \
|
||||||
|
$(STAGING_DIR)/usr/lib/
|
||||||
|
$(SED) "s,\"/usr\",$(STAGING_DIR)/usr," $(STAGING_DIR)/usr/bin/apu-config
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Build/UninstallDev
|
||||||
|
rm $(STAGING_DIR)/usr/bin/apu-config \
|
||||||
|
$(STAGING_DIR)/usr/include/apr-0/{apr_anylock.h,apr_base64.h,apr_buckets.h,apr_date.h,apr_dbm.h,apr_hooks.h,apr_ldap.h,apr_ldap_url.h,apr_md4.h,apr_md5.h,apr_optional.h,apr_optional_hooks.h,apr_queue.h,apr_reslist.h,apr_rmm.h,apr_sdbm.h,apr_sha1.h,apr_strmatch.h,apr_uri.h,apr_uuid.h,apr_xlate.h,apr_xml.h,apu_compat.h,apu.h,apu_version.h,apu_want.h} \
|
||||||
|
$(STAGING_DIR)/usr/lib/*aprutil*
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/apr-util/install
|
||||||
|
$(INSTALL_DIR) $(1)/usr/bin
|
||||||
|
$(CP) $(PKG_INSTALL_DIR)/usr/bin/apu-config $(1)/usr/bin/
|
||||||
|
$(INSTALL_DIR) $(1)/usr/lib
|
||||||
|
$(CP) $(PKG_INSTALL_DIR)/usr/lib/* $(1)/usr/lib/
|
||||||
|
endef
|
||||||
|
|
||||||
|
$(eval $(call BuildPackage,apr-util))
|
13
utils/apr-util/patches/000-configure.patch
Normal file
13
utils/apr-util/patches/000-configure.patch
Normal file
@ -0,0 +1,13 @@
|
|||||||
|
diff -ur apr-util-0.9.13-old/configure apr-util-0.9.13/configure
|
||||||
|
--- apr-util-0.9.13-old/configure 2006-11-29 13:01:46.000000000 +0100
|
||||||
|
+++ apr-util-0.9.13/configure 2007-05-15 02:12:29.000000000 +0200
|
||||||
|
@@ -2039,9 +2039,6 @@
|
||||||
|
{ (exit 1); exit 1; }; }
|
||||||
|
fi
|
||||||
|
|
||||||
|
- APR_BUILD_DIR="`$apr_config --installbuilddir`"
|
||||||
|
-
|
||||||
|
- APR_BUILD_DIR="`cd $APR_BUILD_DIR && pwd`"
|
||||||
|
|
||||||
|
APR_INCLUDES="`$apr_config --includes`"
|
||||||
|
APR_LIBS="`$apr_config --link-libtool --libs`"
|
24
utils/apr-util/patches/001-libtool.patch
Normal file
24
utils/apr-util/patches/001-libtool.patch
Normal file
@ -0,0 +1,24 @@
|
|||||||
|
diff -ur apr-util-0.9.13-old/xml/expat/aclocal.m4 apr-util-0.9.13/xml/expat/aclocal.m4
|
||||||
|
--- apr-util-0.9.13-old/xml/expat/aclocal.m4 2006-11-29 13:01:46.000000000 +0100
|
||||||
|
+++ apr-util-0.9.13/xml/expat/aclocal.m4 2007-05-15 10:38:44.000000000 +0200
|
||||||
|
@@ -69,7 +69,7 @@
|
||||||
|
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
|
||||||
|
|
||||||
|
# Always use our own libtool.
|
||||||
|
-LIBTOOL='$(SHELL) $(top_builddir)/libtool'
|
||||||
|
+LIBTOOL='$(SHELL) libtool'
|
||||||
|
AC_SUBST(LIBTOOL)dnl
|
||||||
|
|
||||||
|
# Prevent multiple expansion
|
||||||
|
diff -ur apr-util-0.9.13-old/xml/expat/configure apr-util-0.9.13/xml/expat/configure
|
||||||
|
--- apr-util-0.9.13-old/xml/expat/configure 2006-11-29 13:01:59.000000000 +0100
|
||||||
|
+++ apr-util-0.9.13/xml/expat/configure 2007-05-15 10:59:40.000000000 +0200
|
||||||
|
@@ -19162,7 +19162,7 @@
|
||||||
|
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
|
||||||
|
|
||||||
|
# Always use our own libtool.
|
||||||
|
-LIBTOOL='$(SHELL) $(top_builddir)/libtool'
|
||||||
|
+LIBTOOL='$(SHELL) libtool'
|
||||||
|
|
||||||
|
# Prevent multiple expansion
|
||||||
|
|
28
utils/apr-util/patches/002-uri_delims.patch
Normal file
28
utils/apr-util/patches/002-uri_delims.patch
Normal file
@ -0,0 +1,28 @@
|
|||||||
|
diff -Nur apr-util-0.9.13-old/uri/Makefile.in apr-util-0.9.13/uri/Makefile.in
|
||||||
|
--- apr-util-0.9.13-old/uri/Makefile.in 2004-11-25 00:45:40.000000000 +0100
|
||||||
|
+++ apr-util-0.9.13/uri/Makefile.in 2007-05-15 14:05:15.000000000 +0200
|
||||||
|
@@ -15,4 +15,3 @@
|
||||||
|
apr_uri.lo: uri_delims.h apr_uri.c
|
||||||
|
|
||||||
|
uri_delims.h: gen_uri_delims
|
||||||
|
- ./gen_uri_delims > uri_delims.h
|
||||||
|
diff -Nur apr-util-0.9.13-old/uri/uri_delims.h apr-util-0.9.13/uri/uri_delims.h
|
||||||
|
--- apr-util-0.9.13-old/uri/uri_delims.h 1970-01-01 01:00:00.000000000 +0100
|
||||||
|
+++ apr-util-0.9.13/uri/uri_delims.h 2007-05-15 14:01:53.000000000 +0200
|
||||||
|
@@ -0,0 +1,16 @@
|
||||||
|
+/* this file is automatically generated by gen_uri_delims, do not edit */
|
||||||
|
+static const unsigned char uri_delims[256] = {
|
||||||
|
+ T_NUL,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,
|
||||||
|
+ 0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,T_HASH,0,0,0,0,
|
||||||
|
+ 0,0,0,0,0,0,0,T_SLASH,0,0,0,0,0,0,0,0,0,0,T_COLON,0,
|
||||||
|
+ 0,0,0,T_QUESTION,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,
|
||||||
|
+ 0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,
|
||||||
|
+ 0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,
|
||||||
|
+ 0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,
|
||||||
|
+ 0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,
|
||||||
|
+ 0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,
|
||||||
|
+ 0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,
|
||||||
|
+ 0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,
|
||||||
|
+ 0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,
|
||||||
|
+ 0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0
|
||||||
|
+};
|
Loading…
x
Reference in New Issue
Block a user