fix peerguardian build
git-svn-id: svn://svn.openwrt.org/openwrt/packages@5361 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
fa7deb2e71
commit
4ad2d9ae97
@ -1,3 +1,4 @@
|
|||||||
|
#
|
||||||
# Copyright (C) 2006 OpenWrt.org
|
# Copyright (C) 2006 OpenWrt.org
|
||||||
#
|
#
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
@ -10,23 +11,26 @@ include $(TOPDIR)/rules.mk
|
|||||||
PKG_NAME:=peerguardian
|
PKG_NAME:=peerguardian
|
||||||
PKG_VERSION:=1.5beta
|
PKG_VERSION:=1.5beta
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
PKG_MD5SUM:=0fb2bc5501b031604fc56eec3bd35fa4
|
|
||||||
|
|
||||||
PKG_SOURCE_URL:=@SF/peerguardian
|
|
||||||
PKG_SOURCE:=pglinux-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=pglinux-$(PKG_VERSION).tar.gz
|
||||||
PKG_BUILD_DIR:=$(BUILD_DIR)/pglinux-$(PKG_VERSION)
|
PKG_SOURCE_URL:=@SF/peerguardian
|
||||||
|
PKG_MD5SUM:=0fb2bc5501b031604fc56eec3bd35fa4
|
||||||
PKG_CAT:=zcat
|
PKG_CAT:=zcat
|
||||||
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
|
||||||
|
PKG_BUILD_DIR:=$(BUILD_DIR)/pglinux-$(PKG_VERSION)
|
||||||
|
|
||||||
|
PKG_BUILDDEP:=iptables
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
define Package/peerguardian
|
define Package/peerguardian
|
||||||
SECTION:=net
|
SECTION:=net
|
||||||
CATEGORY:=Network
|
CATEGORY:=Network
|
||||||
DEPENDS:=@BROKEN +libpthread +libncurses +iptables
|
DEPENDS:= +libpthread +libncurses
|
||||||
TITLE:=PeerGuardian for Linux
|
TITLE:=PeerGuardian for Linux
|
||||||
DESCRIPTION:=PeerGuardian helps protect your privacy by blocking many ranges\\\
|
DESCRIPTION:=\
|
||||||
of aggressive IPs while you use P2P.\\\
|
PeerGuardian helps protect your privacy by blocking many ranges \\\
|
||||||
|
of aggressive IPs while you use P2P.
|
||||||
URL:=http://phoenixlabs.org/
|
URL:=http://phoenixlabs.org/
|
||||||
endef
|
endef
|
||||||
|
|
||||||
@ -35,13 +39,31 @@ define Package/peerguardian/conffiles
|
|||||||
/etc/p2p.p2b.p2p
|
/etc/p2p.p2b.p2p
|
||||||
endef
|
endef
|
||||||
|
|
||||||
|
# commas are interpreted by the $(call ...) macro, so define an intermediate variable holding our settings
|
||||||
|
PKG_CONFIGURE_LIBS:=-Wl,-Bdynamic,-luClibc++,-Bstatic,-lstdc++,-Bdynamic,-lm,-lc
|
||||||
|
|
||||||
|
define Build/Configure
|
||||||
|
$(call Build/Configure/Default, \
|
||||||
|
, \
|
||||||
|
CXXFLAGS="$$$$CXXFLAGS $$$$CPPFLAGS -fno-builtin -fno-rtti" \
|
||||||
|
LIBS="$(PKG_CONFIGURE_LIBS)" \
|
||||||
|
)
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Build/Compile
|
||||||
|
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||||
|
CXXLD="$(TARGET_CC)"
|
||||||
|
endef
|
||||||
|
|
||||||
define Package/peerguardian/install
|
define Package/peerguardian/install
|
||||||
install -d -m0755 $(1)/usr/sbin $(1)/etc/init.d
|
install -d -m0755 $(1)/etc
|
||||||
install -m0755 $(PKG_BUILD_DIR)/peerguardnf $(1)/usr/sbin/
|
|
||||||
install -m0755 $(PKG_BUILD_DIR)/pgtext $(1)/usr/sbin/
|
|
||||||
install -m0644 $(PKG_BUILD_DIR)/PG.conf $(1)/etc/
|
install -m0644 $(PKG_BUILD_DIR)/PG.conf $(1)/etc/
|
||||||
install -m0644 $(PKG_BUILD_DIR)/p2p.p2b.p2p $(1)/etc/
|
install -m0644 $(PKG_BUILD_DIR)/p2p.p2b.p2p $(1)/etc/
|
||||||
install -m0644 files/peerguardian.init $(1)/etc/init.d/peerguardian
|
install -d -m0755 $(1)/usr/sbin
|
||||||
|
install -m0755 $(PKG_BUILD_DIR)/peerguardnf $(1)/usr/sbin/
|
||||||
|
install -m0755 $(PKG_BUILD_DIR)/pgtext $(1)/usr/sbin/
|
||||||
|
install -d -m0755 $(1)/etc/init.d
|
||||||
|
install -m0644 ./files/peerguardian.init $(1)/etc/init.d/peerguardian
|
||||||
endef
|
endef
|
||||||
|
|
||||||
$(eval $(call BuildPackage,peerguardian))
|
$(eval $(call BuildPackage,peerguardian))
|
||||||
|
@ -1,16 +0,0 @@
|
|||||||
diff -urN pglinux-1.5beta/Makefile.in pglinux-1.5beta/Makefile.in
|
|
||||||
--- pglinux-1.5beta/Makefile.in 2005-03-31 09:40:29.000000000 +0200
|
|
||||||
+++ pglinux-1.5beta/Makefile.in 2005-11-25 19:14:16.000000000 +0100
|
|
||||||
@@ -83,10 +83,10 @@
|
|
||||||
PROGRAMS = $(mybin_PROGRAMS)
|
|
||||||
|
|
||||||
|
|
||||||
-DEFS = @DEFS@ -I. -I$(srcdir) -I.
|
|
||||||
+DEFS = @DEFS@ -I. -I$(srcdir) -I. -I$(STAGING_DIR)/usr/include
|
|
||||||
CPPFLAGS = @CPPFLAGS@
|
|
||||||
LDFLAGS = @LDFLAGS@
|
|
||||||
-LIBS = @LIBS@
|
|
||||||
+LIBS = @LIBS@ -L$(STAGING_DIR)/usr/lib
|
|
||||||
peerguardnf_OBJECTS = Main.o PeerGuard.o BlockList.o Blocker_Linux.o \
|
|
||||||
Blocker_BSD.o HttpServer.o HttpRequest.o sha1.o
|
|
||||||
peerguardnf_DEPENDENCIES =
|
|
14
net/peerguardian/patches/01-no_host_includes.patch
Normal file
14
net/peerguardian/patches/01-no_host_includes.patch
Normal file
@ -0,0 +1,14 @@
|
|||||||
|
diff -ruN pglinux-1.5beta-old/Makefile.in pglinux-1.5beta-new/Makefile.in
|
||||||
|
--- pglinux-1.5beta-old/Makefile.in 2005-03-31 09:40:29.000000000 +0200
|
||||||
|
+++ pglinux-1.5beta-new/Makefile.in 2006-10-31 17:04:22.000000000 +0100
|
||||||
|
@@ -74,8 +74,8 @@
|
||||||
|
pgtext_SOURCES = pgtext.cpp
|
||||||
|
peerguardnf_LDADD = -lipq -lpthread
|
||||||
|
pgtext_LDADD = -lncurses -lpthread
|
||||||
|
-peerguardnf_LDFLAGS = $(all_includes) -I/usr/include/libipq
|
||||||
|
-AM_CPPFLAGS = $(ALL_INCLUDES) -I/usr/include/libipq
|
||||||
|
+peerguardnf_LDFLAGS = $(all_includes)
|
||||||
|
+AM_CPPFLAGS = $(ALL_INCLUDES)
|
||||||
|
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
|
||||||
|
mkinstalldirs = $(SHELL) $(top_srcdir)/../mkinstalldirs
|
||||||
|
CONFIG_HEADER = config.h
|
Loading…
x
Reference in New Issue
Block a user