Upgrade httping to 1.2.2 (#1414)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@6405 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
93f71a5e36
commit
4ba1c9b85a
@ -9,12 +9,12 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=httping
|
PKG_NAME:=httping
|
||||||
PKG_VERSION:=1.0.10
|
PKG_VERSION:=1.2.2
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
|
||||||
PKG_SOURCE_URL:=http://www.vanheusden.com/httping/
|
PKG_SOURCE_URL:=http://www.vanheusden.com/httping/
|
||||||
PKG_MD5SUM:=998b00b8babeb3196d28c20ad87d9c15
|
PKG_MD5SUM:=cde335c0110fb1b156afdf80ff5ade1d
|
||||||
PKG_CAT:=zcat
|
PKG_CAT:=zcat
|
||||||
|
|
||||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||||
|
@ -1,14 +1,14 @@
|
|||||||
diff -urN httping-1.0.10.orig/Makefile httping-1.0.10/Makefile
|
diff -ruaN httping-1.2.2.orig/Makefile httping-1.2.2/Makefile
|
||||||
--- httping-1.0.10.orig/Makefile 2006-01-02 17:07:29.000000000 +0100
|
--- httping-1.2.2.orig/Makefile 2006-11-09 20:13:12.000000000 +0100
|
||||||
+++ httping-1.0.10/Makefile 2006-02-13 13:44:45.066590304 +0100
|
+++ httping-1.2.2/Makefile 2007-02-27 11:34:47.000000000 +0100
|
||||||
@@ -15,8 +15,8 @@
|
@@ -15,8 +15,8 @@
|
||||||
VERSION=1.0.10
|
include version
|
||||||
|
|
||||||
DEBUG=-g
|
DEBUG=-g # -D_DEBUG
|
||||||
-LDFLAGS+=-lssl -lcrypto $(DEBUG)
|
-LDFLAGS+=-lssl -lcrypto $(DEBUG)
|
||||||
-CFLAGS+=-O2 -Wall -DVERSION=\"$(VERSION)\" $(DEBUG)
|
-CFLAGS+=-O2 -Wall -DVERSION=\"$(VERSION)\" $(DEBUG)
|
||||||
+LDFLAGS+=$(EXTRA_LDFLAGS) -lssl -lcrypto $(DEBUG)
|
+LDFLAGS+=$(EXTRA_LDFLAGS) -lssl -lcrypto $(DEBUG)
|
||||||
+CFLAGS+=$(EXTRA_CFLAGS) -Wall -DVERSION=\"$(VERSION)\" $(DEBUG)
|
+CFLAGS+=$(EXTRA_CFLAGS) -Wall -DVERSION=\"$(VERSION)\" $(DEBUG)
|
||||||
|
|
||||||
OBJS=http.o io.o str.o error.o utils.o main.o tcp.o mssl.o res.o
|
OBJS=mem.o http.o io.o str.o error.o utils.o main.o tcp.o mssl.o res.o
|
||||||
|
|
||||||
|
@ -1,16 +1,16 @@
|
|||||||
diff -urN httping-1.0.10/main.c httping-1.0.10.new/main.c
|
diff -ruaN httping-1.2.2.orig/main.c httping-1.2.2/main.c
|
||||||
--- httping-1.0.10/main.c 2006-01-02 17:07:29.000000000 +0100
|
--- httping-1.2.2.orig/main.c 2006-11-09 20:13:12.000000000 +0100
|
||||||
+++ httping-1.0.10.new/main.c 2007-02-27 11:14:32.000000000 +0100
|
+++ httping-1.2.2/main.c 2007-02-27 11:38:14.000000000 +0100
|
||||||
@@ -38,6 +38,8 @@
|
@@ -40,6 +40,8 @@
|
||||||
#include "utils.h"
|
#include "utils.h"
|
||||||
#include "error.h"
|
#include "error.h"
|
||||||
|
|
||||||
+#define VERSION "1.0.10"
|
+#define VERSION "1.2.2"
|
||||||
+
|
+
|
||||||
static volatile int stop = 0;
|
static volatile int stop = 0;
|
||||||
|
|
||||||
int quiet = 0;
|
int quiet = 0;
|
||||||
@@ -48,7 +50,7 @@
|
@@ -50,7 +52,7 @@
|
||||||
|
|
||||||
void version(void)
|
void version(void)
|
||||||
{
|
{
|
||||||
@ -19,12 +19,12 @@ diff -urN httping-1.0.10/main.c httping-1.0.10.new/main.c
|
|||||||
#ifndef NO_SSL
|
#ifndef NO_SSL
|
||||||
fprintf(stderr, "SSL support included\n");
|
fprintf(stderr, "SSL support included\n");
|
||||||
#endif
|
#endif
|
||||||
@@ -382,7 +384,7 @@
|
@@ -413,7 +415,7 @@
|
||||||
if (useragent)
|
if (useragent)
|
||||||
sprintf(&request[strlen(request)], "User-Agent: %s\r\n", useragent);
|
sprintf(&request[strlen(request)], "User-Agent: %s\r\n", useragent);
|
||||||
else
|
else
|
||||||
- sprintf(&request[strlen(request)], "User-Agent: HTTPing v" VERSION "\r\n");
|
- sprintf(&request[strlen(request)], "User-Agent: HTTPing v" VERSION "\r\n");
|
||||||
+ sprintf(&request[strlen(request)], "User-Agent: HTTPing v%s\r\n", VERSION);
|
+ sprintf(&request[strlen(request)], "User-Agent: HTTPing v%s\r\n", VERSION);
|
||||||
|
sprintf(&request[strlen(request)], "Host: %s\r\n", hostname);
|
||||||
if (referer)
|
if (referer)
|
||||||
sprintf(&request[strlen(request)], "Referer: %s\r\n", referer);
|
sprintf(&request[strlen(request)], "Referer: %s\r\n", referer);
|
||||||
strcat(request, "\r\n");
|
|
||||||
|
Loading…
x
Reference in New Issue
Block a user