Port socat to -ng
git-svn-id: svn://svn.openwrt.org/openwrt/packages@4536 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
48de5f771f
commit
4bb77395f6
53
net/socat/Makefile
Normal file
53
net/socat/Makefile
Normal file
@ -0,0 +1,53 @@
|
||||
#
|
||||
# Copyright (C) 2006 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
# $Id$
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=socat
|
||||
PKG_VERSION:=1.4.3.0
|
||||
PKG_RELEASE:=1
|
||||
PKG_MD5SUM:=ce574e75c2fda4456e8efd4efb86ec5e
|
||||
|
||||
PKG_SOURCE_URL:=http://www.dest-unreach.org/socat/download/
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_CAT:=bzcat
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-1.4
|
||||
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/socat
|
||||
SECTION:=net
|
||||
CATEGORY:=Network
|
||||
DEPENDS:=+libopenssl +libpthread
|
||||
TITLE:=A multipurpose relay (SOcket CAT)
|
||||
DESCRIPTION:=SoCat (for SOcket CAT) establishes two bidirectional byte streams and\\\
|
||||
transfers data between them.\\\
|
||||
Data channels may be files, pipes, devices (terminal or modem, etc.), or\\\
|
||||
sockets (Unix, IPv4, IPv6, raw, UDP, TCP, SSL). It provides forking,\\\
|
||||
logging and tracing, different modes for interprocess communication and\\\
|
||||
many more options.\\\
|
||||
URL:=http://www.dest-unreach.org/socat/
|
||||
endef
|
||||
|
||||
define Build/Configure
|
||||
$(call Build/Configure/Default,--disable-libwrap \
|
||||
--disable-readline, sc_cv_termios_ispeed="no")
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
$(call Build/Compile/Default, DESTDIR="$(PKG_INSTALL_DIR)" all install)
|
||||
endef
|
||||
|
||||
define Package/socat/install
|
||||
install -d -m0755 $(1)/usr/bin
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/bin/socat $(1)/usr/bin/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,socat))
|
13
net/socat/patches/501-honor_ldflags.patch
Normal file
13
net/socat/patches/501-honor_ldflags.patch
Normal file
@ -0,0 +1,13 @@
|
||||
diff -ruN socat-1.4-old/Makefile.in socat-1.4-new/Makefile.in
|
||||
--- socat-1.4-old/Makefile.in 2005-09-10 22:09:11.000000000 +0200
|
||||
+++ socat-1.4-new/Makefile.in 2005-10-08 17:12:45.000000000 +0200
|
||||
@@ -36,7 +36,8 @@
|
||||
|
||||
#0 CFLAGS = @CFLAGS@ $(CCOPTS) $(DEFS) $(INCLS)
|
||||
CFLAGS = @CFLAGS@ $(CCOPTS) $(DEFS) $(CPPFLAGS)
|
||||
-CLIBS = $(LIBS)
|
||||
+LDFLAGS = @LDFLAGS@
|
||||
+CLIBS = $(LDFLAGS) $(LIBS)
|
||||
#CLIBS = $(LIBS) -lm -lefence
|
||||
XIOSRCS = xioinitialize.c xiohelp.c xioparam.c xiodiag.c xioopen.c xioopts.c \
|
||||
xiosignal.c xiosigchld.c xioread.c xiowrite.c \
|
Loading…
x
Reference in New Issue
Block a user