Port sablevm to -ng

git-svn-id: svn://svn.openwrt.org/openwrt/packages@4520 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
florian 2006-08-08 09:05:12 +00:00
parent b0a2b5f7aa
commit 4bcbf5784e
2 changed files with 74 additions and 0 deletions

59
lang/sablevm/Makefile Normal file
View File

@ -0,0 +1,59 @@
#
# Copyright (C) 2006 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
# $Id$
include $(TOPDIR)/rules.mk
PKG_NAME:=sablevm
PKG_VERSION:=1.13
PKG_RELEASE:=1
PKG_MD5SUM:=d5828200032bfe921dd43e450931e38c
PKG_SOURCE_URL:=http://sablevm.org/download/release/$(PKG_VERSION)/
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_CAT:=zcat
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
include $(INCLUDE_DIR)/package.mk
define Package/sablevm
SECTION:=lang
CATEGORY:=Languages
DEPENDS:=+libffi-sable +libltdl +libpopt +libpthread +zlib
TITLE:=A Java Virtual Machine (JVM) implementation
DESCRIPTION:=SableVM is a robust, extremely portable, efficient, and specifications-\\\
-compliant Java virtual machine that aims to be easy to maintain and to\\\
extend. It features a state-of-the-art and efficient interpreter engine.\\\
Its source code is very accessible and easy to understand. It also has\\\
many robustness features that have been the object of careful design. \\\
URL:=http://sablevm.org/
endef
define Build/Configure
$(call Build/Configure/Default,--enable-shared \
--disable-static, LDFLAGS="-L$(STAGING_DIR)/usr/lib -lffi -lltdl -lpopt -lz")
endef
define Build/Compile
rm -rf $(PKG_INSTALL_DIR)
mkdir -p $(PKG_INSTALL_DIR)
$(MAKE) -C $(PKG_BUILD_DIR) \
DESTDIR="$(PKG_INSTALL_DIR)" \
all install
endef
define Package/sablevm/install
install -m0755 -d $(1)/usr/bin
$(CP) $(PKG_INSTALL_DIR)/usr/bin/{java-,}sablevm $(1)/usr/bin/
install -m0755 -d $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libsablevm-*.so $(1)/usr/lib/
endef
$(eval $(call BuildPackage,sablevm))

View File

@ -0,0 +1,15 @@
diff -ruN sablevm-1.11.1-orig/src/libsablevm/system.h sablevm-1.11.1-1/src/libsablevm/system.h
--- sablevm-1.11.1-orig/src/libsablevm/system.h 2005-03-18 01:25:09.000000000 +0100
+++ sablevm-1.11.1-1/src/libsablevm/system.h 2005-03-22 01:05:19.000000000 +0100
@@ -279,9 +279,9 @@
#elif defined (_SABLEVM_COPY_GC) || (_SABLEVM_GENCOPY_GC)
-#define SVM_HEAP_DEFAULT_MIN_SIZE 16777216
+#define SVM_HEAP_DEFAULT_MIN_SIZE 1048576
#define SVM_HEAP_DEFAULT_MAX_SIZE 0
-#define SVM_HEAP_DEFAULT_ALLOCATION_INCREMENT 1048576
+#define SVM_HEAP_DEFAULT_ALLOCATION_INCREMENT 65536
#if defined (_SABLEVM_GENCOPY_GC)