cleanup Makefile, extract image-data, add init-script, replace generic image with a smaller one (320x320)

git-svn-id: svn://svn.openwrt.org/openwrt/packages@15812 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
mirko 2009-05-13 07:23:33 +00:00
parent abc77c0a23
commit 4c09e0b9dc
6 changed files with 5545 additions and 12062 deletions

View File

@ -15,6 +15,10 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://projects.o-hand.com/sources/psplash/
PKG_MD5SUM:=7649b7e0fac573eca2048a2a267e242b
PKG_INSTALL:=1
IMAGE_FILE:=generic
include $(INCLUDE_DIR)/package.mk
define Package/psplash
@ -29,20 +33,21 @@ define Package/psplash/description
PSplash is a userspace graphical boot splash screen.
endef
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) \
DESTDIR="$(PKG_INSTALL_DIR)" \
all install
define Build/Configure
$(CP) \
./files/image_$(IMAGE_FILE).h \
$(PKG_BUILD_DIR)/psplash-owrt-img.h
$(call Build/Configure/Default)
endef
define Package/psplash/install
$(INSTALL_DIR) $(1)/bin
$(INSTALL_DIR) $(1)/bin $(1)/etc/init.d
$(CP) \
$(PKG_INSTALL_DIR)/usr/bin/psplash \
$(PKG_INSTALL_DIR)/usr/bin/psplash-write \
$(PKG_INSTALL_DIR)/usr/bin/psplash* \
$(1)/bin/
$(INSTALL_BIN) \
./files/init \
$(1)/etc/init.d/psplash
endef
$(eval $(call BuildPackage,psplash))

File diff suppressed because it is too large Load Diff

11
utils/psplash/files/init Executable file
View File

@ -0,0 +1,11 @@
#!/bin/sh /etc/rc.common
# Copyright (C) 2006 OpenWrt.org
START=05
start() {
psplash &
}
stop() {
killall psplash
}

File diff suppressed because it is too large Load Diff

View File

@ -0,0 +1,42 @@
--- psplash.orig/psplash.c 2009-05-11 15:45:57.000000000 +0200
+++ psplash/psplash.c 2009-05-13 00:21:20.000000000 +0200
@@ -19,11 +19,11 @@
*/
#include "psplash.h"
-#include "psplash-hand-img.h"
+#include "psplash-owrt-img.h"
#include "psplash-bar-img.h"
#include "radeon-font.h"
-#define MSG ""
+#define MSG "Loading - please wait..."
void
psplash_exit (int signum)
@@ -263,17 +263,17 @@
goto fb_fail;
}
- /* Clear the background with #ecece1 */
- psplash_fb_draw_rect (fb, 0, 0, fb->width, fb->height, 0xec, 0xec, 0xe1);
+ /* Clear the background with #192a65 */
+ psplash_fb_draw_rect (fb, 0, 0, fb->width, fb->height, 0x19, 0x2a, 0x65);
/* Draw the OH logo */
psplash_fb_draw_image (fb,
- (fb->width - HAND_IMG_WIDTH)/2,
- (fb->height - HAND_IMG_HEIGHT)/2,
- HAND_IMG_WIDTH,
- HAND_IMG_HEIGHT,
- HAND_IMG_BYTES_PER_PIXEL,
- HAND_IMG_RLE_PIXEL_DATA);
+ 0,
+ 0,
+ OWRT_IMG_WIDTH,
+ OWRT_IMG_HEIGHT,
+ OWRT_IMG_BYTES_PER_PIXEL,
+ OWRT_IMG_RLE_PIXEL_DATA);
/* Draw progress bar border */
psplash_fb_draw_image (fb,

View File

@ -1,6 +1,6 @@
diff -ruN psplash/psplash.c psplash.x/psplash.c
--- psplash/psplash.c 2009-05-11 23:55:59.000000000 +0200
+++ psplash.x/psplash.c 2009-05-11 23:38:22.000000000 +0200
diff -ruN psplash.x/psplash.c psplash/psplash.c
--- psplash.x/psplash.c 2009-05-12 10:11:25.000000000 +0200
+++ psplash/psplash.c 2009-05-12 10:24:09.000000000 +0200
@@ -276,17 +276,17 @@
OWRT_IMG_RLE_PIXEL_DATA);