[package] add libvncserver (#5093)

git-svn-id: svn://svn.openwrt.org/openwrt/packages@15894 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
florian 2009-05-17 15:42:30 +00:00
parent 4bf00ca578
commit 4c18fca500
2 changed files with 70 additions and 0 deletions

View File

@ -0,0 +1,57 @@
#
# Copyright (C) 2009 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
PKG_NAME:=LibVNCServer
PKG_VERSION:=0.9.7
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/libvncserver
PKG_MD5SUM:=14af5bdae461df4666c18e5f83c150c4
PKG_FIXUP:=libtool
include $(INCLUDE_DIR)/package.mk
PKG_INSTALL=1
define Package/libvncserver
SECTION:=libs
CATEGORY:=Libraries
DEPENDS:=+zlib +libiconv
TITLE:=VNC Server Library
endef
CONFIGURE_ARGS += \
--without-xkeyboard \
--without-xinerama \
--without-xrandr \
--without-xfixes \
--without-xdamage \
--without-xtrap \
--without-xrecord \
--without-fbpm \
--without-dpms \
--without-filetransfer \
--without-macosx-native \
--without-ssl \
--without-avahi
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/{lib,include,bin}
$(CP) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin
$(CP) $(PKG_INSTALL_DIR)/usr/lib/lib* $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
endef
define Package/libvncserver/install
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/lib*so* $(1)/usr/lib/
endef
$(eval $(call BuildPackage,libvncserver))

View File

@ -0,0 +1,13 @@
--- LibVNCServer-0.9.7/Makefile.in.orig 2009-01-12 03:53:15.000000000 +0100
+++ LibVNCServer-0.9.7/Makefile.in 2009-05-02 00:23:00.000000000 +0200
@@ -228,8 +228,8 @@
target_alias = @target_alias@
with_ffmpeg = @with_ffmpeg@
@WITH_X11VNC_TRUE@X11VNC = x11vnc
-SUBDIRS = libvncserver examples contrib libvncclient vncterm classes client_examples test $(X11VNC)
-DIST_SUBDIRS = libvncserver examples contrib libvncclient vncterm classes client_examples test
+SUBDIRS = libvncserver
+DIST_SUBDIRS = libvncserver
bin_SCRIPTS = libvncserver-config
#include_HEADERS=rfb.h rfbconfig.h rfbint.h rfbproto.h keysym.h rfbregion.h
include_HEADERS = rfb/rfb.h rfb/rfbconfig.h rfb/rfbint.h rfb/rfbproto.h \