Port fetchmail to -ng

git-svn-id: svn://svn.openwrt.org/openwrt/packages@4379 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
florian 2006-08-01 20:19:55 +00:00
parent e210233b5f
commit 4c5fdf43b4
3 changed files with 119 additions and 0 deletions

55
utils/fetchmail/Makefile Normal file
View File

@ -0,0 +1,55 @@
#
# Copyright (C) 2006 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
# $Id$
include $(TOPDIR)/rules.mk
PKG_NAME:=fetchmail
PKG_VERSION:=6.2.5
PKG_RELEASE:=1
PKG_MD5SUM:=9956b30139edaa4f5f77c4d0dbd80225
PKG_SOURCE_URL:=http://www.catb.org/~esr/fetchmail/
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_CAT:=zcat
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
include $(INCLUDE_DIR)/package.mk
define Package/fetchmail
SECTION:=utils
CATEGORY:=Utilities
TITLE:=Remote mail retriever
DESCRIPTION:=Retrieves remote mail via POP/IMAP\\\
Very useful in conjunction with mutt.
URL:=http://www.catb.org/~esr/fetchmail/
endef
define Build/Configure
$(call Build/Configure/Default,--enable-fallback=procmail --without-hesiod,ac_cv_c_bigendian=no \
ac_cv_sizeof_off_t=8 \
ac_cv_sizeof_int=4 \
ac_cv_sizeof_long=4 \
)
endef
define Build/Compile
rm -rf $(PKG_INSTALL_DIR)
mkdir -p $(PKG_INSTALL_DIR)
$(MAKE) -C $(PKG_BUILD_DIR) \
DESTDIR="$(PKG_INSTALL_DIR)" \
all install
endef
define Package/fetchmail/install
mkdir -p $(1)/usr/bin
$(CP) $(PKG_INSTALL_DIR)/usr/bin/$(PKG_NAME) $(1)/usr/bin/
endef
$(eval $(call BuildPackage,fetchmail))

View File

@ -0,0 +1,43 @@
diff -urN fetchmail-6.2.5/config.sub fetchmail-6.2.5.new/config.sub
--- fetchmail-6.2.5/config.sub 2003-07-17 03:03:20.000000000 +0200
+++ fetchmail-6.2.5.new/config.sub 2006-03-30 00:36:11.000000000 +0200
@@ -176,7 +176,7 @@
| 580 | i960 | h8300 \
| x86 | ppcbe | mipsbe | mipsle | shbe | shle | armbe | armle \
| hppa | hppa1.0 | hppa1.1 | hppa2.0 | hppa2.0w | hppa2.0n \
- | hppa64 \
+ | hppa64 | x86_64 \
| alpha | alphaev[4-8] | alphaev56 | alphapca5[67] \
| alphaev6[78] \
| we32k | ns16k | clipper | i370 | sh | powerpc | powerpcle \
@@ -194,7 +194,7 @@
# We use `pc' rather than `unknown'
# because (1) that's what they normally are, and
# (2) the word "unknown" tends to confuse beginning users.
- i[34567]86)
+ i*86 | x86_64)
basic_machine=$basic_machine-pc
;;
# Object if more than one company name word.
@@ -209,7 +209,7 @@
| mips-* | pyramid-* | tron-* | a29k-* | romp-* | rs6000-* \
| power-* | none-* | 580-* | cray2-* | h8300-* | h8500-* | i960-* \
| xmp-* | ymp-* \
- | x86-* | ppcbe-* | mipsbe-* | mipsle-* | shbe-* | shle-* | armbe-* | armle-* \
+ | x86-* | x86_64-* | ppcbe-* | mipsbe-* | mipsle-* | shbe-* | shle-* | armbe-* | armle-* \
| hppa-* | hppa1.0-* | hppa1.1-* | hppa2.0-* | hppa2.0w-* \
| hppa2.0n-* | hppa64-* \
| alpha-* | alphaev[4-8]-* | alphaev56-* | alphapca5[67]-* \
@@ -256,6 +256,12 @@
basic_machine=a29k-none
os=-bsd
;;
+ amd64)
+ basic_machine=x86_64-pc
+ ;;
+ amd64-*)
+ basic_machine=x86_64-`echo $basic_machine | sed 's/^[^-]*-//'`
+ ;;
amdahl)
basic_machine=580-amdahl
os=-sysv

View File

@ -0,0 +1,21 @@
diff -ruN fetchmail-6.2.5-old/po/fr.po.rej fetchmail-6.2.5-new/po/fr.po.rej
--- fetchmail-6.2.5-old/po/fr.po.rej 2003-07-17 03:23:26.000000000 +0200
+++ fetchmail-6.2.5-new/po/fr.po.rej 1970-01-01 01:00:00.000000000 +0100
@@ -1,17 +0,0 @@
-***************
-*** 2166,2172 ****
- #: rcfile_y.y:433
- #, fuzzy, c-format
- msgid "File %s must be a regular file.\n"
-- msgstr "Le fichier %s doit etre un lien symbolique.\n"
-
- #: rcfile_y.y:440
- #, c-format
---- 2166,2172 ----
- #: rcfile_y.y:433
- #, fuzzy, c-format
- msgid "File %s must be a regular file.\n"
-+ msgstr "Le fichier %s doit être un fichier normal.\n"
-
- #: rcfile_y.y:440
- #, c-format