update aircrack-ng to v0.7 (closes: #1307), thanks to olg!

git-svn-id: svn://svn.openwrt.org/openwrt/packages@6249 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
nico 2007-02-02 00:32:22 +00:00
parent 859482e47a
commit 4c95a07ff9
3 changed files with 12 additions and 30 deletions

View File

@ -9,12 +9,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=aircrack-ng
PKG_VERSION:=0.6.2
PKG_VERSION:=0.7
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://download.aircrack-ng.org/
PKG_MD5SUM:=0b1a9fb6818822f933336efc9fff316b
PKG_MD5SUM:=34c0447951d438d76fa32d08eab5da01
PKG_CAT:=zcat
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)

View File

@ -0,0 +1,10 @@
--- aircrack-ng-0.7.orig/src/airtun-ng.c 2007-02-02 00:01:36.000000000 +0100
+++ aircrack-ng-0.7/src/airtun-ng.c 2007-02-01 23:58:44.000000000 +0100
@@ -32,6 +32,7 @@
#include <netpacket/packet.h>
#include <linux/if_ether.h>
+#include <linux/if.h>
#include <linux/wireless.h>
#include <arpa/inet.h>
#include <unistd.h>

View File

@ -1,28 +0,0 @@
diff -urN aircrack-ng-0.6.2/src/aireplay-ng.c aircrack-ng-0.6.2.new/src/aireplay-ng.c
--- aircrack-ng-0.6.2/src/aireplay-ng.c 2006-09-24 20:28:42.000000000 +0200
+++ aircrack-ng-0.6.2.new/src/aireplay-ng.c 2007-01-05 22:54:08.000000000 +0100
@@ -29,6 +29,10 @@
#include <sys/wait.h>
#include <sys/time.h>
+#include <linux/version.h>
+#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,19)
+#include <net/if.h>
+#endif
#include <netpacket/packet.h>
#include <linux/if_ether.h>
#include <linux/wireless.h>
diff -urN aircrack-ng-0.6.2/src/airodump-ng.c aircrack-ng-0.6.2.new/src/airodump-ng.c
--- aircrack-ng-0.6.2/src/airodump-ng.c 2006-09-09 16:38:26.000000000 +0200
+++ aircrack-ng-0.6.2.new/src/airodump-ng.c 2007-01-05 22:55:00.000000000 +0100
@@ -25,6 +25,10 @@
#include <sys/wait.h>
#include <sys/time.h>
+#include <linux/version.h>
+#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,19)
+#include <net/if.h>
+#endif
#include <netpacket/packet.h>
#include <linux/if_ether.h>
#include <linux/wireless.h>