libs: add lttng-ust library

Required for the LTTng package

Signed-off-by: Florian Fainelli <florian@openwrt.org>

git-svn-id: svn://svn.openwrt.org/openwrt/packages@35164 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
florian 2013-01-15 10:15:42 +00:00
parent 6d7e69548b
commit 4cd0147b17
2 changed files with 82 additions and 0 deletions

47
libs/lttng-ust/Makefile Normal file
View File

@ -0,0 +1,47 @@
#
# Copyright (C) 2013 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
PKG_NAME:=lttng-ust
PKG_VERSION:=2.1.0
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://lttng.org/files/$(PKG_NAME)
PKG_MD5SUM:=2032e66f3438949c51ec9922c6f8542b
PKG_BUILD_PARALLEL:=1
PKG_INSTALL:=1
include $(INCLUDE_DIR)/package.mk
define Package/lttng-ust
SECTION:=libs
CATEGORY:=Libraries
DEPENDS:=+liburcu +libuuid +librt
TITLE:=LTTng Userspace Tracing Library
URL:=https://lttng.org/
endef
define Package/lttng-ust/description
LTTng Userspace Tracing Library
endef
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include
$(CP) $(PKG_INSTALL_DIR)/usr/include/lttng* $(1)/usr/include/
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/liblttng-ust*.{a,so*} $(1)/usr/lib/
endef
define Package/lttng-ust/install
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/liblttng-ust*.so.* $(1)/usr/lib/
endef
$(eval $(call BuildPackage,lttng-ust))

View File

@ -0,0 +1,35 @@
diff -urN lttng-ust-2.1.0/Makefile.am lttng-ust-2.1.0.new/Makefile.am
--- lttng-ust-2.1.0/Makefile.am 2012-12-10 21:29:20.000000000 +0100
+++ lttng-ust-2.1.0.new/Makefile.am 2013-01-14 14:25:41.923661688 +0100
@@ -5,9 +5,7 @@
liblttng-ust-ctl \
liblttng-ust-fork \
liblttng-ust-libc-wrapper \
- tools \
- tests \
- doc
+ tools
if BUILD_JNI_INTERFACE
SUBDIRS += liblttng-ust-java
diff -urN lttng-ust-2.1.0/Makefile.in lttng-ust-2.1.0.new/Makefile.in
--- lttng-ust-2.1.0/Makefile.in 2012-12-20 19:24:57.000000000 +0100
+++ lttng-ust-2.1.0.new/Makefile.in 2013-01-14 14:25:31.247661789 +0100
@@ -135,7 +135,7 @@
CTAGS = ctags
DIST_SUBDIRS = . include snprintf libringbuffer liblttng-ust-comm \
liblttng-ust liblttng-ust-ctl liblttng-ust-fork \
- liblttng-ust-libc-wrapper tools tests doc liblttng-ust-java
+ liblttng-ust-libc-wrapper tools liblttng-ust-java
DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
distdir = $(PACKAGE)-$(VERSION)
top_distdir = $(distdir)
@@ -307,7 +307,7 @@
ACLOCAL_AMFLAGS = -I config
SUBDIRS = . include snprintf libringbuffer liblttng-ust-comm \
liblttng-ust liblttng-ust-ctl liblttng-ust-fork \
- liblttng-ust-libc-wrapper tools tests doc $(am__append_1)
+ liblttng-ust-libc-wrapper tools $(am__append_1)
#temporarily disabled
# liblttng-ust-malloc