* Cleanup Makefile
 * Refresh patches

git-svn-id: svn://svn.openwrt.org/openwrt/packages@8555 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
olli 2007-08-30 18:57:37 +00:00
parent 8ef85849da
commit 4dd3ba4602
3 changed files with 18 additions and 17 deletions

View File

@ -15,7 +15,6 @@ PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
PKG_SOURCE_URL:=http://ftp.debian.org/debian/pool/main/s/ssmtp/
PKG_MD5SUM:=957e6fff08625fe34f4fc33d0925bbc9
PKG_CAT:=zcat
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
EXTRA_LDFLAGS+=-Wl,-rpath-link,$(STAGING_DIR)/usr/lib
@ -38,13 +37,8 @@ define Package/ssmtp
URL:=http://packages.debian.org/stable/mail/ssmtp
endef
# uses GNU configure
define Build/Configure
$(call Build/Configure/Default, \
--enable-ssl \
)
endef
CONFIGURE_ARGS += \
--enable-ssl
define Package/ssmtp/install
$(INSTALL_DIR) $(1)/etc/ssmtp

View File

@ -1,5 +1,7 @@
--- ssmtp-2.61.orig/ssmtp.conf
+++ ssmtp-2.61/ssmtp.conf
Index: ssmtp-2.61/ssmtp.conf
===================================================================
--- ssmtp-2.61.orig/ssmtp.conf 2007-08-30 20:56:56.000000000 +0200
+++ ssmtp-2.61/ssmtp.conf 2007-08-30 20:56:56.000000000 +0200
@@ -36,3 +36,8 @@
# Use this RSA certificate.
@ -9,8 +11,10 @@
+# If you want to have debugging of the config file parsing, move this option
+# to the top of the config file and uncomment
+#Debug=YES
--- ssmtp-2.61.orig/ssmtp.c
+++ ssmtp-2.61/ssmtp.c
Index: ssmtp-2.61/ssmtp.c
===================================================================
--- ssmtp-2.61.orig/ssmtp.c 2007-08-30 20:56:56.000000000 +0200
+++ ssmtp-2.61/ssmtp.c 2007-08-30 20:56:56.000000000 +0200
@@ -93,6 +93,7 @@
static char hextab[]="0123456789abcdef";
#endif
@ -233,8 +237,10 @@
return(0);
}
--- ssmtp-2.61.orig/configure.in
+++ ssmtp-2.61/configure.in
Index: ssmtp-2.61/configure.in
===================================================================
--- ssmtp-2.61.orig/configure.in 2007-08-30 20:56:56.000000000 +0200
+++ ssmtp-2.61/configure.in 2007-08-30 20:56:56.000000000 +0200
@@ -24,8 +24,8 @@
AC_STRUCT_TM

View File

@ -1,6 +1,7 @@
diff -ruN ssmtp-2.60-old/arpadate.c ssmtp-2.60-new/arpadate.c
--- ssmtp-2.60-old/arpadate.c 2002-12-08 18:30:11.000000000 +0100
+++ ssmtp-2.60-new/arpadate.c 2004-05-23 18:54:32.000000000 +0200
Index: ssmtp-2.61/arpadate.c
===================================================================
--- ssmtp-2.61.orig/arpadate.c 2007-08-30 20:56:56.000000000 +0200
+++ ssmtp-2.61/arpadate.c 2007-08-30 20:56:56.000000000 +0200
@@ -79,7 +79,7 @@
time_t now;