[patchteam] Add wide-ipv6 packages, thanks Raphael

git-svn-id: svn://svn.openwrt.org/openwrt/packages@19862 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
spudz76 2010-02-26 01:13:38 +00:00
parent 7f2ef75144
commit 4e125ff4a8
3 changed files with 99 additions and 0 deletions

65
ipv6/wide-dhcpv6/Makefile Normal file
View File

@ -0,0 +1,65 @@
#
# Copyright (C) 2006-2010 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
PKG_NAME:=wide-dhcpv6
PKG_VERSION:=20080615
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/$(PKG_NAME)
PKG_MD5SUM:=1011e165850fe40d3e332dad2bfd30b3
include $(INCLUDE_DIR)/package.mk
define Package/wide-dhcpv6/Default
SECTION:=ipv6
CATEGORY:=IPv6
TITLE:=IPv6 DHCPv6 implementaion for BSD and Linux
URL:=http://wide-dhcpv6.sourceforge.net/
endef
define Package/wide-dhcpv6/description
WIDE-DHCPv6 is an open-source implementation of Dynamic Host Configuration
Protocol for IPv6 (DHCPv6) originally developed by the KAME project. The
implementation mainly conforms to the following standards: RFC3315,3319,3633,
3646,4075,4272,etc.
endef
define Package/wide-dhcpv6-client
$(call Package/wide-dhcpv6/Default)
TITLE+= client
endef
define Package/wide-dhcpv6-server
$(call Package/wide-dhcpv6/Default)
TITLE+= server
endef
define Package/wide-dhcpv6-relay
$(call Package/wide-dhcpv6/Default)
TITLE+= relay
endef
define Package/wide-dhcpv6-ctl
$(call Package/wide-dhcpv6/Default)
TITLE+= ctl
endef
define Package/wide-dhcpv6-client/install
$(INSTALL_DIR) $(1)/sbin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/dhcp6c $(1)/sbin
$(INSTALL_DIR) $(1)/etc
$(INSTALL_DATA) ./files/dhcp6c.config $(1)/etc/dhcp6c.conf
endef
$(eval $(call BuildPackage,wide-dhcpv6-client))
$(eval $(call BuildPackage,wide-dhcpv6-server))
$(eval $(call BuildPackage,wide-dhcpv6-relay))
$(eval $(call BuildPackage,wide-dhcpv6-ctl))

View File

@ -0,0 +1,25 @@
# The followings are a sample configuration for requiring the "stateless"
# DHCPv6 service.
# interface eth0 {
# information-only;
#};
# The followings are a sample configuration to be delegated an IPv6 prefix
# from an upstream service provider. With this configuration dhcp6c will
# send solicit messages containing an IA_PD option, with an IAID 0, on to
# an upstream PPP link, ppp0. After receiving some prefixes from a server,
# dhcp6c will then configure derived IPv6 prefixes with the SLA ID 1 on a
# local ethernet interface, ne0. Note that the IAID for the id-assoc
# statement is 0 according to the default.
interface ppp1 {
send ia-pd 0;
};
id-assoc pd {
prefix-interface lan0 {
sla-id 1;
sla-len 8;
};
};

View File

@ -0,0 +1,9 @@
--- a/cftoken.l 2007-03-21 10:52:55.000000000 +0100
+++ b/cftoken.l 2009-06-12 15:40:03.000000000 +0200
@@ -1,5 +1,6 @@
/* $KAME: cftoken.l,v 1.35 2005/01/12 06:06:11 suz Exp $ */
+%option noyywrap
%{
/*
* Copyright (C) 2002 WIDE Project.