Update httping to 1.2.6 (#3624)

git-svn-id: svn://svn.openwrt.org/openwrt/packages@11707 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
florian 2008-07-06 14:16:21 +00:00
parent 31e23ee867
commit 4e6bfc0ca1
3 changed files with 12 additions and 16 deletions

View File

@ -9,14 +9,12 @@
include $(TOPDIR)/rules.mk include $(TOPDIR)/rules.mk
PKG_NAME:=httping PKG_NAME:=httping
PKG_VERSION:=1.2.2 PKG_VERSION:=1.2.6
PKG_RELEASE:=1 PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
PKG_SOURCE_URL:=http://www.vanheusden.com/httping/ PKG_SOURCE_URL:=http://www.vanheusden.com/httping/
PKG_MD5SUM:=cde335c0110fb1b156afdf80ff5ade1d PKG_MD5SUM:=2fa68b95d190a9e101232792df49e1ad
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
include $(INCLUDE_DIR)/package.mk include $(INCLUDE_DIR)/package.mk
@ -29,8 +27,8 @@ define Package/httping
endef endef
define Package/httping/description define Package/httping/description
Give it an url, and it'll show you how long it takes to connect, send a Give it an url, and it'll show you how long it takes to connect, send a
request and retrieve the reply (only the headers). Be aware that the request and retrieve the reply (only the headers). Be aware that the
transmission across the network also takes time! transmission across the network also takes time!
endef endef

View File

@ -1,6 +1,5 @@
diff -ruaN httping-1.2.2.orig/Makefile httping-1.2.2/Makefile --- a/Makefile
--- httping-1.2.2.orig/Makefile 2006-11-09 20:13:12.000000000 +0100 +++ b/Makefile
+++ httping-1.2.2/Makefile 2007-02-27 11:34:47.000000000 +0100
@@ -15,8 +15,8 @@ @@ -15,8 +15,8 @@
include version include version

View File

@ -1,11 +1,10 @@
diff -ruaN httping-1.2.2.orig/main.c httping-1.2.2/main.c --- a/main.c
--- httping-1.2.2.orig/main.c 2006-11-09 20:13:12.000000000 +0100 +++ b/main.c
+++ httping-1.2.2/main.c 2007-02-27 11:38:14.000000000 +0100
@@ -40,6 +40,8 @@ @@ -40,6 +40,8 @@
#include "utils.h" #include "utils.h"
#include "error.h" #include "error.h"
+#define VERSION "1.2.2" +#define VERSION "1.2.6"
+ +
static volatile int stop = 0; static volatile int stop = 0;
@ -14,12 +13,12 @@ diff -ruaN httping-1.2.2.orig/main.c httping-1.2.2/main.c
void version(void) void version(void)
{ {
- fprintf(stderr, "HTTPing v" VERSION ", (C) 2003-2005 folkert@vanheusden.com\n"); - fprintf(stderr, "HTTPing v" VERSION ", (C) 2003-2008 folkert@vanheusden.com\n");
+ fprintf(stderr, "HTTPing v%s (C) 2003-2005 folkert@vanheusden.com\n", VERSION); + fprintf(stderr, "HTTPing v%s (C) 2003-2008 folkert@vanheusden.com\n", VERSION);
#ifndef NO_SSL #ifndef NO_SSL
fprintf(stderr, "SSL support included\n"); fprintf(stderr, "SSL support included\n");
#endif #endif
@@ -413,7 +415,7 @@ @@ -425,7 +427,7 @@
if (useragent) if (useragent)
sprintf(&request[strlen(request)], "User-Agent: %s\r\n", useragent); sprintf(&request[strlen(request)], "User-Agent: %s\r\n", useragent);
else else