update to postgresql 8.2.5 and refresh patches
git-svn-id: svn://svn.openwrt.org/openwrt/packages@8876 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
4170b3a0db
commit
4f68b060ef
@ -9,7 +9,7 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=postgresql
|
||||
PKG_VERSION:=8.2.4
|
||||
PKG_VERSION:=8.2.5
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
@ -17,7 +17,7 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=\
|
||||
ftp://ftp.us.postgresql.org/pub/mirrors/postgresql/source/v$(PKG_VERSION) \
|
||||
ftp://ftp-archives.postgresql.org/pub/source/v$(PKG_VERSION)
|
||||
PKG_MD5SUM:=af7ec100a33c41bfb8d87b5e0ec2f44a
|
||||
PKG_MD5SUM:=bb1cd309ea72f070cb964736f5755847
|
||||
PKG_CAT:=bzcat
|
||||
|
||||
PKG_BUILD_DEPENDS:=libnotimpl
|
||||
|
@ -1,5 +1,7 @@
|
||||
--- postgresql-8.2.3/src/port/Makefile 2006-07-14 11:45:43.000000000 -0500
|
||||
+++ new-postgresql-8.2.3/src/port/Makefile 2007-04-09 12:14:11.906032000 -0500
|
||||
Index: postgresql-8.2.5/src/port/Makefile
|
||||
===================================================================
|
||||
--- postgresql-8.2.5.orig/src/port/Makefile 2007-09-20 10:18:17.000000000 -0500
|
||||
+++ postgresql-8.2.5/src/port/Makefile 2007-09-20 10:18:17.000000000 -0500
|
||||
@@ -43,6 +43,7 @@
|
||||
|
||||
libpgport.a: $(LIBOBJS)
|
||||
|
@ -1,5 +1,7 @@
|
||||
--- postgresql-8.2.3/src/template/linux 2006-03-10 22:38:41.000000000 -0600
|
||||
+++ new-postgresql-8.2.3/src/template/linux 2007-04-09 12:15:36.223301500 -0500
|
||||
Index: postgresql-8.2.5/src/template/linux
|
||||
===================================================================
|
||||
--- postgresql-8.2.5.orig/src/template/linux 2007-09-20 10:18:17.000000000 -0500
|
||||
+++ postgresql-8.2.5/src/template/linux 2007-09-20 10:18:17.000000000 -0500
|
||||
@@ -1,4 +1,4 @@
|
||||
# $PostgreSQL: pgsql/src/template/linux,v 1.28 2006/03/11 04:38:41 momjian Exp $
|
||||
|
||||
|
@ -1,5 +1,7 @@
|
||||
--- postgresql-8.2.3/src/bin/psql/print.h.old 2007-04-09 16:49:24.297992000 -0500
|
||||
+++ postgresql-8.2.3/src/bin/psql/print.h 2007-04-09 16:49:40.983034750 -0500
|
||||
Index: postgresql-8.2.5/src/bin/psql/print.h
|
||||
===================================================================
|
||||
--- postgresql-8.2.5.orig/src/bin/psql/print.h 2007-09-20 10:18:16.000000000 -0500
|
||||
+++ postgresql-8.2.5/src/bin/psql/print.h 2007-09-20 10:18:17.000000000 -0500
|
||||
@@ -88,10 +88,6 @@
|
||||
|
||||
void setDecimalLocale(void);
|
||||
|
@ -1,6 +1,7 @@
|
||||
diff -ruN postgresql-8.2.3-old/src/backend/utils/adt/float.c postgresql-8.2.3-new/src/backend/utils/adt/float.c
|
||||
--- postgresql-8.2.3-old/src/backend/utils/adt/float.c 2006-10-05 03:40:45.000000000 +0200
|
||||
+++ postgresql-8.2.3-new/src/backend/utils/adt/float.c 2007-04-10 23:13:16.000000000 +0200
|
||||
Index: postgresql-8.2.5/src/backend/utils/adt/float.c
|
||||
===================================================================
|
||||
--- postgresql-8.2.5.orig/src/backend/utils/adt/float.c 2007-09-20 10:18:16.000000000 -0500
|
||||
+++ postgresql-8.2.5/src/backend/utils/adt/float.c 2007-09-20 10:18:17.000000000 -0500
|
||||
@@ -110,7 +110,9 @@
|
||||
static int float8_cmp_internal(float8 a, float8 b);
|
||||
|
||||
|
Loading…
x
Reference in New Issue
Block a user