[Packages] utils/strace: Update 4.5.14 > 4.5.16
git-svn-id: svn://svn.openwrt.org/openwrt/packages@10072 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
650ae61978
commit
50f84a619c
@ -1,5 +1,5 @@
|
||||
#
|
||||
# Copyright (C) 2006 OpenWrt.org
|
||||
#
|
||||
# Copyright (C) 2007 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
@ -9,14 +9,14 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=strace
|
||||
PKG_VERSION:=4.5.14
|
||||
PKG_VERSION:=4.5.16
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=@SF/strace
|
||||
PKG_MD5SUM:=09bcd5d00ece28f8154dec11cadfce3c
|
||||
PKG_SOURCE_URL:=@SF/$(PKG_NAME)
|
||||
PKG_MD5SUM:=77f66d09aa82981bb6d65fa19a2c1ba9
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_FIXUP = libtool
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
@ -28,13 +28,11 @@ define Package/strace
|
||||
endef
|
||||
|
||||
define Package/strace/description
|
||||
A useful diagnostic, instructional, and debugging tool.
|
||||
Allows you to track what system calls a program makes while it is
|
||||
A useful diagnostic, instructional, and debugging tool.
|
||||
Allows you to track what system calls a program makes while it is
|
||||
running.
|
||||
endef
|
||||
|
||||
# uses GNU configure
|
||||
|
||||
define Build/Compile
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||
CC="$(TARGET_CC)"
|
||||
@ -42,7 +40,7 @@ endef
|
||||
|
||||
define Package/strace/install
|
||||
$(INSTALL_DIR) $(1)/usr/sbin
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/strace $(1)/usr/sbin/
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/sbin/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,strace))
|
||||
|
@ -1,58 +0,0 @@
|
||||
diff -urN strace-4.5.14/signal.c strace-4.5.14.new/signal.c
|
||||
--- strace-4.5.14/signal.c 2006-01-12 23:34:50.000000000 +0100
|
||||
+++ strace-4.5.14.new/signal.c 2006-12-10 15:14:20.000000000 +0100
|
||||
@@ -66,7 +66,7 @@
|
||||
|
||||
|
||||
#ifdef LINUX
|
||||
-
|
||||
+#include <linux/version.h>
|
||||
#ifdef IA64
|
||||
# include <asm/ptrace_offsets.h>
|
||||
#endif /* !IA64 */
|
||||
@@ -1420,7 +1420,11 @@
|
||||
if (umove(tcp, sp, &sc) < 0)
|
||||
return 0;
|
||||
tcp->u_arg[0] = 1;
|
||||
+#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,0)
|
||||
tcp->u_arg[1] = sc.sc_sigset;
|
||||
+#else
|
||||
+ tcp->u_arg[1] = sc.sc_hi2;
|
||||
+#endif
|
||||
} else {
|
||||
tcp->u_rval = tcp->u_error = 0;
|
||||
if(tcp->u_arg[0] == 0)
|
||||
diff -urN strace-4.5.14/strace.c strace-4.5.14.new/strace.c
|
||||
--- strace-4.5.14/strace.c 2006-01-12 10:50:49.000000000 +0100
|
||||
+++ strace-4.5.14.new/strace.c 2006-12-10 15:15:01.000000000 +0100
|
||||
@@ -2251,7 +2251,7 @@
|
||||
if (!cflag
|
||||
&& (qual_flags[WSTOPSIG(status)] & QUAL_SIGNAL)) {
|
||||
unsigned long addr = 0, pc = 0;
|
||||
-#ifdef PT_GETSIGINFO
|
||||
+#if defined(PT_CR_IPSR) && defined(PT_CR_IIP) && defined(PT_GETSIGINFO)
|
||||
# define PSR_RI 41
|
||||
struct siginfo si;
|
||||
unsigned long psr;
|
||||
diff -urN strace-4.5.14/system.c strace-4.5.14.new/system.c
|
||||
--- strace-4.5.14/system.c 2006-01-12 22:21:06.000000000 +0100
|
||||
+++ strace-4.5.14.new/system.c 2006-12-10 15:14:20.000000000 +0100
|
||||
@@ -78,6 +78,7 @@
|
||||
#endif
|
||||
|
||||
#include <linux/sysctl.h>
|
||||
+#include <linux/version.h>
|
||||
|
||||
static const struct xlat mount_flags[] = {
|
||||
{ MS_MGC_VAL, "MS_MGC_VAL" },
|
||||
@@ -1578,7 +1579,9 @@
|
||||
{ CTL_KERN, "CTL_KERN" },
|
||||
{ CTL_VM, "CTL_VM" },
|
||||
{ CTL_NET, "CTL_NET" },
|
||||
- { CTL_PROC, "CTL_PROC" },
|
||||
+#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,18)
|
||||
+ { CTL_PROC, "CTL_PROC" },
|
||||
+#endif
|
||||
{ CTL_FS, "CTL_FS" },
|
||||
{ CTL_DEBUG, "CTL_DEBUG" },
|
||||
{ CTL_DEV, "CTL_DEV" },
|
@ -1,6 +1,8 @@
|
||||
--- strace-4.5.12-orig/syscall.c 2005-06-08 21:45:28.000000000 +0100
|
||||
+++ strace-4.5.12/syscall.c 2005-10-25 19:26:39.000000000 +0100
|
||||
@@ -1013,6 +1013,15 @@ struct tcb *tcp;
|
||||
Index: strace-4.5.16/syscall.c
|
||||
===================================================================
|
||||
--- strace-4.5.16.orig/syscall.c 2007-12-31 16:49:59.000000000 +0100
|
||||
+++ strace-4.5.16/syscall.c 2007-12-31 16:49:59.000000000 +0100
|
||||
@@ -1045,6 +1045,15 @@
|
||||
/*
|
||||
* Note: we only deal with only 32-bit CPUs here.
|
||||
*/
|
||||
|
Loading…
x
Reference in New Issue
Block a user