[package] zaptel-1.4.x: fix build failure, refresh patches move to "Voice over IP"
git-svn-id: svn://svn.openwrt.org/openwrt/packages@32936 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
5c8f51ddfb
commit
5151878443
@ -27,7 +27,7 @@ endef
|
|||||||
|
|
||||||
define KernelPackage/zaptel14/Default
|
define KernelPackage/zaptel14/Default
|
||||||
TITLE:=Zaptel (kernel module)
|
TITLE:=Zaptel (kernel module)
|
||||||
SUBMENU:=Other modules
|
SUBMENU:=Voice over IP
|
||||||
DEPENDS:=
|
DEPENDS:=
|
||||||
endef
|
endef
|
||||||
|
|
||||||
|
@ -2,8 +2,8 @@
|
|||||||
kernel/ztdummy.c | 18 +++++++++++++++---
|
kernel/ztdummy.c | 18 +++++++++++++++---
|
||||||
1 file changed, 15 insertions(+), 3 deletions(-)
|
1 file changed, 15 insertions(+), 3 deletions(-)
|
||||||
|
|
||||||
--- zaptel-1.4.12.1.orig/kernel/ztdummy.c
|
--- a/kernel/ztdummy.c
|
||||||
+++ zaptel-1.4.12.1/kernel/ztdummy.c
|
+++ b/kernel/ztdummy.c
|
||||||
@@ -54,7 +54,7 @@
|
@@ -54,7 +54,7 @@
|
||||||
* the #define USE_RTC should be commented out.
|
* the #define USE_RTC should be commented out.
|
||||||
*/
|
*/
|
||||||
|
@ -2,8 +2,8 @@
|
|||||||
kernel/ztdummy.c | 2 --
|
kernel/ztdummy.c | 2 --
|
||||||
1 file changed, 2 deletions(-)
|
1 file changed, 2 deletions(-)
|
||||||
|
|
||||||
--- zaptel-1.4.12.1.orig/kernel/ztdummy.c
|
--- a/kernel/ztdummy.c
|
||||||
+++ zaptel-1.4.12.1/kernel/ztdummy.c
|
+++ b/kernel/ztdummy.c
|
||||||
@@ -53,7 +53,6 @@
|
@@ -53,7 +53,6 @@
|
||||||
* If using an i386 architecture without a PC real-time clock,
|
* If using an i386 architecture without a PC real-time clock,
|
||||||
* the #define USE_RTC should be commented out.
|
* the #define USE_RTC should be commented out.
|
||||||
|
@ -2,8 +2,8 @@
|
|||||||
Makefile | 1 +
|
Makefile | 1 +
|
||||||
1 file changed, 1 insertion(+)
|
1 file changed, 1 insertion(+)
|
||||||
|
|
||||||
--- zaptel-1.4.12.1.orig/Makefile
|
--- a/Makefile
|
||||||
+++ zaptel-1.4.12.1/Makefile
|
+++ b/Makefile
|
||||||
@@ -18,6 +18,7 @@ ifeq ($(MAKELEVEL),0)
|
@@ -18,6 +18,7 @@ ifeq ($(MAKELEVEL),0)
|
||||||
PWD:=$(shell pwd)
|
PWD:=$(shell pwd)
|
||||||
export PWD
|
export PWD
|
||||||
|
@ -2,8 +2,8 @@
|
|||||||
Makefile | 2 +-
|
Makefile | 2 +-
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
--- zaptel-1.4.12.1.orig/Makefile
|
--- a/Makefile
|
||||||
+++ zaptel-1.4.12.1/Makefile
|
+++ b/Makefile
|
||||||
@@ -25,7 +25,7 @@ ARCH:=$(shell uname -m | sed -e s/i.86/i
|
@@ -25,7 +25,7 @@ ARCH:=$(shell uname -m | sed -e s/i.86/i
|
||||||
endif
|
endif
|
||||||
|
|
||||||
|
@ -2,8 +2,8 @@
|
|||||||
kernel/zaptel-base.c | 3 +++
|
kernel/zaptel-base.c | 3 +++
|
||||||
1 file changed, 3 insertions(+)
|
1 file changed, 3 insertions(+)
|
||||||
|
|
||||||
--- zaptel-1.4.12.1.orig/kernel/zaptel-base.c
|
--- a/kernel/zaptel-base.c
|
||||||
+++ zaptel-1.4.12.1/kernel/zaptel-base.c
|
+++ b/kernel/zaptel-base.c
|
||||||
@@ -59,6 +59,9 @@
|
@@ -59,6 +59,9 @@
|
||||||
#include <linux/if_ppp.h>
|
#include <linux/if_ppp.h>
|
||||||
#endif
|
#endif
|
||||||
|
@ -1,7 +1,5 @@
|
|||||||
Index: zaptel-1.4.12.1/kernel/zconfig.h
|
--- a/kernel/zconfig.h
|
||||||
===================================================================
|
+++ b/kernel/zconfig.h
|
||||||
--- zaptel-1.4.12.1.orig/kernel/zconfig.h 2010-06-13 08:51:02.000000000 +0200
|
|
||||||
+++ zaptel-1.4.12.1/kernel/zconfig.h 2010-06-13 08:53:22.000000000 +0200
|
|
||||||
@@ -22,6 +22,8 @@
|
@@ -22,6 +22,8 @@
|
||||||
#include <linux/version.h>
|
#include <linux/version.h>
|
||||||
#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,18)
|
#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,18)
|
||||||
@ -11,4 +9,3 @@ Index: zaptel-1.4.12.1/kernel/zconfig.h
|
|||||||
#else
|
#else
|
||||||
#include <linux/autoconf.h>
|
#include <linux/autoconf.h>
|
||||||
#endif
|
#endif
|
||||||
|
|
||||||
|
@ -1,7 +1,5 @@
|
|||||||
Index: zaptel-1.4.12.1/kernel/wctdm.c
|
--- a/kernel/wctdm.c
|
||||||
===================================================================
|
+++ b/kernel/wctdm.c
|
||||||
--- zaptel-1.4.12.1.orig/kernel/wctdm.c 2010-06-13 12:11:26.000000000 +0200
|
|
||||||
+++ zaptel-1.4.12.1/kernel/wctdm.c 2010-06-13 12:17:47.000000000 +0200
|
|
||||||
@@ -30,6 +30,8 @@
|
@@ -30,6 +30,8 @@
|
||||||
#include <linux/errno.h>
|
#include <linux/errno.h>
|
||||||
#include <linux/pci.h>
|
#include <linux/pci.h>
|
||||||
@ -11,10 +9,8 @@ Index: zaptel-1.4.12.1/kernel/wctdm.c
|
|||||||
#include <asm/io.h>
|
#include <asm/io.h>
|
||||||
#include "proslic.h"
|
#include "proslic.h"
|
||||||
#include "wctdm.h"
|
#include "wctdm.h"
|
||||||
Index: zaptel-1.4.12.1/kernel/wcusb.c
|
--- a/kernel/wcusb.c
|
||||||
===================================================================
|
+++ b/kernel/wcusb.c
|
||||||
--- zaptel-1.4.12.1.orig/kernel/wcusb.c 2010-06-13 12:10:07.000000000 +0200
|
|
||||||
+++ zaptel-1.4.12.1/kernel/wcusb.c 2010-06-13 12:10:13.000000000 +0200
|
|
||||||
@@ -37,6 +37,7 @@
|
@@ -37,6 +37,7 @@
|
||||||
#include <linux/init.h>
|
#include <linux/init.h>
|
||||||
#include <linux/usb.h>
|
#include <linux/usb.h>
|
||||||
@ -23,10 +19,8 @@ Index: zaptel-1.4.12.1/kernel/wcusb.c
|
|||||||
|
|
||||||
#include <linux/version.h>
|
#include <linux/version.h>
|
||||||
#if LINUX_VERSION_CODE > KERNEL_VERSION(2,4,19)
|
#if LINUX_VERSION_CODE > KERNEL_VERSION(2,4,19)
|
||||||
Index: zaptel-1.4.12.1/kernel/ztdummy.c
|
--- a/kernel/ztdummy.c
|
||||||
===================================================================
|
+++ b/kernel/ztdummy.c
|
||||||
--- zaptel-1.4.12.1.orig/kernel/ztdummy.c 2010-06-13 08:58:02.000000000 +0200
|
|
||||||
+++ zaptel-1.4.12.1/kernel/ztdummy.c 2010-06-13 08:58:23.000000000 +0200
|
|
||||||
@@ -38,6 +38,7 @@
|
@@ -38,6 +38,7 @@
|
||||||
*/
|
*/
|
||||||
|
|
||||||
@ -35,4 +29,3 @@ Index: zaptel-1.4.12.1/kernel/ztdummy.c
|
|||||||
|
|
||||||
#ifndef VERSION_CODE
|
#ifndef VERSION_CODE
|
||||||
# define VERSION_CODE(vers,rel,seq) ( ((vers)<<16) | ((rel)<<8) | (seq) )
|
# define VERSION_CODE(vers,rel,seq) ( ((vers)<<16) | ((rel)<<8) | (seq) )
|
||||||
|
|
||||||
|
@ -2,8 +2,8 @@
|
|||||||
kernel/zaptel-base.c | 18 ++++++++++++++++++
|
kernel/zaptel-base.c | 18 ++++++++++++++++++
|
||||||
1 file changed, 18 insertions(+)
|
1 file changed, 18 insertions(+)
|
||||||
|
|
||||||
--- zaptel-1.4.12.1.orig/kernel/zaptel-base.c
|
--- a/kernel/zaptel-base.c
|
||||||
+++ zaptel-1.4.12.1/kernel/zaptel-base.c
|
+++ b/kernel/zaptel-base.c
|
||||||
@@ -5181,6 +5181,20 @@ static int zt_ioctl(struct inode *inode,
|
@@ -5181,6 +5181,20 @@ static int zt_ioctl(struct inode *inode,
|
||||||
return zt_chan_ioctl(inode, file, cmd, data, unit);
|
return zt_chan_ioctl(inode, file, cmd, data, unit);
|
||||||
}
|
}
|
||||||
|
19
libs/zaptel-1.4.x/patches/390-include_spinlock_h.patch
Normal file
19
libs/zaptel-1.4.x/patches/390-include_spinlock_h.patch
Normal file
@ -0,0 +1,19 @@
|
|||||||
|
--- a/kernel/ztdummy.c
|
||||||
|
+++ b/kernel/ztdummy.c
|
||||||
|
@@ -79,6 +79,7 @@
|
||||||
|
#include <asm/io.h>
|
||||||
|
#endif
|
||||||
|
#ifdef LINUX26
|
||||||
|
+#include <linux/spinlock.h>
|
||||||
|
#ifdef USE_HIGHRESTIMER
|
||||||
|
#include <linux/hrtimer.h>
|
||||||
|
#endif
|
||||||
|
@@ -328,7 +329,7 @@ int init_module(void)
|
||||||
|
#ifdef LINUX26
|
||||||
|
ztd->counter = 0;
|
||||||
|
#ifdef USE_RTC
|
||||||
|
- ztd->rtclock = SPIN_LOCK_UNLOCKED;
|
||||||
|
+ spin_lock_init(&ztd->rtclock);
|
||||||
|
ztd->rtc_task.func = ztdummy_rtc_interrupt;
|
||||||
|
ztd->rtc_task.private_data = ztd;
|
||||||
|
err = rtc_register(&ztd->rtc_task);
|
Loading…
x
Reference in New Issue
Block a user