[packages] remove xyssl package, it's discontinued upstream and replaced by polarssl

git-svn-id: svn://svn.openwrt.org/openwrt/packages@14759 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
jow 2009-03-06 13:45:38 +00:00
parent 5016bc9c6c
commit 519f8c7053
3 changed files with 0 additions and 104 deletions

View File

@ -1,79 +0,0 @@
#
# Copyright (C) 2006 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
# $Id$
include $(TOPDIR)/rules.mk
PKG_NAME:=xyssl
PKG_VERSION:=0.9
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
PKG_SOURCE_URL:=http://ftp.de.debian.org/debian/pool/main/x/xyssl
PKG_MD5SUM:=3f0695831aa874cb77e3790755d6b570
include $(INCLUDE_DIR)/package.mk
define Package/xyssl/Default
TITLE:=Embedded SSL
URL:=http://xyssl.org/
endef
define Package/libxyssl/Default/description
The aim of the XySSL project is to provide a quality, open-source
cryptographic library written in C and targeted at embedded systems.
endef
define Package/libxyssl
$(call Package/xyssl/Default)
SECTION:=libs
CATEGORY:=Libraries
TITLE+= (library)
endef
define Package/xyssl-progs
$(call Package/xyssl/Default)
SECTION:=utils
CATEGORY:=Utilities
DEPENDS:=+libxyssl
TITLE+= (programs)
endef
define Build/Configure
endef
TARGET_CFLAGS += $(FPIC)
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) \
$(TARGET_CONFIGURE_OPTS) \
OFLAGS="$(TARGET_CFLAGS)" \
all
$(MAKE) -C $(PKG_BUILD_DIR) \
DESTDIR="$(PKG_INSTALL_DIR)/usr" \
install
endef
define Build/InstallDev
mkdir -p $(1)/usr/include
$(CP) $(PKG_INSTALL_DIR)/usr/include/xyssl $(1)/usr/include/
mkdir -p $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libxyssl.{a,so} $(1)/usr/lib/
endef
define Package/libxyssl/install
$(INSTALL_DIR) $(1)/usr/lib
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/libxyssl.so $(1)/usr/lib/
endef
define Package/xyssl-progs/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/xyssl_* $(1)/usr/bin/
endef
$(eval $(call BuildPackage,libxyssl))
$(eval $(call BuildPackage,xyssl-progs))

View File

@ -1,12 +0,0 @@
diff -urN xyssl-0.8.orig/library/Makefile xyssl-0.8/library/Makefile
--- xyssl-0.8.orig/library/Makefile 2007-10-20 20:29:26.000000000 +0200
+++ xyssl-0.8/library/Makefile 2007-10-20 20:30:41.000000000 +0200
@@ -28,7 +28,7 @@
.SILENT:
-all: static
+all: static shared
static: libxyssl.a

View File

@ -1,13 +0,0 @@
--- xyssl-0.9/Makefile.orig 2008-03-16 15:14:56.000000000 +0100
+++ xyssl-0.9/Makefile 2008-08-06 17:11:20.000000000 +0200
@@ -5,8 +5,8 @@
.SILENT:
all:
- cd library && make all && cd ..
- cd programs && make all && cd ..
+ cd library && $(MAKE) all && cd ..
+ cd programs && $(MAKE) all && cd ..
install:
mkdir -p $(DESTDIR)/include/xyssl