[packages] libsigc++: update to 2.2.8 (#8276), thanks sav, use PKG_INSTALL and refresh patches

git-svn-id: svn://svn.openwrt.org/openwrt/packages@24635 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
swalker 2010-12-17 04:33:19 +00:00
parent 7e92bcbead
commit 532ad856cb
2 changed files with 12 additions and 20 deletions

View File

@ -1,4 +1,4 @@
# #
# Copyright (C) 2006-2010 OpenWrt.org # Copyright (C) 2006-2010 OpenWrt.org
# #
# This is free software, licensed under the GNU General Public License v2. # This is free software, licensed under the GNU General Public License v2.
@ -8,14 +8,15 @@
include $(TOPDIR)/rules.mk include $(TOPDIR)/rules.mk
PKG_NAME:=libsigc++ PKG_NAME:=libsigc++
PKG_VERSION:=2.2.6 PKG_VERSION:=2.2.8
PKG_RELEASE:=1 PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=@GNOME/libsigc++/2.2 PKG_SOURCE_URL:=@GNOME/libsigc++/2.2
PKG_MD5SUM:=d216ef85785e0d17eda9b0326cfdcf71 PKG_MD5SUM:=1198425eab9fd605721a278c651b8dd8
PKG_FIXUP = libtool PKG_FIXUP:=libtool
PKG_INSTALL:=1
include $(INCLUDE_DIR)/package.mk include $(INCLUDE_DIR)/package.mk
@ -42,12 +43,6 @@ CONFIGURE_ARGS += \
--enable-shared \ --enable-shared \
--enable-static \ --enable-static \
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) \
DESTDIR="$(PKG_INSTALL_DIR)" \
all install
endef
define Build/InstallDev define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include $(INSTALL_DIR) $(1)/usr/include
$(CP) $(PKG_INSTALL_DIR)/usr/include/sigc++-2.0 $(1)/usr/include/ $(CP) $(PKG_INSTALL_DIR)/usr/include/sigc++-2.0 $(1)/usr/include/
@ -64,4 +59,3 @@ define Package/libsigcxx/install
endef endef
$(eval $(call BuildPackage,libsigcxx)) $(eval $(call BuildPackage,libsigcxx))

View File

@ -1,7 +1,6 @@
diff -urN libsigc++-2.2.3/Makefile.am libsigc++-2.2.3.new/Makefile.am --- a/Makefile.am
--- a/Makefile.am 2009-08-20 14:32:40.000000000 +0400 +++ b/Makefile.am
+++ b/Makefile.am 2009-11-13 10:26:01.000000000 +0300 @@ -22,7 +22,7 @@ doc_subdirs = docs
@@ -22,7 +22,7 @@
else else
doc_subdirs = doc_subdirs =
endif endif
@ -10,11 +9,10 @@ diff -urN libsigc++-2.2.3/Makefile.am libsigc++-2.2.3.new/Makefile.am
sigc_configdir = $(libdir)/$(SIGCXX_MODULE_NAME)/include sigc_configdir = $(libdir)/$(SIGCXX_MODULE_NAME)/include
nodist_sigc_config_HEADERS = sigc++config.h nodist_sigc_config_HEADERS = sigc++config.h
diff -urN libsigc++-2.2.3/Makefile.in libsigc++-2.2.3.new/Makefile.in --- a/Makefile.in
--- a/Makefile.in 2009-09-02 19:55:19.000000000 +0400 +++ b/Makefile.in
+++ b/Makefile.in 2009-11-13 10:29:43.000000000 +0300 @@ -114,7 +114,7 @@ AM_RECURSIVE_TARGETS = $(RECURSIVE_TARGE
@@ -89,7 +89,7 @@ distdir dist dist-all distcheck
distclean-recursive maintainer-clean-recursive
ETAGS = etags ETAGS = etags
CTAGS = ctags CTAGS = ctags
-DIST_SUBDIRS = sigc++ tests examples docs -DIST_SUBDIRS = sigc++ tests examples docs