diff --git a/net/udp-broadcast-relay/Makefile b/net/udp-broadcast-relay/Makefile
index 9fcdd6c02..e95f2e142 100644
--- a/net/udp-broadcast-relay/Makefile
+++ b/net/udp-broadcast-relay/Makefile
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=udp-broadcast-relay
 PKG_VERSION:=0.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.joachim-breitner.de/udp-broadcast-relay/files/
@@ -36,11 +36,11 @@ define Package/udp-broadcast-relay/description
 	downgoing interfaces yourself.
 endef
 
-define Build/Compile	
-	$(TARGET_CC) $(PKG_BUILD_DIR)/main.c -o $(PKG_BUILD_DIR)/$(PKG_NAME)
+define Build/Compile
+	$(TARGET_CC) $(TARGET_CFLAGS) $(PKG_BUILD_DIR)/main.c -o $(PKG_BUILD_DIR)/$(PKG_NAME)
 endef
 
-define Package/udp-broadcast-relay/install	
+define Package/udp-broadcast-relay/install
 	$(INSTALL_DIR) $(1)/usr/sbin
 	$(CP) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/sbin/
 endef