From 55578e51d8fec60606f1d3b4645e0d086ab21a18 Mon Sep 17 00:00:00 2001
From: florian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Date: Sat, 8 Mar 2014 00:57:44 +0000
Subject: [PATCH] udp-broadcast-relay: pass our CFLAGS

Signed-off-by: Florian Fainelli <florian@openwrt.org>

git-svn-id: svn://svn.openwrt.org/openwrt/packages@39827 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 net/udp-broadcast-relay/Makefile | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/net/udp-broadcast-relay/Makefile b/net/udp-broadcast-relay/Makefile
index 9fcdd6c02..e95f2e142 100644
--- a/net/udp-broadcast-relay/Makefile
+++ b/net/udp-broadcast-relay/Makefile
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=udp-broadcast-relay
 PKG_VERSION:=0.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.joachim-breitner.de/udp-broadcast-relay/files/
@@ -36,11 +36,11 @@ define Package/udp-broadcast-relay/description
 	downgoing interfaces yourself.
 endef
 
-define Build/Compile	
-	$(TARGET_CC) $(PKG_BUILD_DIR)/main.c -o $(PKG_BUILD_DIR)/$(PKG_NAME)
+define Build/Compile
+	$(TARGET_CC) $(TARGET_CFLAGS) $(PKG_BUILD_DIR)/main.c -o $(PKG_BUILD_DIR)/$(PKG_NAME)
 endef
 
-define Package/udp-broadcast-relay/install	
+define Package/udp-broadcast-relay/install
 	$(INSTALL_DIR) $(1)/usr/sbin
 	$(CP) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/sbin/
 endef