[package] add umurmur (#6196)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@18483 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
1dc11f32d7
commit
556b8e3707
56
net/umurmur/Makefile
Normal file
56
net/umurmur/Makefile
Normal file
@ -0,0 +1,56 @@
|
||||
#
|
||||
# Copyright (C) 2009 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
|
||||
PKG_NAME:=umurmur
|
||||
PKG_VERSION:=0.1.3
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://umurmur.googlecode.com/files/
|
||||
PKG_MD5SUM:=f72b6f0aee7fdba31cd4faa9fb01ab6d
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/umurmur
|
||||
SECTION:=net
|
||||
CATEGORY:=Network
|
||||
TITLE:=uMurmur
|
||||
DEPENDS:=+libopenssl +libconfig
|
||||
URL:=http://code.google.com/p/umurmur
|
||||
MAINTAINER:=Martin Johansson <martin@fatbob.nu>
|
||||
endef
|
||||
|
||||
define Package/umurmur/description
|
||||
Minimalistic Mumble server daemon.
|
||||
endef
|
||||
|
||||
TARGET_CFLAGS := \
|
||||
-DWRT_TARGET \
|
||||
-I$(STAGING_DIR)/usr/include \
|
||||
$(TARGET_CFLAGS)
|
||||
|
||||
define Build/Compile
|
||||
CC="$(TARGET_CC)" \
|
||||
CFLAGS="$(TARGET_CFLAGS)" \
|
||||
LDFLAGS="$(TARGET_LDFLAGS)" \
|
||||
$(MAKE) -C $(PKG_BUILD_DIR)/src \
|
||||
all
|
||||
endef
|
||||
|
||||
define Package/umurmur/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/umurmurd $(1)/usr/bin/
|
||||
$(INSTALL_DIR) $(1)/etc
|
||||
$(INSTALL_CONF) $(PKG_BUILD_DIR)/files/umurmur.conf $(1)/etc/
|
||||
$(INSTALL_DIR) $(1)/etc/init.d
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/files/umurmur.init $(1)/etc/init.d/umurmur
|
||||
$(INSTALL_DIR) $(1)/etc/umurmur
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,umurmur))
|
25
net/umurmur/patches/001-makefile.patch
Normal file
25
net/umurmur/patches/001-makefile.patch
Normal file
@ -0,0 +1,25 @@
|
||||
--- umurmur-0.1.3/src/Makefile.old 2009-08-26 22:00:32.000000000 +0200
|
||||
+++ umurmur-0.1.3/src/Makefile 2009-11-20 23:13:26.141571090 +0100
|
||||
@@ -5,18 +5,18 @@
|
||||
CFLAGS:=$(CFLAGS) -Wall -Os -g
|
||||
LDFLAGS:=$(LDFLAGS) -lcrypto -lssl -lconfig
|
||||
|
||||
-umurmurd:$(OBJS) depend.mak
|
||||
+umurmurd:$(OBJS)
|
||||
$(CC) $(LDFLAGS) $(OBJS) -o umurmurd
|
||||
|
||||
# remove object files and executable when user executes "make clean"
|
||||
clean:
|
||||
rm *.o umurmurd
|
||||
|
||||
-all: umurmur
|
||||
+all: umurmurd
|
||||
|
||||
$(OBJS): Makefile
|
||||
|
||||
depend.mak:
|
||||
$(CC) -M $(SRCS) > depend.mak
|
||||
|
||||
-include depend.mak
|
||||
\ No newline at end of file
|
||||
+
|
Loading…
x
Reference in New Issue
Block a user