xtables-addons: Update to 1.29. This fixes compile on linux-2.6.36. Also fix parallel build.
git-svn-id: svn://svn.openwrt.org/openwrt/packages@23185 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
1ffe0fdb34
commit
5579522bf7
@ -9,13 +9,15 @@ include $(TOPDIR)/rules.mk
|
||||
include $(INCLUDE_DIR)/kernel.mk
|
||||
|
||||
PKG_NAME:=xtables-addons
|
||||
PKG_VERSION:=1.28
|
||||
PKG_VERSION:=1.29
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_MD5SUM:=2d81508449ddd7295e9dc08aff72d377
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||
PKG_MD5SUM:=25e3d7de905d8ed7cfb5e297a316bfc8
|
||||
PKG_SOURCE_URL:=@SF/xtables-addons
|
||||
PKG_BUILD_DEPENDS:=iptables
|
||||
PKG_INSTALL:=1
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
@ -34,13 +36,23 @@ CONFIGURE_ARGS+= \
|
||||
--with-xtlibdir="/usr/lib/iptables" \
|
||||
|
||||
define Build/Compile
|
||||
$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
|
||||
ARCH="$(LINUX_KARCH)" \
|
||||
CROSS_COMPILE="$(TARGET_CROSS)" \
|
||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||
DEPMOD="/bin/true" \
|
||||
LDFLAGS="$(TARGET_LDFLAGS)" \
|
||||
all
|
||||
endef
|
||||
|
||||
define Build/Install
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||
ARCH="$(LINUX_KARCH)" \
|
||||
CROSS_COMPILE="$(TARGET_CROSS)" \
|
||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||
DEPMOD="/bin/true" \
|
||||
LDFLAGS="$(TARGET_LDFLAGS)" \
|
||||
all install
|
||||
install
|
||||
endef
|
||||
|
||||
# 1: extension/module suffix used in package name
|
||||
|
@ -1,6 +1,10 @@
|
||||
--- a/Makefile.in
|
||||
+++ b/Makefile.in
|
||||
@@ -752,8 +752,7 @@ install-dvi: install-dvi-recursive
|
||||
---
|
||||
Makefile.in | 3 +--
|
||||
1 file changed, 1 insertion(+), 2 deletions(-)
|
||||
|
||||
--- xtables-addons-1.29.orig/Makefile.in
|
||||
+++ xtables-addons-1.29/Makefile.in
|
||||
@@ -754,8 +754,7 @@ install-dvi: install-dvi-recursive
|
||||
install-dvi-am:
|
||||
|
||||
install-exec-am:
|
||||
|
Loading…
x
Reference in New Issue
Block a user