[package] downgrade netatalk to 2.0.5 (#6965, #6619)

git-svn-id: svn://svn.openwrt.org/openwrt/packages@20546 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
florian 2010-03-28 17:04:28 +00:00
parent d4cbd2f9bb
commit 55f5dafb85
2 changed files with 99 additions and 22 deletions

View File

@ -1,5 +1,5 @@
#
# Copyright (C) 2009-2010 OpenWrt.org
# Copyright (C) 2009 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@ -8,21 +8,18 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=netatalk
PKG_VERSION:=2.1beta1
PKG_VERSION=2.0.5
PKG_RELEASE:=2
PKG_SOURCE:=netatalk-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/netatalk
PKG_MD5SUM:=86be058b18270e9df4699a1f393846b0
PKG_FIXUP:=libtool
PKG_SOURCE_URL:=@SF/netatalk/
PKG_MD5SUM:=f35cd7a4ce26c780de380cd2bcae5ce6
include $(INCLUDE_DIR)/package.mk
define Package/netatalk
SECTION:=net
CATEGORY:=Network
DEPENDS:=+libdb47 +libgcrypt +libopenssl
DEPENDS:=+libdb47 +libgcrypt +libopenssl +kmod-appletalk
TITLE:=netatalk
URL:=http://netatalk.sourceforge.net
endef
@ -31,10 +28,13 @@ define Package/netatalk/decription
Netatalk is an implementation of the AppleTalk protocol suite
endef
CONFIGURE_VARS += \
CFLAGS="$(TARGET_CFLAGS) -std=gnu99 -Drestrict='' -DNO_DEBUG "
EXTRA_CFLAGS += -I$(STAGING_DIR)/usr/include
CONFIGURE_ARGS += \
--disable-afs \
--enable-hfs \
--disable-debugging \
--disable-shell-check \
--disable-timelord \
--disable-a2boot \
--disable-cups \
@ -43,32 +43,39 @@ CONFIGURE_ARGS += \
--with-bdb="$(STAGING_DIR)/usr/" \
--with-libgcrypt-dir="$(STAGING_DIR)/usr" \
--with-ssl-dir="$(STAGING_DIR)/usr" \
--with-uams-path="/usr/lib/uams"
--with-uams-path="/usr/lib/uams" \
--disable-admin-group \
--disable-srvloc \
define Package/netatalk/install
$(INSTALL_DIR) $(1)/usr/bin/
$(INSTALL_DIR) $(1)/usr/sbin/
$(INSTALL_DIR) $(1)/usr/lib/uams/
$(INSTALL_DIR) $(1)/etc/netatalk/
$(INSTALL_DIR) $(1)/etc/init.d/
$(CP) \
$(PKG_BUILD_DIR)/etc/afpd/afpd \
$(1)/usr/bin/
$(1)/usr/sbin/
$(CP) \
$(PKG_BUILD_DIR)/bin/afppasswd/afppasswd \
$(1)/usr/sbin/
$(CP) \
$(PKG_BUILD_DIR)/etc/cnid_dbd/cnid_dbd \
$(1)/usr/bin/
$(1)/usr/sbin/
$(CP) \
$(PKG_BUILD_DIR)/etc/cnid_dbd/cnid_metad \
$(1)/usr/bin/
$(CP) \
$(PKG_BUILD_DIR)/etc/cnid_dbd/dbd \
$(1)/usr/bin/
$(1)/usr/sbin/
$(CP) \
$(PKG_BUILD_DIR)/etc/uams/.libs/*.so \
$(1)/usr/lib/uams/
$(CP) ./files/afpd.init $(1)/etc/init.d/afpd
$(CP) ./files/AppleVolumes.default $(1)/etc/netatalk/
$(CP) ./files/AppleVolumes.system $(1)/etc/netatalk/
$(INSTALL_BIN) ./files/afpd.conf $(1)/etc/netatalk/
$(CP) \
./files/AppleVolumes.* \
$(1)/etc/netatalk/
$(CP) \
./files/afpd.conf \
$(1)/etc/netatalk/
$(CP) \
./files/afpd.init \
$(1)/etc/init.d/afpd
endef
$(eval $(call BuildPackage,netatalk))

View File

@ -0,0 +1,70 @@
diff -Naur netatalk-2.0.5.orig/configure netatalk-2.0.5/configure
--- netatalk-2.0.5.orig/configure 2009-10-05 11:27:29.000000000 +0300
+++ netatalk-2.0.5/configure 2010-01-31 22:03:19.000000000 +0200
@@ -26504,10 +26504,7 @@
if test $ac_cv_lib_afsauthent_pioctl = yes; then
netatalk_cv_afs=yes
else
- { { echo "$as_me:$LINENO: error: AFS installation not found" >&5
-echo "$as_me: error: AFS installation not found" >&2;}
- { (exit 1); exit 1; }; }
-
+ netatalk_cv_afs=yes
fi
AFS_LIBS=-lresolv -lafsrpc -lafsauthent
@@ -30832,7 +30829,7 @@
trybdbdir=""
dobdbsearch=yes
bdb_search_dirs="/usr/local /usr"
- search_subdirs="/ /db4.7 /db47 /db4.6 /db46 /db4.5 /db45 /db4.4 /db44 /db4.3 /db43 /db4.2 /db42 /db4.1 /db41 /db4"
+ search_subdirs="/ /db4.7 /db47 /db4.6 /db46 /db4.5 /db45 /db4.4 /db44 /db4.3 /db43 /db4.2 /db42 /db4.1 /db41 /db4 /./"
DB_MAJOR_REQ=4
DB_MINOR_REQ=1
@@ -30932,11 +30929,7 @@
{ echo "$as_me:$LINENO: checking Berkeley DB library ($lib)" >&5
echo $ECHO_N "checking Berkeley DB library ($lib)... $ECHO_C" >&6; }
if test "$cross_compiling" = yes; then
- { { echo "$as_me:$LINENO: error: cannot run test program while cross compiling
-See \`config.log' for more details." >&5
-echo "$as_me: error: cannot run test program while cross compiling
-See \`config.log' for more details." >&2;}
- { (exit 1); exit 1; }; }
+ { { echo "$as_me:$LINENO: result yes" >&5; echo "${ECHO_T}yes" >&6; }; }
else
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
@@ -31042,23 +31035,7 @@
if test "x$bdbfound" = "xyes"; then
:
else
-
- { echo "$as_me:$LINENO: result: " >&5
-echo "${ECHO_T}" >&6; }
- { echo "$as_me:$LINENO: result: Make sure you have the required Berkeley DB libraries AND headers installed." >&5
-echo "${ECHO_T}Make sure you have the required Berkeley DB libraries AND headers installed." >&6; }
- { echo "$as_me:$LINENO: result: You can download the latest version from http://www.sleepycat.com." >&5
-echo "${ECHO_T}You can download the latest version from http://www.sleepycat.com." >&6; }
- { echo "$as_me:$LINENO: result: If you have installed BDB in a non standard location use the" >&5
-echo "${ECHO_T}If you have installed BDB in a non standard location use the" >&6; }
- { echo "$as_me:$LINENO: result: --with-bdb=/path/to/bdb configure option and make sure" >&5
-echo "${ECHO_T}--with-bdb=/path/to/bdb configure option and make sure" >&6; }
- { echo "$as_me:$LINENO: result: your linker is configured to check for libraries there." >&5
-echo "${ECHO_T}your linker is configured to check for libraries there." >&6; }
- { { echo "$as_me:$LINENO: error: Berkeley DB library required but not found!" >&5
-echo "$as_me: error: Berkeley DB library required but not found!" >&2;}
- { (exit 1); exit 1; }; }
-
+ :
fi
@@ -31080,6 +31057,7 @@
esac
done
BDB_LIBS=$ac_new_flags
+ BDB_LIBS="-ldb-4.7"