diff --git a/sound/sox/Makefile b/sound/sox/Makefile
index 14cc50ea8..653021a36 100644
--- a/sound/sox/Makefile
+++ b/sound/sox/Makefile
@@ -20,12 +20,14 @@ PKG_CAT:=zcat
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
+PKG_BUILDDEP:=libnotimpl
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/sox
   SECTION:=sound
   CATEGORY:=Sound
-  DEPENDS:=+libflac +libid3tag +libmad +libvorbisidec +libnotimpl
+  DEPENDS:=+libflac +libid3tag +libmad +libvorbisidec
   TITLE:=Sox is a general purpose sound converter/player/recorder
   DESCRIPTION:=\
 	SoX is a command line utility that can convert various formats\\\