[packages] libnet1: update to 1.1.6

Signed-off-by: Peter Wagner <tripolar@gmx.at>


git-svn-id: svn://svn.openwrt.org/openwrt/packages@38707 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
tripolar 2013-11-10 18:07:16 +00:00
parent 989ec039d4
commit 57805c0015
4 changed files with 14 additions and 14 deletions

View File

@ -1,5 +1,5 @@
#
# Copyright (C) 2006-2010 OpenWrt.org
# Copyright (C) 2006-2013 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@ -8,11 +8,11 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=libnet
PKG_VERSION:=1.1.2.1
PKG_RELEASE:=2
PKG_VERSION:=1.1.6
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME).tar.gz
PKG_SOURCE_URL:=http://www.packetfactory.net/libnet/dist/
PKG_SOURCE_URL:=@SF/$(PKG_NAME)
PKG_MD5SUM:=be845c41170d72c7db524f3411b50256
PKG_BUILD_DIR:=$(BUILD_DIR)/libnet

View File

@ -1,6 +1,6 @@
--- a/configure.in
+++ b/configure.in
@@ -21,7 +21,7 @@
@@ -21,7 +21,7 @@ dnl Check for the usual programs
dnl
AC_PROG_CC
AC_PROG_INSTALL
@ -11,7 +11,7 @@
--- a/include/libnet/libnet-functions.h
+++ b/include/libnet/libnet-functions.h
@@ -1429,7 +1429,7 @@
@@ -1429,7 +1429,7 @@ libnet_t *l, libnet_ptag_t ptag);
* @param ptag protocol tag to modify an existing header, 0 to build a new one
* @return protocol tag value on success, -1 on error
*/
@ -22,7 +22,7 @@
/**
--- a/Makefile.am
+++ b/Makefile.am
@@ -12,4 +12,4 @@
@@ -12,4 +12,4 @@ SUBDIRS = include src sample
EXTRA_DIST = Makefile.am.common
@ -30,7 +30,7 @@
+bin_SCRIPTS = libnet-config
--- a/sample/Makefile.am
+++ b/sample/Makefile.am
@@ -60,4 +60,4 @@
@@ -60,4 +60,4 @@ ip_raw_SOURCES = ip_raw.c
ip_link_SOURCES = ip_link.c
sebek_SOURCES = sebek.c
@ -38,7 +38,7 @@
+LDADD = $(top_srcdir)/src/libnet.la
--- a/src/libnet_checksum.c
+++ b/src/libnet_checksum.c
@@ -42,8 +42,10 @@
@@ -42,8 +42,10 @@ int
libnet_in_cksum(u_int16_t *addr, int len)
{
int sum;
@ -49,7 +49,7 @@
while (len > 1)
{
@@ -52,7 +54,8 @@
@@ -52,7 +54,8 @@ libnet_in_cksum(u_int16_t *addr, int len
}
if (len == 1)
{
@ -73,7 +73,7 @@
libnet_build_802.1q.c \
libnet_build_802.1x.c \
libnet_build_802.2.c \
@@ -57,15 +57,20 @@
@@ -57,15 +57,20 @@ libnet_a_SOURCES = libnet_asn1.c \
libnet_version.c \
libnet_write.c

View File

@ -1,6 +1,6 @@
--- a/configure.in
+++ b/configure.in
@@ -67,7 +67,10 @@
@@ -67,7 +67,10 @@ dnl Get link-layer interface type
dnl
AC_MSG_CHECKING(link-layer packet interface type)

View File

@ -1,6 +1,6 @@
--- a/acinclude.m4
+++ b/acinclude.m4
@@ -281,6 +281,7 @@
@@ -281,6 +281,7 @@ dnl
AC_DEFUN(AC_LIBNET_ENDIAN_CHECK,
[AC_MSG_CHECKING(machine endianess)
@ -8,7 +8,7 @@
cat > conftest.c << EOF
# include <stdio.h>
# include <stdlib.h>
@@ -332,6 +333,7 @@
@@ -332,6 +333,7 @@ dnl failed to compile for some reason
fi
fi
rm -f conftest* core core.conftest