adds tctool for controlling dsl modems, thanks Maik Zumstrull fixes #2402
git-svn-id: svn://svn.openwrt.org/openwrt/packages@11972 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
204f73c930
commit
5851bcb5a7
37
net/tctool/Makefile
Normal file
37
net/tctool/Makefile
Normal file
@ -0,0 +1,37 @@
|
|||||||
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
|
PKG_NAME:=tctool
|
||||||
|
PKG_VERSION:=0.9.7
|
||||||
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).zip
|
||||||
|
PKG_SOURCE_URL:=http://download2.berlios.de/speedmodem50b
|
||||||
|
PKG_MD5SUM:=df38334206d4cad106e58bd71c6f1d9a
|
||||||
|
PKG_CAT:=unzip
|
||||||
|
|
||||||
|
PKG_BUILD_DIR=$(BUILD_DIR)/$(PKG_NAME)
|
||||||
|
|
||||||
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
|
define Package/tctool
|
||||||
|
SECTION:=net
|
||||||
|
CATEGORY:=Network
|
||||||
|
TITLE:=TrendChip-Modem-Utility
|
||||||
|
URL:=http://speedmodem50b.berlios.de/
|
||||||
|
DEPENDS:=+libstdcpp
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/tctool/description
|
||||||
|
tcTool provides access to the console-service of TrendChip-based ADSL-Modems.
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Build/Compile
|
||||||
|
$(MAKE) -C $(PKG_BUILD_DIR)/src $(TARGET_CONFIGURE_OPTS) tctool
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/tctool/install
|
||||||
|
$(INSTALL_DIR) $(1)/usr/sbin
|
||||||
|
$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/tctool $(1)/usr/sbin/
|
||||||
|
endef
|
||||||
|
|
||||||
|
$(eval $(call BuildPackage,tctool))
|
30
net/tctool/patches/001_Makefile_fix.diff
Normal file
30
net/tctool/patches/001_Makefile_fix.diff
Normal file
@ -0,0 +1,30 @@
|
|||||||
|
diff -ur tctool.old/src/Makefile tctool/src/Makefile
|
||||||
|
--- tctool.old/src/Makefile 2007-01-03 02:32:24.000000000 +0100
|
||||||
|
+++ tctool/src/Makefile 2007-09-18 19:15:03.068155702 +0200
|
||||||
|
@@ -31,16 +31,16 @@
|
||||||
|
EXAMPLE := example
|
||||||
|
EXOBJ := if.o interface.o etherStream.o etherStreambuf.o tcStream.o tcStreambuf.o tcRtsDump.o tcRtsDumpbuf.o
|
||||||
|
|
||||||
|
-CXX := g++
|
||||||
|
-CXXFLAGS := -march=i386 -O2
|
||||||
|
-LDFLAGS := --strip-unneeded
|
||||||
|
-LIBS :=
|
||||||
|
-LDSTATIC := -L. -static-libgcc
|
||||||
|
-STATICLIBS := stdc++ m
|
||||||
|
-COUNTRY := "C"
|
||||||
|
-LANG := "C"
|
||||||
|
-LANGUAGE := "C"
|
||||||
|
-LC_ALL := "C"
|
||||||
|
+#CXX := g++
|
||||||
|
+#CXXFLAGS := -march=i386 -O2
|
||||||
|
+#LDFLAGS := --strip-unneeded
|
||||||
|
+#LIBS :=
|
||||||
|
+#LDSTATIC := -L. -static-libgcc
|
||||||
|
+#STATICLIBS := stdc++ m
|
||||||
|
+#COUNTRY := "C"
|
||||||
|
+#LANG := "C"
|
||||||
|
+#LANGUAGE := "C"
|
||||||
|
+#LC_ALL := "C"
|
||||||
|
|
||||||
|
default: install
|
||||||
|
|
Loading…
x
Reference in New Issue
Block a user