Update dansguardian to 2.10.0.2 (stable), includes patches from #4281

git-svn-id: svn://svn.openwrt.org/openwrt/packages@13471 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
florian 2008-12-02 15:41:27 +00:00
parent 8cbcb44128
commit 58d00bd584
3 changed files with 14 additions and 21 deletions

View File

@ -9,12 +9,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=dansguardian
PKG_VERSION:=2.9.9.2
PKG_VERSION:=2.10.0.2
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://dansguardian.org/downloads/2/Beta
PKG_MD5SUM:=7877ee4d34df6ac538e6522755cedaf6
PKG_SOURCE_URL:=http://dansguardian.org/downloads/2/Stable
PKG_MD5SUM:=0a6c6d35c9e0c82fbc4a2150e8ffe977
PKG_FIXUP = libtool

View File

@ -20,24 +20,6 @@ Index: dansguardian-2.9.9.2/configure
if test "x$staticzlib" = "xtrue"; then
LIBS="-Bstatic -L${withval} -lz -Bdynamic ${LIBS}"
else
@@ -9637,7 +9637,7 @@
PCRE_PREFIX=`pcre-config --prefix`
LIBS="${PCRE_LIBS} ${LIBS}"
- CPPFLAGS="${CPPFLAGS} -I${PCRE_PREFIX}/include"
+ CPPFLAGS="${CPPFLAGS}"
{ echo "$as_me:$LINENO: checking for REG_DOTALL in pcreposix.h" >&5
echo $ECHO_N "checking for REG_DOTALL in pcreposix.h... $ECHO_C" >&6; }
@@ -10076,7 +10076,7 @@
CLAMAV_PREFIX=`clamav-config --prefix`
LIBS="${CLAMAV_LIBS} -lclamav ${LIBS}"
- CPPFLAGS="${CPPFLAGS} -I${CLAMAV_PREFIX}/include"
+ CPPFLAGS="${CPPFLAGS}"
cat >>confdefs.h <<\_ACEOF
@@ -10753,7 +10753,7 @@
if test "${with_libiconv+set}" = set; then
withval=$with_libiconv; # check for header & func (in library) in given prefix

View File

@ -0,0 +1,11 @@
--- dansguardian-2.10/src/IPList.cpp.orig 2008-11-19 07:45:54 +0000
+++ dansguardian-2.10/src/IPList.cpp 2008-11-19 07:46:44 +0000
@@ -81,7 +81,7 @@
hostnames.reset(new std::deque<String>);
hostnames->push_back(*host);
}
- for (std::deque<String>::const_iterator i = hostnames->begin(); i != hostnames->end(); ++i)
+ for (std::deque<String>::iterator i = hostnames->begin(); i != hostnames->end(); ++i)
{
if (std::binary_search(hostlist.begin(), hostlist.end(), *i))
{