[packages] mpd: update to 0.16.1 and refresh patches

git-svn-id: svn://svn.openwrt.org/openwrt/packages@26014 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
loswillios 2011-03-10 16:57:22 +00:00
parent d9815e0188
commit 59af235edb
2 changed files with 17 additions and 18 deletions

View File

@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk include $(TOPDIR)/rules.mk
PKG_NAME:=mpd PKG_NAME:=mpd
PKG_VERSION:=0.15.8 PKG_VERSION:=0.16.1
PKG_RELEASE:=6 PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=@SF/musicpd PKG_SOURCE_URL:=@SF/musicpd
PKG_MD5SUM:=824e1ce46c0f468865d9e5e403cdaf5d PKG_MD5SUM:=4d07459125ab0154c5b4fe364331498a
PKG_INSTALL:=1 PKG_INSTALL:=1
PKG_BUILD_PARALLEL:=1 PKG_BUILD_PARALLEL:=1
@ -74,7 +74,6 @@ CONFIGURE_ARGS += \
--enable-curl \ --enable-curl \
--disable-oss \ --disable-oss \
--with-zeroconf=no \ --with-zeroconf=no \
--disable-libOggFLACtest \
--disable-test \ --disable-test \
--with-tremor=yes \ --with-tremor=yes \
--with-faad="$(STAGING_DIR)/usr" \ --with-faad="$(STAGING_DIR)/usr" \

View File

@ -1,8 +1,8 @@
Index: mpd-0.15.8/configure Index: mpd-0.16.1/configure
=================================================================== ===================================================================
--- mpd-0.15.8.orig/configure 2010-11-04 00:14:37.187000000 +0100 --- mpd-0.16.1.orig/configure 2011-01-10 02:58:36.000000000 +0100
+++ mpd-0.15.8/configure 2010-11-04 00:15:00.156000001 +0100 +++ mpd-0.16.1/configure 2011-03-10 13:01:31.000000000 +0100
@@ -9191,6 +9191,7 @@ @@ -8718,6 +8718,7 @@
# Check whether --with-faad was given. # Check whether --with-faad was given.
if test "${with_faad+set}" = set; then : if test "${with_faad+set}" = set; then :
withval=$with_faad; withval=$with_faad;
@ -10,18 +10,18 @@ Index: mpd-0.15.8/configure
else else
faad_prefix="" faad_prefix=""
fi fi
Index: mpd-0.15.8/src/input/file_input_plugin.c Index: mpd-0.16.1/src/input/file_input_plugin.c
=================================================================== ===================================================================
--- mpd-0.15.8.orig/src/input/file_input_plugin.c 2010-11-04 00:15:41.467000002 +0100 --- mpd-0.16.1.orig/src/input/file_input_plugin.c 2011-01-10 02:58:08.000000000 +0100
+++ mpd-0.15.8/src/input/file_input_plugin.c 2010-11-04 00:15:49.194999211 +0100 +++ mpd-0.16.1/src/input/file_input_plugin.c 2011-03-10 13:02:15.000000000 +0100
@@ -65,10 +65,6 @@ @@ -79,10 +79,6 @@
return false;
is->size = st.st_size; }
-#ifdef POSIX_FADV_SEQUENTIAL -#ifdef POSIX_FADV_SEQUENTIAL
- posix_fadvise(fd, (off_t)0, is->size, POSIX_FADV_SEQUENTIAL); - posix_fadvise(fd, (off_t)0, st.st_size, POSIX_FADV_SEQUENTIAL);
-#endif -#endif
- -
is->plugin = &input_plugin_file; fis = g_new(struct file_input_stream, 1);
is->data = GINT_TO_POINTER(fd); input_stream_init(&fis->base, &input_plugin_file, filename);
is->ready = true;