The attached patch fixes xyssl build on non-linux plaforms -- the original Makefile does recursive calls using 'make' instead of '' thus breaking when make != GNU make. (#3854)

git-svn-id: svn://svn.openwrt.org/openwrt/packages@12234 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
florian 2008-08-07 09:56:54 +00:00
parent bddbca86b6
commit 59e2646d9f

View File

@ -0,0 +1,13 @@
--- xyssl-0.9/Makefile.orig 2008-03-16 15:14:56.000000000 +0100
+++ xyssl-0.9/Makefile 2008-08-06 17:11:20.000000000 +0200
@@ -5,8 +5,8 @@
.SILENT:
all:
- cd library && make all && cd ..
- cd programs && make all && cd ..
+ cd library && $(MAKE) all && cd ..
+ cd programs && $(MAKE) all && cd ..
install:
mkdir -p $(DESTDIR)/include/xyssl