[packages] lsof: update to 4.86
git-svn-id: svn://svn.openwrt.org/openwrt/packages@32153 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
40b1bd9d6b
commit
59f34e71f7
@ -1,5 +1,5 @@
|
|||||||
#
|
#
|
||||||
# Copyright (C) 2007-2010 OpenWrt.org
|
# Copyright (C) 2007-2012 OpenWrt.org
|
||||||
#
|
#
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
# See /LICENSE for more information.
|
# See /LICENSE for more information.
|
||||||
@ -9,14 +9,14 @@ include $(TOPDIR)/rules.mk
|
|||||||
include $(INCLUDE_DIR)/kernel.mk
|
include $(INCLUDE_DIR)/kernel.mk
|
||||||
|
|
||||||
PKG_NAME:=lsof
|
PKG_NAME:=lsof
|
||||||
PKG_VERSION:=4.81
|
PKG_VERSION:=4.86
|
||||||
PKG_RELEASE:=2
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).dfsg.1.orig.tar.gz
|
PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION)+dfsg.orig.tar.gz
|
||||||
PKG_SOURCE_URL:=http://ftp2.de.debian.org/debian/pool/main/l/lsof
|
PKG_SOURCE_URL:=http://ftp2.de.debian.org/debian/pool/main/l/lsof
|
||||||
PKG_MD5SUM:=138b628cb1b6a3b16b32b792f77abcce
|
PKG_MD5SUM:=23420509564a897b76055f9d84d19068
|
||||||
|
|
||||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION).dfsg.1
|
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)+dfsg.orig
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
|
@ -1,7 +1,6 @@
|
|||||||
diff -ru lsof_4.77.orig/lsof_4.77_src/lib/Makefile.skel lsof_4.77/lsof_4.77_src/lib/Makefile.skel
|
--- a/lib/Makefile.skel
|
||||||
--- lsof_4.77.orig/lib/Makefile.skel 2001-02-13 03:12:22.000000000 +0100
|
+++ b/lib/Makefile.skel
|
||||||
+++ lsof_4.77/lib/Makefile.skel 2006-11-29 13:51:44.000000000 +0100
|
@@ -21,8 +21,8 @@ OBJ= ckkv.o cvfs.o dvch.o fino.o isfn.o
|
||||||
@@ -21,8 +21,8 @@
|
|
||||||
all: ${LIB}
|
all: ${LIB}
|
||||||
|
|
||||||
${LIB}: ${OBJ}
|
${LIB}: ${OBJ}
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- lsof_4.77/print.orig.c 2006-08-23 13:37:43.000000000 -0600
|
--- a/print.c
|
||||||
+++ lsof_4.77/print.c 2006-08-23 13:38:29.000000000 -0600
|
+++ b/print.c
|
||||||
@@ -148,6 +148,7 @@
|
@@ -161,6 +161,7 @@ endnm(sz)
|
||||||
static void
|
static void
|
||||||
fill_portmap()
|
fill_portmap()
|
||||||
{
|
{
|
||||||
@ -8,11 +8,11 @@
|
|||||||
char buf[128], *cp, *nm;
|
char buf[128], *cp, *nm;
|
||||||
CLIENT *c;
|
CLIENT *c;
|
||||||
int h, port, pr;
|
int h, port, pr;
|
||||||
@@ -266,6 +267,7 @@
|
@@ -279,6 +280,7 @@ fill_portmap()
|
||||||
Pth[pr][h] = pt;
|
Pth[pr][h] = pt;
|
||||||
}
|
}
|
||||||
clnt_destroy(c);
|
clnt_destroy(c);
|
||||||
+#endif
|
+#endif
|
||||||
}
|
}
|
||||||
|
#endif /* !defined(HASNORPC_H) */
|
||||||
|
|
||||||
|
11
utils/lsof/patches/003-lsof_selinux.patch
Normal file
11
utils/lsof/patches/003-lsof_selinux.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- a/Configure
|
||||||
|
+++ b/Configure
|
||||||
|
@@ -2806,7 +2806,7 @@ return(0); }
|
||||||
|
LSOF_TMP1=1
|
||||||
|
fi # }
|
||||||
|
fi # }
|
||||||
|
- if test $LSOF_TMP1 -eq 1 # {
|
||||||
|
+ if 0 -eq 1 # {
|
||||||
|
then
|
||||||
|
LSOF_CFGF="$LSOF_CFGF -DHASSELINUX"
|
||||||
|
LSOF_CFGL="$LSOF_CFGL -lselinux"
|
@ -1,12 +0,0 @@
|
|||||||
diff -ru lsof_4.77.orig/lsof_4.77_src/dialects/linux/dlsof.h lsof_4.77/lsof_4.77_src/dialects/linux/dlsof.h
|
|
||||||
--- lsof_4.77.orig/dialects/linux/dlsof.h 2006-03-28 00:57:14.000000000 +0200
|
|
||||||
+++ lsof_4.77/dialects/linux/dlsof.h 2006-11-29 14:03:07.000000000 +0100
|
|
||||||
@@ -49,7 +49,7 @@
|
|
||||||
#include <unistd.h>
|
|
||||||
#include <netinet/in.h>
|
|
||||||
|
|
||||||
-# if defined(GLIBCV)
|
|
||||||
+# if defined(GLIBCV) || defined __UCLIBC__
|
|
||||||
#include <netinet/tcp.h>
|
|
||||||
# else /* !defined(GLIBCV) */
|
|
||||||
#include <linux/tcp.h>
|
|
@ -1,6 +1,6 @@
|
|||||||
--- a/Configure
|
--- a/Configure
|
||||||
+++ b/Configure
|
+++ b/Configure
|
||||||
@@ -2547,6 +2547,9 @@
|
@@ -2682,6 +2682,9 @@ LOCKF_OWNER4
|
||||||
if test "X$LSOF_CC" = "X" # {
|
if test "X$LSOF_CC" = "X" # {
|
||||||
then
|
then
|
||||||
LSOF_CC=cc
|
LSOF_CC=cc
|
||||||
@ -9,4 +9,4 @@
|
|||||||
+ then
|
+ then
|
||||||
LSOF_CCV=`$LSOF_CC -v 2>&1 | sed -n 's/.*version \(.*\)/\1/p'`
|
LSOF_CCV=`$LSOF_CC -v 2>&1 | sed -n 's/.*version \(.*\)/\1/p'`
|
||||||
fi # }
|
fi # }
|
||||||
LSOF_DIALECT_DIR=""
|
if test "X$LINUX_CONF_CC" = "X" # {
|
@ -1,12 +0,0 @@
|
|||||||
diff -Naur lsof-4.81.dfsg.1.orig/Configure lsof-4.81.dfsg.1/Configure
|
|
||||||
--- lsof-4.81.dfsg.1.orig/Configure 2009-04-20 03:03:28.863704499 -0400
|
|
||||||
+++ lsof-4.81.dfsg.1/Configure 2009-04-20 03:05:58.467696265 -0400
|
|
||||||
@@ -2646,7 +2646,7 @@
|
|
||||||
LSOF_TMP1=1
|
|
||||||
fi # }
|
|
||||||
fi # }
|
|
||||||
- if test $LSOF_TMP1 -eq 1 # {
|
|
||||||
+ if 0 -eq 1 # {
|
|
||||||
then
|
|
||||||
LSOF_CFGF="$LSOF_CFGF -DHASSELINUX"
|
|
||||||
LSOF_CFGL="$LSOF_CFGL -lselinux"
|
|
Loading…
x
Reference in New Issue
Block a user