add package <gtkhtml> - library to render HTML within GTK

git-svn-id: svn://svn.openwrt.org/openwrt/packages@18407 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
mirko 2009-11-12 20:13:41 +00:00
parent 5f2406021e
commit 5a9a2a8504
2 changed files with 112 additions and 0 deletions

79
Xorg/lib/gtkhtml/Makefile Normal file
View File

@ -0,0 +1,79 @@
#
# Copyright (C) 2008 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
PKG_NAME:=gtkhtml
PKG_RELEASE:=1
PKG_VERSION:=3.29.1
PKG_SOURCE_URL:=@GNOME/$(PKG_NAME)/3.29
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
include $(INCLUDE_DIR)/package.mk
PKG_INSTALL:=1
define Package/gtkhtml
SECTION:=xorg-app
CATEGORY:=Xorg
SUBMENU:=app
DEPENDS:=+gtk2 +libgconf2 +gnome-icon-theme
TITLE:=gtkhtml
URL:=http://www.gnome.org/projects/gtkhtml/
endef
TARGET_CFLAGS+=\
-I$(STAGING_DIR)/usr/lib/libintl/include/ \
-I$(STAGING_DIR)/usr/lib/libiconv/include/
TARGET_LDFLAGS+=\
-Wl,-rpath-link=$(STAGING_DIR)/usr/lib \
-L$(STAGING_DIR)/usr/lib/libintl/lib/ \
-L$(STAGING_DIR)/usr/lib/libiconv/lib/
define Build/Configure
$(call Build/Configure/Default, \
--enable-shared \
--enable-static \
--disable-shlib-factory \
);
endef
define Build/InstallDev
$(INSTALL_DIR) \
$(1)/usr/lib/pkgconfig \
$(1)/usr/include \
$(1)/usr/lib
$(CP) \
$(PKG_INSTALL_DIR)/usr/lib/*.{la,a,so*} \
$(1)/usr/lib/
$(CP) \
$(PKG_INSTALL_DIR)/usr/include/* \
$(1)/usr/include/
$(CP) \
$(PKG_INSTALL_DIR)/usr/lib/pkgconfig/* \
$(1)/usr/lib/pkgconfig/
endef
define Package/gtkhtml/install
$(INSTALL_DIR) \
$(1)/usr/share \
$(1)/usr/lib
$(CP) \
$(PKG_INSTALL_DIR)/usr/lib/*.so* \
$(1)/usr/lib/
$(CP) \
$(PKG_INSTALL_DIR)/usr/share/gtkhtml* \
$(1)/usr/share/
endef
$(eval $(call BuildPackage,gtkhtml))

View File

@ -0,0 +1,33 @@
diff -ruN gtkhtml-3.29.1/components/Makefile.am gtkhtml-3.29.1.mod/components/Makefile.am
--- gtkhtml-3.29.1/components/Makefile.am 2009-10-23 12:25:35.000000000 +0200
+++ gtkhtml-3.29.1.mod/components/Makefile.am 2009-10-30 18:33:25.000000000 +0100
@@ -1,4 +1,4 @@
-SUBDIRS = editor
+SUBDIRS =
-include $(top_srcdir)/git.mk
diff -ruN gtkhtml-3.29.1/components/Makefile.in gtkhtml-3.29.1.mod/components/Makefile.in
--- gtkhtml-3.29.1/components/Makefile.in 2009-10-26 09:22:21.000000000 +0100
+++ gtkhtml-3.29.1.mod/components/Makefile.in 2009-10-30 18:32:41.000000000 +0100
@@ -265,7 +265,7 @@
top_build_prefix = @top_build_prefix@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
-SUBDIRS = editor
+SUBDIRS =
all: all-recursive
.SUFFIXES:
diff -ruN gtkhtml-3.29.1/configure gtkhtml-3.29.1.mod/configure
--- gtkhtml-3.29.1/configure 2009-10-26 09:22:19.000000000 +0100
+++ gtkhtml-3.29.1.mod/configure 2009-10-30 18:39:32.000000000 +0100
@@ -21911,7 +21911,7 @@
-GTKHTML_MODULES="gtk+-2.0 >= 2.16.0 enchant gconf-2.0 iso-codes"
+GTKHTML_MODULES="gtk+-2.0 >= 2.16.0 gconf-2.0"
pkg_failed=no
{ $as_echo "$as_me:$LINENO: checking for GTKHTML" >&5