move fluxbox from rc to full release and fix dependency bug

git-svn-id: svn://svn.openwrt.org/openwrt/packages@10065 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
blogic 2007-12-30 20:10:55 +00:00
parent 4f40e8f46e
commit 5c0aa3dc6e
2 changed files with 13 additions and 13 deletions

View File

@ -9,18 +9,18 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=fluxbox
PKG_VERSION:=1.0rc3
PKG_VERSION:=1.0.0
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://prdownloads.sourceforge.net/fluxbox/
PKG_SOURCE_URL:=http://switch.dl.sourceforge.net/sourceforge/fluxbox/
EXTRA_LDFLAGS:="-Wl,-rpath-link=$(STAGING_DIR)/usr/lib"
include $(INCLUDE_DIR)/package.mk
CONFIGURE_VARS+=LIBS="-nodefaultlibs -luClibc++ -Wl,-Bstatic,-lstdc++,-Bdynamic -lm" \
CXXLD="$(TARGET_CC)"
CONFIGURE_VARS+=LIBS="-nodefaultlibs -luClibc++ -Wl,-Bstatic,-lstdc++,-Bdynamic -lm -lImlib2" \
CXXLD="$(TARGET_CC)"
CONFIGURE_ARGS+=--disable-xmb
@ -31,7 +31,7 @@ endef
define Package/fluxbox
$(call Package/fluxbox/Default)
DEPENDS:=+xorg-server-essentials +uclibcxx +xterm @DISPLAY_SUPPORT
DEPENDS:=+xorg-server-essentials +uclibcxx +xterm +imlib2 @DISPLAY_SUPPORT
TITLE:=fluxbox window manager
MENU:=1
endef

View File

@ -1,12 +1,12 @@
diff -urN fluxbox-1.0rc3.orig/util/Makefile.in fluxbox-1.0rc3/util/Makefile.in
--- fluxbox-1.0rc3.orig/util/Makefile.in 2007-09-17 19:56:45.000000000 +0200
+++ fluxbox-1.0rc3/util/Makefile.in 2007-09-17 19:58:11.000000000 +0200
@@ -301,7 +301,7 @@
done
diff -urN fluxbox-1.0.0.orig/util/Makefile.in fluxbox-1.0.0/util/Makefile.in
--- fluxbox-1.0.0.orig/util/Makefile.in 2007-12-30 18:54:47.000000000 +0100
+++ fluxbox-1.0.0/util/Makefile.in 2007-12-30 18:55:41.000000000 +0100
@@ -276,7 +276,7 @@
-test -z "$(bin_PROGRAMS)" || rm -f $(bin_PROGRAMS)
fbsetroot$(EXEEXT): $(fbsetroot_OBJECTS) $(fbsetroot_DEPENDENCIES)
@rm -f fbsetroot$(EXEEXT)
- $(CXXLINK) $(fbsetroot_OBJECTS) $(fbsetroot_LDADD) $(LIBS)
+ $(CXXLD) $(AM_CXXFLAGS) $(CXXFLAGS) $(AM_LDFLAGS) -o $@ $(fbsetroot_OBJECTS) $(fbsetroot_LDADD) $(LDFLAGS) $(LIBS)
fluxbox-update_configs$(EXEEXT): $(fluxbox_update_configs_OBJECTS) $(fluxbox_update_configs_DEPENDENCIES)
@rm -f fluxbox-update_configs$(EXEEXT)
$(CXXLINK) $(fluxbox_update_configs_OBJECTS) $(fluxbox_update_configs_LDADD) $(LIBS)
fluxbox-remote$(EXEEXT): $(fluxbox_remote_OBJECTS) $(fluxbox_remote_DEPENDENCIES)
@rm -f fluxbox-remote$(EXEEXT)
$(CXXLINK) $(fluxbox_remote_OBJECTS) $(fluxbox_remote_LDADD) $(LIBS)