Add unfs3
git-svn-id: svn://svn.openwrt.org/openwrt/packages@8210 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
8609ffe709
commit
5c2a511f0e
43
net/unfs3/Makefile
Normal file
43
net/unfs3/Makefile
Normal file
@ -0,0 +1,43 @@
|
|||||||
|
#
|
||||||
|
# Copyright (C) 2006 OpenWrt.org
|
||||||
|
#
|
||||||
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
|
# See /LICENSE for more information.
|
||||||
|
#
|
||||||
|
# $Id$
|
||||||
|
|
||||||
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
|
PKG_NAME:=unfs3
|
||||||
|
PKG_VERSION:=0.9.17
|
||||||
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
|
PKG_SOURCE_URL:=@SF/$(PKG_NAME)
|
||||||
|
PKG_MD5SUM:=cde90d604ef42d8ab0c82ed501179417
|
||||||
|
|
||||||
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
|
define Package/unfs3
|
||||||
|
SECTION:=net
|
||||||
|
CATEGORY:=Network
|
||||||
|
DEPENDS:=+portmap
|
||||||
|
TITLE:=User-space NFSv3 Server
|
||||||
|
DESCRIPTION:=\
|
||||||
|
UNFS3 is a user-space implementation of the NFSv3 server \\\
|
||||||
|
specification. It provides a daemon for the MOUNT and NFS \\\
|
||||||
|
protocols, which are used by NFS clients for accessing files \\\
|
||||||
|
on the server.
|
||||||
|
URL:=http://unfs3.sourceforge.net/
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/unfs3/install
|
||||||
|
$(INSTALL_DIR) $(1)/etc/init.d
|
||||||
|
$(INSTALL_BIN) ./files/$(PKG_NAME).init $(1)/etc/init.d/$(PKG_NAME)
|
||||||
|
$(INSTALL_DIR) $(1)/etc
|
||||||
|
$(INSTALL_DATA) ./files/$(PKG_NAME).exports $(1)/etc/exports
|
||||||
|
$(INSTALL_DIR) $(1)/usr/sbin
|
||||||
|
$(INSTALL_BIN) $(PKG_BUILD_DIR)/unfsd $(1)/usr/sbin
|
||||||
|
endef
|
||||||
|
|
||||||
|
$(eval $(call BuildPackage,unfs3))
|
1
net/unfs3/files/unfs3.exports
Normal file
1
net/unfs3/files/unfs3.exports
Normal file
@ -0,0 +1 @@
|
|||||||
|
/mnt (ro,all_squash,insecure)
|
17
net/unfs3/files/unfs3.init
Normal file
17
net/unfs3/files/unfs3.init
Normal file
@ -0,0 +1,17 @@
|
|||||||
|
#!/bin/sh /etc/rc.common
|
||||||
|
# Copyright (C) 2006 OpenWrt.org
|
||||||
|
START=50
|
||||||
|
|
||||||
|
start() {
|
||||||
|
/usr/sbin/unfsd
|
||||||
|
}
|
||||||
|
|
||||||
|
stop() {
|
||||||
|
killall unfsd
|
||||||
|
}
|
||||||
|
|
||||||
|
restart() {
|
||||||
|
stop
|
||||||
|
sleep 1
|
||||||
|
start
|
||||||
|
}
|
49
net/unfs3/patches/100-no_lfl.patch
Normal file
49
net/unfs3/patches/100-no_lfl.patch
Normal file
@ -0,0 +1,49 @@
|
|||||||
|
Index: unfs3-0.9.17/Makefile.in
|
||||||
|
===================================================================
|
||||||
|
--- unfs3-0.9.17.orig/Makefile.in 2007-07-28 22:40:02.000000000 +0200
|
||||||
|
+++ unfs3-0.9.17/Makefile.in 2007-07-28 22:40:02.000000000 +0200
|
||||||
|
@@ -11,7 +11,7 @@
|
||||||
|
md5.o mount.o nfs.o password.o readdir.o user.o xdr.o winsupport.o
|
||||||
|
CONFOBJ = Config/lib.a
|
||||||
|
EXTRAOBJ = @EXTRAOBJ@
|
||||||
|
-LDFLAGS = @LDFLAGS@ @LIBS@ @LEXLIB@
|
||||||
|
+LDFLAGS = @LDFLAGS@ @LIBS@
|
||||||
|
EXEEXT = @EXEEXT@
|
||||||
|
|
||||||
|
prefix = @prefix@
|
||||||
|
Index: unfs3-0.9.17/configure
|
||||||
|
===================================================================
|
||||||
|
--- unfs3-0.9.17.orig/configure 2007-07-28 22:40:02.000000000 +0200
|
||||||
|
+++ unfs3-0.9.17/configure 2007-07-28 22:40:02.000000000 +0200
|
||||||
|
@@ -2122,7 +2122,7 @@
|
||||||
|
echo $ECHO_N "(cached) $ECHO_C" >&6
|
||||||
|
else
|
||||||
|
ac_check_lib_save_LIBS=$LIBS
|
||||||
|
-LIBS="-lfl $LIBS"
|
||||||
|
+LIBS="$LIBS"
|
||||||
|
cat >conftest.$ac_ext <<_ACEOF
|
||||||
|
/* confdefs.h. */
|
||||||
|
_ACEOF
|
||||||
|
Index: unfs3-0.9.17/Config/lex.yy.c
|
||||||
|
===================================================================
|
||||||
|
--- unfs3-0.9.17.orig/Config/lex.yy.c 2007-07-28 22:40:21.000000000 +0200
|
||||||
|
+++ unfs3-0.9.17/Config/lex.yy.c 2007-07-28 22:40:56.000000000 +0200
|
||||||
|
@@ -442,9 +442,15 @@
|
||||||
|
|
||||||
|
#ifndef YY_SKIP_YYWRAP
|
||||||
|
#ifdef __cplusplus
|
||||||
|
-extern "C" int yywrap YY_PROTO(( void ));
|
||||||
|
-#else
|
||||||
|
-extern int yywrap YY_PROTO(( void ));
|
||||||
|
+/* extern "C" int yywrap YY_PROTO(( void )); */
|
||||||
|
+int yywrap (void ) {
|
||||||
|
+ return 1;
|
||||||
|
+}
|
||||||
|
+#else
|
||||||
|
+/* extern int yywrap YY_PROTO(( void )); */
|
||||||
|
+int yywrap (void ) {
|
||||||
|
+ return 1;
|
||||||
|
+}
|
||||||
|
#endif
|
||||||
|
#endif
|
||||||
|
|
Loading…
x
Reference in New Issue
Block a user