[packages] rtorrent: update to 0.8.6_r1130 (#6685)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@19651 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
5f05a363e8
commit
5c992a98e5
@ -1,5 +1,5 @@
|
||||
#
|
||||
# Copyright (C) 2007-2009 OpenWrt.org
|
||||
# Copyright (C) 2007-2010 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
@ -9,17 +9,18 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=rtorrent
|
||||
|
||||
PKG_REV:=1123
|
||||
PKG_REV:=1130
|
||||
PKG_VERSION:=0.8.6_r$(PKG_REV)
|
||||
PKG_RELEASE:=2
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=svn://rakshasa.no/libtorrent/trunk/rtorrent
|
||||
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_SOURCE_VERSION:=$(PKG_REV)
|
||||
PKG_SOURCE_PROTO:=svn
|
||||
|
||||
PKG_FIXUP = libtool
|
||||
PKG_FIXUP:=libtool
|
||||
PKG_INSTALL:=1
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
@ -29,7 +30,7 @@ define Package/rtorrent
|
||||
CATEGORY:=Network
|
||||
TITLE:=BitTorrent client for ncurses
|
||||
URL:=http://libtorrent.rakshasa.no/
|
||||
DEPENDS:=+libcurl +libtorrent +libncurses +libsigcxx +xmlrpc-c
|
||||
DEPENDS:=+libcurl +libtorrent +libncurses +libsigcxx +xmlrpc-c +libpthread
|
||||
endef
|
||||
|
||||
define Package/rtorrent/description
|
||||
@ -43,6 +44,8 @@ ifneq ($(CONFIG_GCC_VERSION_3_4)$(CONFIG_GCC_VERSION_4_1),)
|
||||
TARGET_CPPFLAGS += -fno-strict-aliasing
|
||||
endif
|
||||
|
||||
TARGET_LDFLAGS += -lpthread
|
||||
|
||||
CONFIGURE_ARGS+= \
|
||||
--enable-shared \
|
||||
--disable-static \
|
||||
@ -54,15 +57,9 @@ define Build/Configure
|
||||
$(call Build/Configure/Default)
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||
all install
|
||||
endef
|
||||
|
||||
define Package/rtorrent/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/bin/rtorrent $(1)/usr/bin/
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/rtorrent $(1)/usr/bin/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,rtorrent))
|
||||
|
@ -1,7 +1,6 @@
|
||||
diff -durN a/scripts/common.m4 b/scripts/common.m4
|
||||
--- a/scripts/common.m4 2009-11-13 10:44:23.000000000 +0300
|
||||
+++ b/scripts/common.m4 2009-11-05 11:20:35.000000000 +0300
|
||||
@@ -184,7 +183,7 @@
|
||||
--- a/scripts/common.m4
|
||||
+++ b/scripts/common.m4
|
||||
@@ -209,7 +209,7 @@ dnl Need to fix this so that it uses t
|
||||
AC_DEFUN([TORRENT_CHECK_EXECINFO], [
|
||||
AC_MSG_CHECKING(for execinfo.h)
|
||||
|
||||
|
@ -1,8 +1,14 @@
|
||||
Index: rtorrent/rak/allocators.h
|
||||
===================================================================
|
||||
--- rtorrent/rak/allocators.h (revision 1121)
|
||||
+++ rtorrent/rak/allocators.h (working copy)
|
||||
@@ -74,17 +74,13 @@
|
||||
--- a/rak/allocators.h
|
||||
+++ b/rak/allocators.h
|
||||
@@ -42,6 +42,7 @@
|
||||
#include <cstddef>
|
||||
#include <limits>
|
||||
#include <stdlib.h>
|
||||
+#include <stdint.h>
|
||||
#include <sys/types.h>
|
||||
|
||||
namespace rak {
|
||||
@@ -74,17 +75,13 @@ public:
|
||||
size_type max_size () const throw() { return std::numeric_limits<size_t>::max() / sizeof(T); }
|
||||
|
||||
pointer allocate(size_type num, const_void_pointer hint = 0) { return alloc_size(num*sizeof(T)); }
|
||||
@ -11,19 +17,19 @@ Index: rtorrent/rak/allocators.h
|
||||
- static pointer alloc_size(size_type size) {
|
||||
- pointer ptr = NULL;
|
||||
- int __UNUSED result = posix_memalign((void**)&ptr, LT_SMP_CACHE_BYTES, size);
|
||||
-
|
||||
- return ptr;
|
||||
- }
|
||||
+ static pointer alloc_size(size_type size);
|
||||
+ static void dealloc_size(pointer p, size_type size);
|
||||
|
||||
- return ptr;
|
||||
- }
|
||||
-
|
||||
void construct (pointer p, const T& value) { new((void*)p)T(value); }
|
||||
void destroy (pointer p) { p->~T(); }
|
||||
- void deallocate (pointer p, size_type num) { ::operator delete((void*)p); }
|
||||
};
|
||||
|
||||
|
||||
@@ -98,8 +94,38 @@
|
||||
@@ -98,6 +95,36 @@ bool operator!= (const cacheline_allocat
|
||||
return false;
|
||||
}
|
||||
|
||||
@ -46,8 +52,8 @@ Index: rtorrent/rak/allocators.h
|
||||
+#endif
|
||||
+
|
||||
+ return ptr;
|
||||
}
|
||||
|
||||
+}
|
||||
+
|
||||
+template <class T>
|
||||
+inline void cacheline_allocator<T>::dealloc_size(pointer p, size_type size) {
|
||||
+#if HAVE_POSIX_MEMALIGN
|
||||
@ -57,8 +63,6 @@ Index: rtorrent/rak/allocators.h
|
||||
+#endif
|
||||
+}
|
||||
+
|
||||
+}
|
||||
+
|
||||
//
|
||||
// Operator new with custom allocators:
|
||||
}
|
||||
|
||||
//
|
||||
|
@ -1,9 +0,0 @@
|
||||
--- a/src/thread_base.cc 2010-01-26 09:40:34.000000000 +0300
|
||||
+++ b/src/thread_base.cc 2010-01-31 18:38:25.000000000 +0300
|
||||
@@ -191,5 +191,5 @@
|
||||
void
|
||||
ThreadBase::queue_item(thread_base_func newFunc) {
|
||||
m_threadQueue->push_back(newFunc);
|
||||
- pthread_kill(m_thread, SIGUSR1);
|
||||
+ if(m_thread != NULL) pthread_kill(m_thread, SIGUSR1);
|
||||
}
|
Loading…
x
Reference in New Issue
Block a user