[package] tinyproxy: fix creation of pid and log (#7641)

git-svn-id: svn://svn.openwrt.org/openwrt/packages@22431 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
florian 2010-07-31 11:39:13 +00:00
parent 3f072dbc06
commit 5cf435ad03
2 changed files with 16 additions and 1 deletions

View File

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=tinyproxy
PKG_VERSION:=1.8.1
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.banu.com/pub/tinyproxy/1.8/

View File

@ -0,0 +1,15 @@
diff -Nur a/src/main.c b/src/main.c
--- a/src/main.c 2010-07-17 11:57:25.000000000 +0200
+++ b/src/main.c 2010-07-17 11:58:52.000000000 +0200
@@ -326,8 +326,8 @@
conf->errorpages = NULL;
conf->stathost = safestrdup (TINYPROXY_STATHOST);
conf->idletimeout = MAX_IDLE_TIME;
- conf->logf_name = safestrdup (LOCALSTATEDIR "/log/tinyproxy/tinyproxy.log");
- conf->pidpath = safestrdup (LOCALSTATEDIR "/run/tinyproxy/tinyproxy.pid");
+ conf->logf_name = safestrdup (LOCALSTATEDIR "/log/tinyproxy.log");
+ conf->pidpath = safestrdup (LOCALSTATEDIR "/tinyproxy.pid");
}
/**